aboutsummaryrefslogtreecommitdiff
path: root/security/py-scp/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-04-05 03:32:06 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-04-05 03:32:06 +0000
commit3476a93d19000397b5226d8d6e05d73428609ec5 (patch)
treeea0d0a7c69d929963a66e289028443f4e4b9a2e8 /security/py-scp/Makefile
parent7c9040518028f43cb606b557fa48d110cd3d5b0c (diff)
downloadports-3476a93d19000397b5226d8d6e05d73428609ec5.tar.gz
ports-3476a93d19000397b5226d8d6e05d73428609ec5.zip
New port: security/py-scp: Scp module for paramiko
PR: 224423 Submitted by: Sergey Akhmatov <sergey@akhmatov.ru>
Notes
Notes: svn path=/head/; revision=466526
Diffstat (limited to 'security/py-scp/Makefile')
-rw-r--r--security/py-scp/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/security/py-scp/Makefile b/security/py-scp/Makefile
new file mode 100644
index 000000000000..c76df00ce1e7
--- /dev/null
+++ b/security/py-scp/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= scp
+DISTVERSION= 0.10.2
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sergey@akhmatov.ru
+COMMENT= Scp module for paramiko
+
+LICENSE= LGPL21+
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}paramiko>0:security/py-paramiko@${FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>