aboutsummaryrefslogtreecommitdiff
path: root/security/py-sshpubkeys
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-11-06 11:12:02 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-11-06 11:12:02 +0000
commitcbcbe4f066748bd25509d8349a96a84d9391f1e1 (patch)
tree1195355fd6f0526fd6efdf126cc5d9cca38c121f /security/py-sshpubkeys
parentbfd638fbb3b3bacc4cc9548ffe8cffbc51d13c27 (diff)
downloadports-cbcbe4f066748bd25509d8349a96a84d9391f1e1.tar.gz
ports-cbcbe4f066748bd25509d8349a96a84d9391f1e1.zip
Add py-sshpubkeys 3.1.0
sshpubkeys provides a native implementation for validating OpenSSH public keys. WWW: https://github.com/ojarva/python-sshpubkeys
Notes
Notes: svn path=/head/; revision=554186
Diffstat (limited to 'security/py-sshpubkeys')
-rw-r--r--security/py-sshpubkeys/Makefile23
-rw-r--r--security/py-sshpubkeys/distinfo3
-rw-r--r--security/py-sshpubkeys/pkg-descr3
3 files changed, 29 insertions, 0 deletions
diff --git a/security/py-sshpubkeys/Makefile b/security/py-sshpubkeys/Makefile
new file mode 100644
index 000000000000..808148469350
--- /dev/null
+++ b/security/py-sshpubkeys/Makefile
@@ -0,0 +1,23 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= sshpubkeys
+PORTVERSION= 3.1.0
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= SSH public key parser
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>=2.1.4:security/py-cryptography@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}ecdsa>=0.13:security/py-ecdsa@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/security/py-sshpubkeys/distinfo b/security/py-sshpubkeys/distinfo
new file mode 100644
index 000000000000..2275bb2f1d93
--- /dev/null
+++ b/security/py-sshpubkeys/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1604480700
+SHA256 (sshpubkeys-3.1.0.tar.gz) = b388399caeeccdc145f06fd0d2665eeecc545385c60b55c282a15a022215af80
+SIZE (sshpubkeys-3.1.0.tar.gz) = 10597
diff --git a/security/py-sshpubkeys/pkg-descr b/security/py-sshpubkeys/pkg-descr
new file mode 100644
index 000000000000..f9243620f545
--- /dev/null
+++ b/security/py-sshpubkeys/pkg-descr
@@ -0,0 +1,3 @@
+sshpubkeys provides a native implementation for validating OpenSSH public keys.
+
+WWW: https://github.com/ojarva/python-sshpubkeys