aboutsummaryrefslogtreecommitdiff
path: root/security/py-taxii2-client
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2019-02-20 12:22:42 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2019-02-20 12:22:42 +0000
commit63be7bf69dd67de5fb7e1d4f408d2b9c67e06d97 (patch)
tree9aca1822edf4262142dbb74ed94143cca6a18189 /security/py-taxii2-client
parentc6ed38e2b3378cad4cf48ac59e6f2811aa501173 (diff)
downloadports-63be7bf69dd67de5fb7e1d4f408d2b9c67e06d97.tar.gz
ports-63be7bf69dd67de5fb7e1d4f408d2b9c67e06d97.zip
New port: security/py-taxii2-client
This port provides a minimal client implementation for the TAXII 2.0 server. It supports the following TAXII 2.0 API services: - Server Discovery - Get API Root Information - Get Status - Get Collections - Get a Collection - Get Objects - Add Objects - Get an Object - Get Object Manifests WWW: https://github.com/oasis-open/cti-taxii-client
Notes
Notes: svn path=/head/; revision=493421
Diffstat (limited to 'security/py-taxii2-client')
-rw-r--r--security/py-taxii2-client/Makefile34
-rw-r--r--security/py-taxii2-client/distinfo3
-rw-r--r--security/py-taxii2-client/pkg-descr13
3 files changed, 50 insertions, 0 deletions
diff --git a/security/py-taxii2-client/Makefile b/security/py-taxii2-client/Makefile
new file mode 100644
index 000000000000..a4a8dbe61328
--- /dev/null
+++ b/security/py-taxii2-client/Makefile
@@ -0,0 +1,34 @@
+# $FreeBSD$
+
+PORTNAME= taxii2-client
+PORTVERSION= 0.5.0
+DISTVERSIONPREFIX= v
+CATEGORIES= security python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= antoine@FreeBSD.org
+COMMENT= Minimal client implementation for the TAXII 2.0 server
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytz>=0:devel/py-pytz@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}coverage>=0:devel/py-coverage@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-cov>=0:devel/py-pytest-cov@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}responses>=0:devel/py-responses@${PY_FLAVOR}
+
+USE_GITHUB= yes
+GH_ACCOUNT= oasis-open
+GH_PROJECT= cti-taxii-client
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+DO_MAKE_TEST= ${SETENV} ${TEST_ENV} pytest-${PYTHON_VER} --cov=taxii2client taxii2client/test/ --cov-report term-missing
+TEST_TARGET= # empty
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/security/py-taxii2-client/distinfo b/security/py-taxii2-client/distinfo
new file mode 100644
index 000000000000..5fea2451d20e
--- /dev/null
+++ b/security/py-taxii2-client/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1550499376
+SHA256 (oasis-open-cti-taxii-client-v0.5.0_GH0.tar.gz) = d34869b04ae6bec84e765dc583ff3f837be6818905721131112814e22d97d8e9
+SIZE (oasis-open-cti-taxii-client-v0.5.0_GH0.tar.gz) = 25244
diff --git a/security/py-taxii2-client/pkg-descr b/security/py-taxii2-client/pkg-descr
new file mode 100644
index 000000000000..c479f99c05cf
--- /dev/null
+++ b/security/py-taxii2-client/pkg-descr
@@ -0,0 +1,13 @@
+This port provides a minimal client implementation for the TAXII 2.0 server.
+It supports the following TAXII 2.0 API services:
+- Server Discovery
+- Get API Root Information
+- Get Status
+- Get Collections
+- Get a Collection
+- Get Objects
+- Add Objects
+- Get an Object
+- Get Object Manifests
+
+WWW: https://github.com/oasis-open/cti-taxii-client