aboutsummaryrefslogtreecommitdiff
path: root/security/py-webauthn/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-11-15 17:55:59 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-11-15 17:55:59 +0000
commitd84e8051296d738aa0cd4031c0534bd33702d4b1 (patch)
tree1404109ce784e3a71f746ead345e5a2bf394cf05 /security/py-webauthn/Makefile
parente4615bb32b5dc7d048ac324c6ea14f7028caa141 (diff)
downloadports-d84e8051296d738aa0cd4031c0534bd33702d4b1.tar.gz
ports-d84e8051296d738aa0cd4031c0534bd33702d4b1.zip
Add py-webauthn 0.4.7
PyWebAuthn is a Python module which can be used to handle WebAuthn registration and assertion. Currently, WebAuthn is supported in Firefox, Chrome, and Edge. WWW: https://github.com/duo-labs/py_webauthn
Notes
Notes: svn path=/head/; revision=555252
Diffstat (limited to 'security/py-webauthn/Makefile')
-rw-r--r--security/py-webauthn/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/security/py-webauthn/Makefile b/security/py-webauthn/Makefile
new file mode 100644
index 000000000000..5c4ce0bf9487
--- /dev/null
+++ b/security/py-webauthn/Makefile
@@ -0,0 +1,30 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= webauthn
+PORTVERSION= 0.4.7
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= WebAuthn Python module
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cbor2>=4.0.1:devel/py-cbor2@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cryptography>=2.3.1:security/py-cryptography@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}future>=0.17.1:devel/py-future@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}openssl>=16.0.0:security/py-openssl@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.11.0:devel/py-six@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+do-test:
+ cd ${WRKSRC} && ${PYTHON_CMD} -m unittest
+
+.include <bsd.port.mk>