aboutsummaryrefslogtreecommitdiff
path: root/security/py3-cryptography
diff options
context:
space:
mode:
authorBen Woods <woodsb02@FreeBSD.org>2017-06-07 14:22:58 +0000
committerBen Woods <woodsb02@FreeBSD.org>2017-06-07 14:22:58 +0000
commit4a867a7af6db3ff1381bff737d1f8dbf2eefea52 (patch)
tree87ea72f57f03bb80f7c6dc2a700c19fc6c01181e /security/py3-cryptography
parent7ae9a804fd8b8a7dfc7488fa23aec5ec5762291b (diff)
downloadports-4a867a7af6db3ff1381bff737d1f8dbf2eefea52.tar.gz
ports-4a867a7af6db3ff1381bff737d1f8dbf2eefea52.zip
[NEW] security/py3-cryptography: Create Python 3.x version of port
The latest www/py-requests update [1] unbundled its dependencies, now requiring chardet, idna, urllib3 and certifi from ports. www/py3-requests port was not tested during QA, which would have highlighted the need for many new py3-* ports (and their dependencies). This change creates one of those ports. [1] https://svnweb.freebsd.org/changeset/ports/442565 PR: 219833
Notes
Notes: svn path=/head/; revision=442838
Diffstat (limited to 'security/py3-cryptography')
-rw-r--r--security/py3-cryptography/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/security/py3-cryptography/Makefile b/security/py3-cryptography/Makefile
new file mode 100644
index 000000000000..304d0577da67
--- /dev/null
+++ b/security/py3-cryptography/Makefile
@@ -0,0 +1,14 @@
+# Created by: Philip Paeps <philip@FreeBSD.org>
+# $FreeBSD$
+
+MASTERDIR= ${.CURDIR}/../py-cryptography
+
+BUILD_DEPENDS?= ${PYTHON_PKGNAMEPREFIX}cffi>=1.4.1:devel/py3-cffi
+RUN_DEPENDS?= ${PYTHON_PKGNAMEPREFIX}six>=1.4.1:devel/py3-six \
+ ${PYTHON_PKGNAMEPREFIX}pyasn1>=0.1.8:devel/py3-pyasn1 \
+ ${PYTHON_PKGNAMEPREFIX}cffi>=1.1.0:devel/py3-cffi \
+ ${PYTHON_PKGNAMEPREFIX}idna>=2.0:dns/py3-idna
+
+USES= python:3.3+ ssl
+
+.include "${MASTERDIR}/Makefile"