aboutsummaryrefslogtreecommitdiff
path: root/security/py3-openssl
diff options
context:
space:
mode:
authorBen Woods <woodsb02@FreeBSD.org>2017-06-07 14:32:40 +0000
committerBen Woods <woodsb02@FreeBSD.org>2017-06-07 14:32:40 +0000
commit0463f581a85a01e42e198bb1b33e35bf754c0095 (patch)
treeea20cc7d033ff05d9337ce41c1bc794ba4748978 /security/py3-openssl
parent2657f937123ffe028467f992b8da8e7d7c562a98 (diff)
downloadports-0463f581a85a01e42e198bb1b33e35bf754c0095.tar.gz
ports-0463f581a85a01e42e198bb1b33e35bf754c0095.zip
[NEW] security/py3-openssl: Create Python 3.x version of port
The latest www/py-requests update [1] unbundled its dependencies, now requiring chardet, idna, urllib3 and certifi from ports. www/py3-requests port was not tested during QA, which would have highlighted the need for many new py3-* ports (and their dependencies). This change creates one of those ports. [1] https://svnweb.freebsd.org/changeset/ports/442565 PR: 219833
Notes
Notes: svn path=/head/; revision=442841
Diffstat (limited to 'security/py3-openssl')
-rw-r--r--security/py3-openssl/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/security/py3-openssl/Makefile b/security/py3-openssl/Makefile
new file mode 100644
index 000000000000..872384f85553
--- /dev/null
+++ b/security/py3-openssl/Makefile
@@ -0,0 +1,11 @@
+# Created by: Ben Woods <woodsb02@FreeBSD.org>
+# $FreeBSD$
+
+MASTERDIR= ${.CURDIR}/../py-openssl
+
+RUN_DEPENDS?= ${PYTHON_PKGNAMEPREFIX}cryptography>=0.2.1:security/py3-cryptography \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.5.2:devel/py3-six
+
+USES= cpe python:3.3+
+
+.include "${MASTERDIR}/Makefile"