aboutsummaryrefslogtreecommitdiff
path: root/security/qtkeychain
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2018-07-18 19:17:28 +0000
committerGleb Popov <arrowd@FreeBSD.org>2018-07-18 19:17:28 +0000
commitbd22665013e8be74802a16c666d6d350fc201256 (patch)
treecd00f39367ba3592a4ca3a19841d4040d5360e91 /security/qtkeychain
parent4373c6b7c40db4cfc0e6e94e718048b5f5722b83 (diff)
downloadports-bd22665013e8be74802a16c666d6d350fc201256.tar.gz
ports-bd22665013e8be74802a16c666d6d350fc201256.zip
security/qtkeychain: Add dependency to libsecret and link to it correctly.
PR: 229837 Reported by: Piotr Kubaj <pkubaj@anongoth.pl> Approved by: tcberner (mentor)
Notes
Notes: svn path=/head/; revision=474893
Diffstat (limited to 'security/qtkeychain')
-rw-r--r--security/qtkeychain/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/security/qtkeychain/Makefile b/security/qtkeychain/Makefile
index 5ef9d65f3cb0..d60747bb5dbe 100644
--- a/security/qtkeychain/Makefile
+++ b/security/qtkeychain/Makefile
@@ -3,6 +3,7 @@
PORTNAME= qtkeychain
DISTVERSIONPREFIX= v
DISTVERSION= 0.9.0
+PORTREVISION= 1
CATEGORIES= security
PKGNAMESUFFIX= -${FLAVOR}
@@ -15,11 +16,10 @@ LICENSE_FILE= ${WRKSRC}/COPYING
FLAVORS= qt4 qt5
FLAVOR?= ${FLAVORS:[1]}
-USES= cmake
+USES= cmake localbase:ldflags pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= frankosterfeld
USE_LDCONFIG= yes
-USE_KDE= ecm
PLIST_SUB+= VERSION=${PORTVERSION}
. if ${FLAVOR} == qt4
@@ -35,5 +35,12 @@ PLIST_SUB+= PLIST_QT_PREFIX_UPCASE=Qt5 PLIST_QT_PREFIX=qt5
PLIST= ${PKGDIR}/pkg-plist.${FLAVOR}
. endif
+OPTIONS_DEFINE= LIBSECRET
+OPTIONS_DEFAULT= LIBSECRET
+
+LIBSECRET_DESC= Enable libsecret backend
+
+LIBSECRET_LIB_DEPENDS= libsecret-1.so:security/libsecret
+LIBSECRET_CMAKE_BOOL= LIBSECRET_SUPPORT
.include <bsd.port.mk>