aboutsummaryrefslogtreecommitdiff
path: root/security/rats
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-07-11 15:13:05 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-07-11 15:13:05 +0000
commit1c04e7d73ece1dfa65385c9bf5ce260f1b803823 (patch)
treeb6d9d3491f567a39f2271c79454fa53287f44173 /security/rats
parent6aaa6f4830337f481a737912cabe5e00b81541c3 (diff)
downloadports-1c04e7d73ece1dfa65385c9bf5ce260f1b803823.tar.gz
ports-1c04e7d73ece1dfa65385c9bf5ce260f1b803823.zip
- Add staging support
- Convert to new LIB_DEPENDS format, options framework
Notes
Notes: svn path=/head/; revision=361546
Diffstat (limited to 'security/rats')
-rw-r--r--security/rats/Makefile20
-rw-r--r--security/rats/pkg-plist1
2 files changed, 12 insertions, 9 deletions
diff --git a/security/rats/Makefile b/security/rats/Makefile
index c21b7f216a65..27df55efbf97 100644
--- a/security/rats/Makefile
+++ b/security/rats/Makefile
@@ -5,12 +5,12 @@ PORTNAME= rats
PORTVERSION= 2.3
CATEGORIES= security devel
MASTER_SITES= https://www.fortify.com/downloads2/public/ \
- http://redundancy.redundancy.org/mirror/
+ http://redundancy.redundancy.org/mirror/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Source code auditing tool
-LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
+LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2
GNU_CONFIGURE= yes
USES= gmake
@@ -20,12 +20,14 @@ CONFIGURE_ARGS+=--with-expat-lib=${LOCALBASE}/lib \
ALL_TARGET= ${PORTNAME}
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
+post-patch:
+ @${REINPLACE_CMD} -E '/^CFLAGS/! s,(BIN|LIB|MAN|SHARE)DIR),DESTDIR)$$(&,g' \
+ ${WRKSRC}/Makefile.in
+
post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
-.endif
-MAN1= rats.1
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/security/rats/pkg-plist b/security/rats/pkg-plist
index f7b36ba7e803..9df49f0a0cc5 100644
--- a/security/rats/pkg-plist
+++ b/security/rats/pkg-plist
@@ -1,4 +1,5 @@
bin/rats
+man/man1/rats.1.gz
%%DATADIR%%/rats-c.xml
%%DATADIR%%/rats-openssl.xml
%%DATADIR%%/rats-perl.xml