aboutsummaryrefslogtreecommitdiff
path: root/security/razorback-api/Makefile
diff options
context:
space:
mode:
authorTom Judge <tj@FreeBSD.org>2012-06-01 15:27:32 +0000
committerTom Judge <tj@FreeBSD.org>2012-06-01 15:27:32 +0000
commit0c6bb056a6d3d4bfa9a134a8b58fd25677c90654 (patch)
tree31c63c950c6746d27657eee550fcaa635f3c325b /security/razorback-api/Makefile
parent0e9c11a9668ca0794a12748224c8f45aac62aac3 (diff)
downloadports-0c6bb056a6d3d4bfa9a134a8b58fd25677c90654.tar.gz
ports-0c6bb056a6d3d4bfa9a134a8b58fd25677c90654.zip
Convert to the new OptionsNG framework.
Approved by: eadler (mentor)
Notes
Notes: svn path=/head/; revision=297962
Diffstat (limited to 'security/razorback-api/Makefile')
-rw-r--r--security/razorback-api/Makefile18
1 files changed, 10 insertions, 8 deletions
diff --git a/security/razorback-api/Makefile b/security/razorback-api/Makefile
index cc3a93d7dce1..2f733d7665d9 100644
--- a/security/razorback-api/Makefile
+++ b/security/razorback-api/Makefile
@@ -23,10 +23,12 @@ LIB_DEPENDS= config.10:${PORTSDIR}/devel/libconfig \
curl.6:${PORTSDIR}/ftp/curl \
json.0:${PORTSDIR}/devel/json-c
-OPTIONS= DEBUG "Enable Debug" off \
- ASSERT "Enable Asserts" off \
- CNC_DEBUG "Enable Command and Control Debug" off \
- STOMP_DEBUG "Enable STOMP Debug" off
+OPTIONS_DEFINE= DEBUG ASSERT CNC_DEBUG STOMP_DEBUG
+
+CNC_DEBUG_DESC= Enable Command and Control Debug
+STOMP_DEBUG_DESC= Enable STOMP Debug
+
+.include <bsd.port.options.mk>
USE_GNOME= gnomehack
USE_AUTOTOOLS= libtool
@@ -35,19 +37,19 @@ USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-.if defined(WITH_DEBUG)
+.if !empty(PORT_OPTIONS:MDEBUG)
CONFIGURE_ARGS+=--enable-debug
.endif
-.if defined(WITH_ASSERT)
+.if !empty(PORT_OPTIONS:MASSERT)
CONFIGURE_ARGS+=--enable-assert
.endif
-.if defined(WITH_CNC_DEBUG)
+.if !empty(PORT_OPTIONS:MCNC_DEBUG)
CONFIGURE_ARGS+=--enable-cnc-debug
.endif
-.if defined(WITH_STOMP_DEBUG)
+.if !empty(PORT_OPTIONS:MSTOMP_DEBUG)
CONFIGURE_ARGS+=--enable-stomp-debug
.endif