aboutsummaryrefslogtreecommitdiff
path: root/security/razorback-pdfFox
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-09-02 20:03:58 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-09-02 20:03:58 +0000
commitefd069754984f95b97c34a6ddcf64f6126dfa1d6 (patch)
treec519edfa8150d5efc6571231295d7b3f1692e61c /security/razorback-pdfFox
parentb7cdacd1734ee37cb94a9963556ad73416d50e18 (diff)
downloadports-efd069754984f95b97c34a6ddcf64f6126dfa1d6.tar.gz
ports-efd069754984f95b97c34a6ddcf64f6126dfa1d6.zip
Add an explicit dependency on pkgconf
Notes
Notes: svn path=/head/; revision=326072
Diffstat (limited to 'security/razorback-pdfFox')
-rw-r--r--security/razorback-pdfFox/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/security/razorback-pdfFox/Makefile b/security/razorback-pdfFox/Makefile
index a5ffc8d0043d..672ba8dbd138 100644
--- a/security/razorback-pdfFox/Makefile
+++ b/security/razorback-pdfFox/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: razorback-archiveInflate
-# Date created: 2011/06/8
-# Whom: Tom Judge <tom@tomjudge.com>
-#
+# Created by: Tom Judge <tom@tomjudge.com>
# $FreeBSD$
-#
PORTNAME= pdfFox
PORTVERSION= 0.5.0
@@ -25,15 +21,16 @@ RUN_DEPENDS= razorback-masterNugget>=0.5.0:${PORTSDIR}/security/razorback-master
OPTIONS_DEFINE= DEBUG ASSERT
ASSERT_DESC= Enable Asserts
-.include <bsd.port.options.mk>
-
RB_LIBDIR?= ${PREFIX}/lib/razorback
GNU_CONFIGURE= yes
+USES= pkgconfig
USE_AUTOTOOLS= libtool
USE_LDCONFIG= ${RB_LIBDIR}
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+.include <bsd.port.options.mk>
+
.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+=--enable-debug
.endif