aboutsummaryrefslogtreecommitdiff
path: root/security/razorback-scriptNugget
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-08-20 17:53:11 +0000
committerJohn Marino <marino@FreeBSD.org>2014-08-20 17:53:11 +0000
commit4c48040b0d78d6a595936d17e90c4a3e019f6c0c (patch)
tree8e7afbb0183c955ddfdc4ecc64fdbeb32e6f39e5 /security/razorback-scriptNugget
parentf4f6fc3d464bb8168a00506c5bdce19e3d744d03 (diff)
downloadports-4c48040b0d78d6a595936d17e90c4a3e019f6c0c.tar.gz
ports-4c48040b0d78d6a595936d17e90c4a3e019f6c0c.zip
security/razorback-scriptNugget: Chase json-c update (Unbreak)
Notes
Notes: svn path=/head/; revision=365493
Diffstat (limited to 'security/razorback-scriptNugget')
-rw-r--r--security/razorback-scriptNugget/Makefile6
-rw-r--r--security/razorback-scriptNugget/files/patch-common__m4_api__deps.m411
-rw-r--r--security/razorback-scriptNugget/files/patch-common__m4_compiler__options.m411
3 files changed, 26 insertions, 2 deletions
diff --git a/security/razorback-scriptNugget/Makefile b/security/razorback-scriptNugget/Makefile
index c55623db13a9..17d91618156f 100644
--- a/security/razorback-scriptNugget/Makefile
+++ b/security/razorback-scriptNugget/Makefile
@@ -3,7 +3,7 @@
PORTNAME= scriptNugget
PORTVERSION= 0.5.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security
MASTER_SITES= SF/razorbacktm/Nuggets
PKGNAMEPREFIX= razorback-
@@ -15,13 +15,15 @@ COMMENT= Framework for an intelligence driven security - Scripting Interface
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= librazorback_api.so:${PORTSDIR}/security/razorback-api
+LIB_DEPENDS= librazorback_api.so:${PORTSDIR}/security/razorback-api \
+ libjson-c.so:${PORTSDIR}/devel/json-c
BUILD_DEPENDS= razorback-masterNugget>=0.5.0:${PORTSDIR}/security/razorback-masterNugget
RUN_DEPENDS= razorback-masterNugget>=0.5.0:${PORTSDIR}/security/razorback-masterNugget \
rubygem-razorback-scriptNugget>=0.5.0:${PORTSDIR}/security/rubygem-razorback-scriptNugget
RB_LIBDIR?= ${PREFIX}/lib/razorback
USES= libtool pkgconfig
+USE_AUTOTOOLS= autoconf
USE_GNOME= libxml2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-ruby
diff --git a/security/razorback-scriptNugget/files/patch-common__m4_api__deps.m4 b/security/razorback-scriptNugget/files/patch-common__m4_api__deps.m4
new file mode 100644
index 000000000000..b424f894f261
--- /dev/null
+++ b/security/razorback-scriptNugget/files/patch-common__m4_api__deps.m4
@@ -0,0 +1,11 @@
+--- common_m4/api_deps.m4.orig 2012-04-16 18:59:44 UTC
++++ common_m4/api_deps.m4
+@@ -55,7 +55,7 @@ LIBS="$LIBCONFIG_LIBS $LIBS"
+ # [AC_MSG_ERROR("curl header file not found")]
+ # )
+
+-PKG_CHECK_MODULES([JSON], [json >= 0.9])
++PKG_CHECK_MODULES([JSON], [json-c >= 0.9])
+
+ CFLAGS="$JSON_CFLAGS $CFLAGS"
+ LIBS="$JSON_LIBS $LIBS"
diff --git a/security/razorback-scriptNugget/files/patch-common__m4_compiler__options.m4 b/security/razorback-scriptNugget/files/patch-common__m4_compiler__options.m4
new file mode 100644
index 000000000000..8e2572727b90
--- /dev/null
+++ b/security/razorback-scriptNugget/files/patch-common__m4_compiler__options.m4
@@ -0,0 +1,11 @@
+--- common_m4/compiler_options.m4.orig 2012-01-04 18:17:09 UTC
++++ common_m4/compiler_options.m4
+@@ -28,7 +28,7 @@ if test "$GCC" = yes ; then
+
+ CFLAGS="$CFLAGS -std=c99 -fno-strict-aliasing"
+ CPPFLAGS="$CPPFLAGS -fno-strict-aliasing"
+- CWARNINGS="$CWARNINGS -Wall -Werror -Wwrite-strings -Wformat -fdiagnostics-show-option -Wextra -Wformat-security -Wsign-compare -Wcast-align -Wno-unused-parameter"
++ CWARNINGS="$CWARNINGS -Wall -Wwrite-strings -Wformat -fdiagnostics-show-option -Wextra -Wformat-security -Wsign-compare -Wcast-align -Wno-unused-parameter"
+ if test "x$NOT_PEDANTIC" = "x"; then
+ CWARNINGS="$CWARNINGS -pedantic"
+ fi