aboutsummaryrefslogtreecommitdiff
path: root/security/rhash
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2021-01-08 09:21:17 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2021-01-08 09:21:17 +0000
commit666900e91d4fb12bd39f42e293ae2c6e84043f33 (patch)
treebb8bbf23e4a3f27d9a09896b54d97cec0cf2ba3f /security/rhash
parentcf01a81b0785b880e8d0f358126cd745c6cb99ef (diff)
downloadports-666900e91d4fb12bd39f42e293ae2c6e84043f33.tar.gz
ports-666900e91d4fb12bd39f42e293ae2c6e84043f33.zip
- Update to version 1.4.1
- GC patch applied upstream Reported by: portscout
Notes
Notes: svn path=/head/; revision=560754
Diffstat (limited to 'security/rhash')
-rw-r--r--security/rhash/Makefile2
-rw-r--r--security/rhash/distinfo6
-rw-r--r--security/rhash/files/patch-librhash_plug__openssl.c60
3 files changed, 4 insertions, 64 deletions
diff --git a/security/rhash/Makefile b/security/rhash/Makefile
index 2d8c7d9ef556..1071a3c7ccce 100644
--- a/security/rhash/Makefile
+++ b/security/rhash/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= rhash
-PORTVERSION= 1.4.0
+PORTVERSION= 1.4.1
CATEGORIES= security
MASTER_SITES= SF
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
diff --git a/security/rhash/distinfo b/security/rhash/distinfo
index 24bbb8674ee3..fa8fa4ea462d 100644
--- a/security/rhash/distinfo
+++ b/security/rhash/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1594834294
-SHA256 (rhash-1.4.0-src.tar.gz) = 2ea39540f5c580da0e655f7b483c19e0d31506aed4202d88e8459fa7aeeb8861
-SIZE (rhash-1.4.0-src.tar.gz) = 406433
+TIMESTAMP = 1610013545
+SHA256 (rhash-1.4.1-src.tar.gz) = 430c812733e69b78f07ce30a05db69563450e41e217ae618507a4ce2e144a297
+SIZE (rhash-1.4.1-src.tar.gz) = 413274
SHA256 (rhash-1.3.2.patch) = 9aeeb0d89f0203429a6f5433e7dd5fd4b621b34bc42fb6d5d32ede6279c990b0
SIZE (rhash-1.3.2.patch) = 9021
diff --git a/security/rhash/files/patch-librhash_plug__openssl.c b/security/rhash/files/patch-librhash_plug__openssl.c
deleted file mode 100644
index 57993b012392..000000000000
--- a/security/rhash/files/patch-librhash_plug__openssl.c
+++ /dev/null
@@ -1,60 +0,0 @@
---- librhash/plug_openssl.c.orig 2019-12-14 16:52:11 UTC
-+++ librhash/plug_openssl.c
-@@ -18,10 +18,15 @@
- #include <string.h>
- #include <assert.h>
- #include <openssl/opensslconf.h>
--#include <openssl/md4.h>
- #include <openssl/md5.h>
- #include <openssl/sha.h>
-
-+#ifndef OPENSSL_NO_MD4
-+# include <openssl/md4.h>
-+# define PLUGIN_MD4 RHASH_MD4
-+#else
-+# define PLUGIN_MD4 0
-+#endif
- #ifndef OPENSSL_NO_RIPEMD
- # include <openssl/ripemd.h>
- # define PLUGIN_RIPEMD160 RHASH_RIPEMD160
-@@ -48,7 +53,7 @@
-
- #define OPENSSL_DEFAULT_HASH_MASK (RHASH_MD5 | RHASH_SHA1 | \
- RHASH_SHA224 | RHASH_SHA256 | RHASH_SHA384 | RHASH_SHA512)
--#define PLUGIN_SUPPORTED_HASH_MASK (RHASH_MD4 | RHASH_MD5 | RHASH_SHA1 | \
-+#define PLUGIN_SUPPORTED_HASH_MASK (PLUGIN_MD4 | RHASH_MD5 | RHASH_SHA1 | \
- RHASH_SHA224 | RHASH_SHA256 | RHASH_SHA384 | RHASH_SHA512 | \
- PLUGIN_RIPEMD160 | PLUGIN_WHIRLPOOL)
-
-@@ -89,7 +94,9 @@ OS_METHOD(WHIRLPOOL);
- CALL_FINAL(name, result, (CTX_TYPE*)ctx); \
- }
-
-+#ifndef OPENSSL_NO_MD4
- WRAP_FINAL(MD4)
-+#endif
- WRAP_FINAL(MD5)
- WRAP_FINAL2(SHA1, SHA_CTX)
- WRAP_FINAL2(SHA224, SHA256_CTX)
-@@ -114,7 +121,11 @@ rhash_info info_sslwhpl = { RHASH_WHIRLPOOL, 0, 64, "W
-
- /* The table of supported OpenSSL hash functions */
- rhash_hash_info rhash_openssl_methods[] = {
-+#ifndef OPENSSL_NO_MD4
- { &info_md4, sizeof(MD4_CTX), offsetof(MD4_CTX, A), HASH_INFO_METHODS(MD4) }, /* 128 bit */
-+#else
-+ { 0, 0, 0, 0, 0, 0, 0},
-+#endif
- { &info_md5, sizeof(MD5_CTX), offsetof(MD5_CTX, A), HASH_INFO_METHODS(MD5) }, /* 128 bit */
- { &info_sha1, sizeof(SHA_CTX), offsetof(SHA_CTX, h0), HASH_INFO_METHODS(SHA1) }, /* 160 bit */
- { &info_sha224, sizeof(SHA256_CTX), offsetof(SHA256_CTX, h), HASH_INFO_METHODS(SHA224) }, /* 224 bit */
-@@ -187,7 +198,9 @@ static int load_openssl_runtime(void)
-
- if (handle == NULL) return 0; /* could not load OpenSSL */
-
-+#ifndef OPENSSL_NO_MD4
- LOAD_ADDR(0, MD4)
-+#endif
- LOAD_ADDR(1, MD5);
- LOAD_ADDR(2, SHA1);
- LOAD_ADDR(3, SHA224);