aboutsummaryrefslogtreecommitdiff
path: root/security/rnp
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2021-02-03 14:30:54 +0000
committerStefan Eßer <se@FreeBSD.org>2021-02-03 14:30:54 +0000
commit545aa04ea5785faea06da1f4c12bba105d7092e4 (patch)
tree2e7a3790b25d1eb6f97c8057b412bb93ba4b402d /security/rnp
parent37b2a9ce25822be2cbc28b0f7996ec0ded0257b3 (diff)
downloadports-545aa04ea5785faea06da1f4c12bba105d7092e4.tar.gz
ports-545aa04ea5785faea06da1f4c12bba105d7092e4.zip
New port for rnp, an alternative to gnupg
Notes
Notes: svn path=/head/; revision=563888
Diffstat (limited to 'security/rnp')
-rw-r--r--security/rnp/Makefile29
-rw-r--r--security/rnp/distinfo3
-rw-r--r--security/rnp/pkg-descr12
-rw-r--r--security/rnp/pkg-plist13
4 files changed, 57 insertions, 0 deletions
diff --git a/security/rnp/Makefile b/security/rnp/Makefile
new file mode 100644
index 000000000000..419dd6c42fef
--- /dev/null
+++ b/security/rnp/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= rnp
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.14.0
+CATEGORIES= security
+
+MAINTAINER= se@FreeBSD.org
+COMMENT= RNP is a set of OpenPGP (RFC4880) tools
+
+LICENSE= APACHE20 BSD2CLAUSE BSD3CLAUSE OCB_Patent
+LICENSE_COMB= multi
+LICENSE_NAME_OCB_Patent= OCB Patent License for Ribose Inc.
+LICENSE_FILE_OCB_Patent= ${WRKSRC}/LICENSE-OCB.md
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+LICENSE_PERMS_OCB_Patent= dist-mirror dist-sell pkg-mirror pkg-sell \
+ auto-accept
+
+LIB_DEPENDS= libbotan-2.so:security/botan2 \
+ libjson-c.so:devel/json-c
+
+USES= cmake
+USE_GITHUB= yes
+GH_ACCOUNT= rnpgp
+
+CMAKE_ARGS= -DBUILD_SHARED_LIBS=on \
+ -DBUILD_TESTING=off
+
+.include <bsd.port.mk>
diff --git a/security/rnp/distinfo b/security/rnp/distinfo
new file mode 100644
index 000000000000..d90cfa4b78ed
--- /dev/null
+++ b/security/rnp/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1612352278
+SHA256 (rnpgp-rnp-v0.14.0_GH0.tar.gz) = 1d87d5826646ef003c95067fbe3e377bb8fd47a24c6a3227e6bce03ee9f49c28
+SIZE (rnpgp-rnp-v0.14.0_GH0.tar.gz) = 1343813
diff --git a/security/rnp/pkg-descr b/security/rnp/pkg-descr
new file mode 100644
index 000000000000..6a8130dcff15
--- /dev/null
+++ b/security/rnp/pkg-descr
@@ -0,0 +1,12 @@
+RNP is a set of OpenPGP (RFC4880) tools that works on Linux, macOS,
+Windows and *BSD built with C++.
+
+rnpkeys allow to generate, import, export, and list keys.
+
+rnp is used to perform encryption, decryption, signing and signature
+checks.
+
+librnp is the library used by RNP for all OpenPGP functions, useful
+for developers to build against, different from GPGME.
+
+WWW: http://example.com
diff --git a/security/rnp/pkg-plist b/security/rnp/pkg-plist
new file mode 100644
index 000000000000..8d426fc2c361
--- /dev/null
+++ b/security/rnp/pkg-plist
@@ -0,0 +1,13 @@
+bin/rnp
+bin/rnpkeys
+include/rnp-0/rnp/rnp.h
+include/rnp-0/rnp/rnp_err.h
+include/rnp-0/rnp/rnp_export.h
+lib/cmake/rnp/rnp-config-version.cmake
+lib/cmake/rnp/rnp-config.cmake
+lib/cmake/rnp/rnp-targets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/rnp/rnp-targets.cmake
+lib/librnp-0.so
+lib/librnp-0.so.0
+lib/librnp-0.so.0.14.0
+libdata/pkgconfig/librnp-0.pc