aboutsummaryrefslogtreecommitdiff
path: root/security/rubygem-devise-two-factor-rails613/Makefile
diff options
context:
space:
mode:
authorMatthias Fechner <mfechner@FreeBSD.org>2021-10-05 07:38:10 +0000
committerMatthias Fechner <mfechner@FreeBSD.org>2021-10-05 07:40:04 +0000
commitf4511dc4a7c439b30c898b75246d314a574f01cb (patch)
treefe53f801c18ad70cb7881f3d6e5f08ea0640637a /security/rubygem-devise-two-factor-rails613/Makefile
parent7dcb3ca59065e8f1c74bbed2f64f3bc8100bbc18 (diff)
downloadports-f4511dc4a7c439b30c898b75246d314a574f01cb.tar.gz
ports-f4511dc4a7c439b30c898b75246d314a574f01cb.zip
*/*: Make rails 6.1.3 available
The upgrade of rails to 6.1.4 broke www/gitlab-ce. PR: 258855
Diffstat (limited to 'security/rubygem-devise-two-factor-rails613/Makefile')
-rw-r--r--security/rubygem-devise-two-factor-rails613/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/security/rubygem-devise-two-factor-rails613/Makefile b/security/rubygem-devise-two-factor-rails613/Makefile
new file mode 100644
index 000000000000..72475439335d
--- /dev/null
+++ b/security/rubygem-devise-two-factor-rails613/Makefile
@@ -0,0 +1,26 @@
+# Created by: Torsten Zuhlsdorff <ports@toco-domains.de>
+
+PORTNAME= devise-two-factor
+PORTVERSION= 4.0.1
+CATEGORIES= security rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= -rails613
+
+MAINTAINER= mfechner@FreeBSD.org
+COMMENT= Barebones two-factor authentication with Devise
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= rubygem-activesupport613>=0<6.2:devel/rubygem-activesupport613 \
+ rubygem-attr_encrypted>=3<4:security/rubygem-attr_encrypted \
+ rubygem-devise-rails613>=4.0<5:devel/rubygem-devise-rails613 \
+ rubygem-railties613>=0<6.2:www/rubygem-railties613 \
+ rubygem-rotp>=6.0<7:devel/rubygem-rotp
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>