aboutsummaryrefslogtreecommitdiff
path: root/security/rubygem-ed25519
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-06-02 22:24:47 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-06-02 22:24:47 +0000
commit8fbf65d618e0ccdaa8a37f9676f63c6d40f2a73c (patch)
tree0029aebf104c7eda2e8fdb2eafa9880a2acb539b /security/rubygem-ed25519
parenta5aa446856e2f4ec933bf8e94e56861742a3de93 (diff)
downloadports-8fbf65d618e0ccdaa8a37f9676f63c6d40f2a73c.tar.gz
ports-8fbf65d618e0ccdaa8a37f9676f63c6d40f2a73c.zip
Add rubygem-ed25519 1.2.4
ed25519.rb is a Ruby binding to the Ed25519 elliptic curve public-key signature system described in RFC 8032. Two implementations are provided: a MRI C extension which uses the "ref10" implementation from the SUPERCOP benchmark suite, and a pure Java version based on str4d/ed25519-java. Ed25519 is one of two notable algorithms implemented atop the Curve25519 elliptic curve. The x25519 gem is a related project of this one, and implements the X25519 Diffie-Hellman key exchange algorithm on the Montgomery form of Curve25519. WWW: https://github.com/crypto-rb/ed25519
Notes
Notes: svn path=/head/; revision=471407
Diffstat (limited to 'security/rubygem-ed25519')
-rw-r--r--security/rubygem-ed25519/Makefile18
-rw-r--r--security/rubygem-ed25519/distinfo3
-rw-r--r--security/rubygem-ed25519/pkg-descr13
3 files changed, 34 insertions, 0 deletions
diff --git a/security/rubygem-ed25519/Makefile b/security/rubygem-ed25519/Makefile
new file mode 100644
index 000000000000..344a06fc5668
--- /dev/null
+++ b/security/rubygem-ed25519/Makefile
@@ -0,0 +1,18 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= ed25519
+PORTVERSION= 1.2.4
+CATEGORIES= security rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Ruby binding to the Ed25519 (RFC 8032)
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_RUBY= yes
+USES= gem
+
+.include <bsd.port.mk>
diff --git a/security/rubygem-ed25519/distinfo b/security/rubygem-ed25519/distinfo
new file mode 100644
index 000000000000..fcc31a67f16e
--- /dev/null
+++ b/security/rubygem-ed25519/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1527946165
+SHA256 (rubygem/ed25519-1.2.4.gem) = dc62c3491e9484d566519ab2bfca1406c7527694c902e6d05074c3a33ecab3b8
+SIZE (rubygem/ed25519-1.2.4.gem) = 137216
diff --git a/security/rubygem-ed25519/pkg-descr b/security/rubygem-ed25519/pkg-descr
new file mode 100644
index 000000000000..d74af08184ac
--- /dev/null
+++ b/security/rubygem-ed25519/pkg-descr
@@ -0,0 +1,13 @@
+ed25519.rb is a Ruby binding to the Ed25519 elliptic curve public-key signature
+system described in RFC 8032.
+
+Two implementations are provided: a MRI C extension which uses the "ref10"
+implementation from the SUPERCOP benchmark suite, and a pure Java version based
+on str4d/ed25519-java.
+
+Ed25519 is one of two notable algorithms implemented atop the Curve25519
+elliptic curve. The x25519 gem is a related project of this one, and implements
+the X25519 Diffie-Hellman key exchange algorithm on the Montgomery form of
+Curve25519.
+
+WWW: https://github.com/crypto-rb/ed25519