aboutsummaryrefslogtreecommitdiff
path: root/security/seahorse
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-12-22 00:06:01 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-12-22 00:06:01 +0000
commit4b6647a9a73a604bb629522bfe4e207b897d6853 (patch)
tree46d77b02f1122c75d0c8187ac878e9e53e16d463 /security/seahorse
parent2530951c6bdb25bb66335bf1ddf900a1c2d37199 (diff)
downloadports-4b6647a9a73a604bb629522bfe4e207b897d6853.tar.gz
ports-4b6647a9a73a604bb629522bfe4e207b897d6853.zip
Update to 0.7.5.
Approved by: maintainer
Notes
Notes: svn path=/head/; revision=124749
Diffstat (limited to 'security/seahorse')
-rw-r--r--security/seahorse/Makefile33
-rw-r--r--security/seahorse/distinfo4
-rw-r--r--security/seahorse/files/patch-configure10
-rw-r--r--security/seahorse/files/patch-libseahorse_seahorse-widget.c11
-rw-r--r--security/seahorse/files/patch-src_main.c31
-rw-r--r--security/seahorse/pkg-plist39
6 files changed, 65 insertions, 63 deletions
diff --git a/security/seahorse/Makefile b/security/seahorse/Makefile
index 4b34da640056..055c1835a328 100644
--- a/security/seahorse/Makefile
+++ b/security/seahorse/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= seahorse
-PORTVERSION= 0.7.3
-PORTREVISION= 4
+PORTVERSION= 0.7.5
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR=sources/${PORTNAME}/0.7
@@ -18,21 +17,31 @@ COMMENT= A front end for GnuPG
BUILD_DEPENDS= gpg:${PORTSDIR}/security/gnupg
RUN_DEPENDS= ${BUILD_DEPENDS}
-LIB_DEPENDS= gpgme03.9:${PORTSDIR}/security/gpgme03
+LIB_DEPENDS= gpgme.14:${PORTSDIR}/security/gpgme
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack gnomeprefix eel2
-USE_INC_LIBTOOL_VER=13
+USE_GNOME= gnomehack intlhack gnomeprefix eel2
+USE_LIBTOOL_VER=15
USE_REINPLACE= yes
+INSTALLS_OMF= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib"
-post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g; \
- s|gpgme-config|gpgme03-config|' ${WRKSRC}/configure
- @${CP} ${WRKSRC}/data/seahorse.schemas.in ${WRKSRC}/data/seahorse.schemas
+GCONF_SCHEMAS= seahorse.schemas
-.include <bsd.port.mk>
+OPTIONS= GEDIT "Enable the gedit plug-in" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_GEDIT)
+BUILD_DEPENDS+= gedit:${PORTSDIR}/editors/gedit2
+RUN_DEPENDS+= gedit:${PORTSDIR}/editors/gedit2
+PLIST_SUB+= GEDIT=""
+.else
+PLIST_SUB+= GEDIT="@comment "
+CONFIGURE_ARGS+=--disable-gedit
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/seahorse/distinfo b/security/seahorse/distinfo
index 17adea679549..3659cf102060 100644
--- a/security/seahorse/distinfo
+++ b/security/seahorse/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/seahorse-0.7.3.tar.bz2) = 9cebb904b22d739dc527443e417c0f78
-SIZE (gnome2/seahorse-0.7.3.tar.bz2) = 548372
+MD5 (gnome2/seahorse-0.7.5.tar.bz2) = aa113297dbc5525a4853e73bedb9af45
+SIZE (gnome2/seahorse-0.7.5.tar.bz2) = 937238
diff --git a/security/seahorse/files/patch-configure b/security/seahorse/files/patch-configure
deleted file mode 100644
index f195f07b43c6..000000000000
--- a/security/seahorse/files/patch-configure
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.orig Wed Dec 11 18:31:51 2002
-+++ configure Thu Dec 12 12:07:17 2002
-@@ -7414,6 +7414,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/security/seahorse/files/patch-libseahorse_seahorse-widget.c b/security/seahorse/files/patch-libseahorse_seahorse-widget.c
new file mode 100644
index 000000000000..ee8063fb02aa
--- /dev/null
+++ b/security/seahorse/files/patch-libseahorse_seahorse-widget.c
@@ -0,0 +1,11 @@
+--- libseahorse/seahorse-widget.c.orig Mon Dec 13 23:49:49 2004
++++ libseahorse/seahorse-widget.c Mon Dec 13 23:49:57 2004
+@@ -197,7 +197,7 @@
+ {
+ //error check help
+ if (g_str_equal (swidget->name, "key-manager"))
+- gnome_help_display (PACKAGE, "toc", NULL);
++ gnome_help_display (PACKAGE, NULL, NULL);
+ else
+ gnome_help_display (PACKAGE, swidget->name, NULL);
+ }
diff --git a/security/seahorse/files/patch-src_main.c b/security/seahorse/files/patch-src_main.c
deleted file mode 100644
index df57a9756d63..000000000000
--- a/security/seahorse/files/patch-src_main.c
+++ /dev/null
@@ -1,31 +0,0 @@
---- src/main.c.orig Mon May 5 02:45:14 2003
-+++ src/main.c Mon May 5 02:45:47 2003
-@@ -29,7 +29,7 @@
- #include "seahorse-libdialogs.h"
-
- static gchar *import = NULL;
--static gchar *encrypt = NULL;
-+static gchar *sea_encrypt = NULL;
- static gchar *sign = NULL;
- static gchar *encrypt_sign = NULL;
- static gchar *decrypt = NULL;
-@@ -40,7 +40,7 @@
- { "import", 'i', POPT_ARG_STRING, &import, 0,
- N_("Import keys from the file"), N_("FILE") },
-
-- { "encrypt", 'e', POPT_ARG_STRING, &encrypt, 0,
-+ { "encrypt", 'e', POPT_ARG_STRING, &sea_encrypt, 0,
- N_("Encrypt file"), N_("FILE") },
-
- { "sign", 's', POPT_ARG_STRING, &sign, 0,
-@@ -137,8 +137,8 @@
- return 0;
- }
- }
-- if (encrypt != NULL)
-- do_encrypt (sctx, encrypt, seahorse_op_encrypt_file, _("Encrypt file is %s"));
-+ if (sea_encrypt != NULL)
-+ do_encrypt (sctx, sea_encrypt, seahorse_op_encrypt_file, _("Encrypt file is %s"));
- if (sign != NULL) {
- new_path = seahorse_op_sign_file (sctx, sign, &err);
-
diff --git a/security/seahorse/pkg-plist b/security/seahorse/pkg-plist
index 59e40d26ab76..9d09f8ba299d 100644
--- a/security/seahorse/pkg-plist
+++ b/security/seahorse/pkg-plist
@@ -1,9 +1,12 @@
bin/seahorse
+bin/seahorse-agent
bin/seahorse-pgp-preferences
-@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/seahorse.schemas > /dev/null || /usr/bin/true
-etc/gconf/schemas/seahorse.schemas
-@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/seahorse.schemas > /dev/null || /usr/bin/true
lib/bonobo/libseahorse-pgp-file-listener.so
+%%GEDIT%%lib/gedit-2/plugins/libseahorse-pgp.so
+%%GEDIT%%lib/gedit-2/plugins/seahorse-pgp.gedit-plugin
+lib/libseahorse-internal.a
+lib/libseahorse-internal.so
+lib/libseahorse-internal.so.0
libdata/bonobo/servers/Seahorse_PGP_File_Listener.server
share/gnome/applications/seahorse.desktop
share/gnome/control-center-2.0/capplets/seahorse-pgp-preferences.desktop
@@ -23,16 +26,17 @@ share/gnome/help/seahorse/C/seahorse.xml
share/gnome/mime-info/seahorse.keys
share/gnome/mime-info/seahorse.mime
share/gnome/omf/seahorse/seahorse-C.omf
-@exec scrollkeeper-install -q %D/share/gnome/omf/seahorse/seahorse-C.omf 2>/dev/null || /usr/bin/true
share/gnome/pixmaps/seahorse.png
share/gnome/seahorse/glade/seahorse-add-subkey.glade
share/gnome/seahorse/glade/seahorse-add-uid.glade
+share/gnome/seahorse/glade/seahorse-agent-cache.glade
share/gnome/seahorse/glade/seahorse-change-passphrase.glade
-share/gnome/seahorse/glade/seahorse-export.glade
-share/gnome/seahorse/glade/seahorse-generate.glade
-share/gnome/seahorse/glade/seahorse-import.glade
+share/gnome/seahorse/glade/seahorse-generate-adv.glade
+share/gnome/seahorse/glade/seahorse-generate-druid.glade
+share/gnome/seahorse/glade/seahorse-generate-select.glade
share/gnome/seahorse/glade/seahorse-key-manager.glade
share/gnome/seahorse/glade/seahorse-key-properties.glade
+share/gnome/seahorse/glade/seahorse-multi-encrypt.glade
share/gnome/seahorse/glade/seahorse-passphrase.glade
share/gnome/seahorse/glade/seahorse-pgp-preferences.glade
share/gnome/seahorse/glade/seahorse-preferences.glade
@@ -40,21 +44,39 @@ share/gnome/seahorse/glade/seahorse-recipients.glade
share/gnome/seahorse/glade/seahorse-revoke.glade
share/gnome/seahorse/glade/seahorse-sign.glade
share/gnome/seahorse/glade/seahorse-signatures.glade
+share/mime/application/pgp-encrypted.xml
+share/mime/application/pgp-keys.xml
+share/mime/application/pgp-signature.xml
+share/mime/packages/seahorse.xml
+share/locale/az/LC_MESSAGES/seahorse.mo
share/locale/ca/LC_MESSAGES/seahorse.mo
share/locale/cs/LC_MESSAGES/seahorse.mo
share/locale/da/LC_MESSAGES/seahorse.mo
share/locale/de/LC_MESSAGES/seahorse.mo
+share/locale/en_CA/LC_MESSAGES/seahorse.mo
+share/locale/en_GB/LC_MESSAGES/seahorse.mo
share/locale/es/LC_MESSAGES/seahorse.mo
+share/locale/eu/LC_MESSAGES/seahorse.mo
share/locale/fi/LC_MESSAGES/seahorse.mo
share/locale/fr/LC_MESSAGES/seahorse.mo
+share/locale/hr/LC_MESSAGES/seahorse.mo
share/locale/hu/LC_MESSAGES/seahorse.mo
+share/locale/it/LC_MESSAGES/seahorse.mo
share/locale/ja/LC_MESSAGES/seahorse.mo
+share/locale/ml/LC_MESSAGES/seahorse.mo
share/locale/ms/LC_MESSAGES/seahorse.mo
share/locale/nl/LC_MESSAGES/seahorse.mo
share/locale/no/LC_MESSAGES/seahorse.mo
+share/locale/pa/LC_MESSAGES/seahorse.mo
+share/locale/pl/LC_MESSAGES/seahorse.mo
+share/locale/pt/LC_MESSAGES/seahorse.mo
share/locale/pt_BR/LC_MESSAGES/seahorse.mo
share/locale/ru/LC_MESSAGES/seahorse.mo
+share/locale/sk/LC_MESSAGES/seahorse.mo
share/locale/sl/LC_MESSAGES/seahorse.mo
+share/locale/sq/LC_MESSAGES/seahorse.mo
+share/locale/sr/LC_MESSAGES/seahorse.mo
+share/locale/sr@Latn/LC_MESSAGES/seahorse.mo
share/locale/sv/LC_MESSAGES/seahorse.mo
share/locale/tr/LC_MESSAGES/seahorse.mo
share/locale/uk/LC_MESSAGES/seahorse.mo
@@ -65,4 +87,5 @@ share/locale/zh_CN/LC_MESSAGES/seahorse.mo
@dirrm share/gnome/omf/seahorse
@dirrm share/gnome/seahorse/glade
@dirrm share/gnome/seahorse
-@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/seahorse/seahorse-C.omf 2>/dev/null || /usr/bin/true
+@exec update-mime-database %D/share/mime
+@unexec update-mime-database %D/share/mime