aboutsummaryrefslogtreecommitdiff
path: root/security/secpanel/Makefile
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2013-11-07 22:35:19 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2013-11-07 22:35:19 +0000
commit271f80e816a975fb206b8e95d4f136a84227196d (patch)
treed7adaf4d4f1963820424dba05edbdecdaf6f33da /security/secpanel/Makefile
parent34a23c610cdff9b52cb6eb92ae8c62232c6b05fd (diff)
downloadports-271f80e816a975fb206b8e95d4f136a84227196d.tar.gz
ports-271f80e816a975fb206b8e95d4f136a84227196d.zip
- Change master sites
- Change maintainer email to @FreeBSD.org - Change Desktop entry file - Support STAGEDIR Approved by: pawel / wg (mentors, implicit)
Notes
Notes: svn path=/head/; revision=333160
Diffstat (limited to 'security/secpanel/Makefile')
-rw-r--r--security/secpanel/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/security/secpanel/Makefile b/security/secpanel/Makefile
index 54bdedfec13e..3e0340645270 100644
--- a/security/secpanel/Makefile
+++ b/security/secpanel/Makefile
@@ -7,13 +7,13 @@ PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= security tcl tk
MASTER_SITES= SF/${PORTNAME} \
- SF/nemysisfreebsdp/:icons
+ SF/nemysisfreebsdp/security/:icons
DISTFILES= ${PORTNAME}-${PORTVERSION}.tgz \
${PORTNAME}.png:icons
DIST_SUBDIR= ${PORTNAME}
EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}.tgz
-MAINTAINER= nemysis@gmx.ch
+MAINTAINER= nemysis@FreeBSD.org
COMMENT= GUI for managing and running ssh and related utilities
LICENSE= GPLv2
@@ -25,20 +25,19 @@ NO_BUILD= yes
USE_TK_WRAPPER= yes
-DESKTOP_ENTRIES="SecPanel" "${COMMENT}" "${PREFIX}/share/pixmaps/${PORTNAME}.png" \
+DESKTOP_ENTRIES="SecPanel" "${COMMENT}" "${PORTNAME}" \
"${PORTNAME}" "" "false"
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} \
-e 's|\[file dirname \[info script\]\]/../lib/secpanel|${DATADIR}|' \
${WRKSRC}/bin/secpanel
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/bin/secpanel ${PREFIX}/bin
- @(cd ${WRKSRC}/lib/secpanel && ${COPYTREE_SHARE} \* ${DATADIR})
- @${CHMOD} u+rw ${DATADIR}/default.config
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+ @(cd ${WRKSRC}/lib/secpanel && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR})
+ @${CHMOD} u+rw ${STAGEDIR}${DATADIR}/default.config
- ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/${PORTNAME}.png ${PREFIX}/share/pixmaps
+ ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png ${STAGEDIR}${PREFIX}/share/pixmaps/
.include <bsd.port.mk>