aboutsummaryrefslogtreecommitdiff
path: root/security/secpanel
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2019-08-29 10:21:48 +0000
committerKurt Jaeger <pi@FreeBSD.org>2019-08-29 10:21:48 +0000
commitdbb33f6ea7cab30f31c85e95de046891b00816e6 (patch)
treee19f63692608ac817145ad8c63f52837c818902c /security/secpanel
parent25cacb79b8843b854bd29852096c02b79406d76e (diff)
downloadports-dbb33f6ea7cab30f31c85e95de046891b00816e6.tar.gz
ports-dbb33f6ea7cab30f31c85e95de046891b00816e6.zip
security/secpanel: fix the mate-only case
PR: 239832 Submitted by: Walter Schwarzenfeld <w.schwarzenfeld@utanet.at> Reported by: Jim D. <radicleparticles@gmail.com>
Notes
Notes: svn path=/head/; revision=510151
Diffstat (limited to 'security/secpanel')
-rw-r--r--security/secpanel/Makefile39
-rw-r--r--security/secpanel/files/patch-bin_secpanel2
-rw-r--r--security/secpanel/files/patch-default.config17
-rw-r--r--security/secpanel/files/patch-lib_secpanel_termdefs.txt13
-rw-r--r--security/secpanel/files/pkg-message.in13
-rw-r--r--security/secpanel/pkg-plist2
6 files changed, 78 insertions, 8 deletions
diff --git a/security/secpanel/Makefile b/security/secpanel/Makefile
index 69d277e57b65..a68deeeb1e2d 100644
--- a/security/secpanel/Makefile
+++ b/security/secpanel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= secpanel
PORTVERSION= 0.6.1
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 1
CATEGORIES= security tcl tk
MASTER_SITES= SF/${PORTNAME} \
@@ -20,12 +20,30 @@ LICENSE= GPLv2
RUN_DEPENDS= ssh-askpass:security/openssh-askpass
-WRKSRC= ${WRKDIR}/usr/local
+USES= tk:wrapper
+
+OPTIONS_RADIO= TERMINAL
+OPTIONS_RADIO_TERMINAL= GNOMETERMINAL MATETERMINAL XTERM
+OPTIONS_DEFAULT= GNOMETERMINAL
+
+GNOMETERMINAL_DESC= build with gnome-terminal
+MATETERMINAL_DESC= build with mate-terminal (you need mate-desktop)
+XTERM_DESC= build with xterm
+GNOMETERMINAL_RUN_DEPENDS= gnome-terminal>=3.0.0:x11/gnome-terminal
+MATETERMINAL_RUN_DEPENDS= mate-terminal:x11/mate-terminal
+XTERM_RUN_DEPENDS= xterm:x11/xterm
+
+WRKSRC= ${WRKDIR}/${PREFIX}
NO_BUILD= yes
+SUB_FILES= pkg-message
-USES= tk:wrapper
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MMATETERMINAL}
+USE_MATE= desktop
+.endif
-DESKTOP_ENTRIES="SecPanel" "${COMMENT}" "${PORTNAME}" "${PORTNAME}" "" false
+DESKTOP_ENTRIES="SecPanel" "${COMMENT}" "${PORTNAME}" "${PORTNAME}" "" ${FALSE}
post-patch:
@${REINPLACE_CMD} \
@@ -33,9 +51,22 @@ post-patch:
${WRKSRC}/bin/secpanel
do-install:
+.if ${PORT_OPTIONS:MMATETERMINAL}
+ ${REINPLACE_CMD} 's|set configs(termver) "Xterm"|set configs(termver) "MATE-Terminal"|' \
+ ${WRKSRC}/bin/secpanel
+ ${REINPLACE_CMD} 's|Xterm|MATE-Terminal|' \
+ ${WRKSRC}/lib/secpanel/default.config
+.elif ${PORT_OPTIONS:MGNOMETERMINAL}
+ ${REINPLACE_CMD} 's|set configs(termver) "Xterm"|set configs(termver) "GNOME-Terminal"|' \
+ ${WRKSRC}/bin/secpanel
+ ${REINPLACE_CMD} 's|Xterm|GNOME-Terminal|' \
+ ${WRKSRC}/lib/secpanel/default.config
+.endif
+
${INSTALL_SCRIPT} ${WRKSRC}/bin/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
@(cd ${WRKSRC}/lib/secpanel && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR})
@${CHMOD} u+rw ${STAGEDIR}${DATADIR}/default.config
+ ${MV} ${STAGEDIR}${DATADIR}/default.config ${STAGEDIR}${DATADIR}/default.config.sample
${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png ${STAGEDIR}${PREFIX}/share/pixmaps/
diff --git a/security/secpanel/files/patch-bin_secpanel b/security/secpanel/files/patch-bin_secpanel
index 9b10100e4ada..4fa9fc098b9b 100644
--- a/security/secpanel/files/patch-bin_secpanel
+++ b/security/secpanel/files/patch-bin_secpanel
@@ -14,7 +14,7 @@
foreach {bintag binprog} \
{sshbin ssh keygenbin ssh-keygen agentbin ssh-agent \
- addbin ssh-add askpassbin ssh-askpass scpbin scp sftpbin Filezilla termver Xterm browserbin firefox \
-+ addbin ssh-add askpassbin ssh-askpass scpbin scp sftpbin Filezilla Thunar termver Xterm browserbin firefox \
++ addbin ssh-add askpassbin ssh-askpass scpbin scp sftpbin Filezilla Thunar thunar termver Xterm browserbin firefox \
} {
if {! [info exists configs($bintag)]} {
set configs($bintag) $binprog
diff --git a/security/secpanel/files/patch-default.config b/security/secpanel/files/patch-default.config
new file mode 100644
index 000000000000..c1b476c3cee6
--- /dev/null
+++ b/security/secpanel/files/patch-default.config
@@ -0,0 +1,17 @@
+--- lib/secpanel/default.config.orig 2019-08-26 09:10:20 UTC
++++ lib/secpanel/default.config
+@@ -1,2 +1,14 @@
++set configs(sshbin) "ssh"
++set configs(keygenbin) "ssh-keygen"
++set configs(agentbin) "ssh-agent"
++set configs(addbin) "ssh-add"
++set configs(askpassbin) "ssh-askpass"
++set configs(scpbin) "scp"
++set configs(browserbin) "firefox"
++set configs(sshver) "OpenSSH"
++set configs(termver) "Xterm"
++set configs(sftpbin) "Filezilla"
++set launcher 0
+ set configs(entback) #fefefe
+ set configs(listback) #ffffff
++set configs(protectdata) "0"
diff --git a/security/secpanel/files/patch-lib_secpanel_termdefs.txt b/security/secpanel/files/patch-lib_secpanel_termdefs.txt
index 08b32c368779..3f27cbd39fff 100644
--- a/security/secpanel/files/patch-lib_secpanel_termdefs.txt
+++ b/security/secpanel/files/patch-lib_secpanel_termdefs.txt
@@ -1,6 +1,6 @@
---- lib/secpanel/termdefs.txt.orig 2017-04-08 17:52:46 UTC
+--- lib/secpanel/termdefs.txt.orig 2019-08-20 12:50:45 UTC
+++ lib/secpanel/termdefs.txt
-@@ -56,7 +56,7 @@ set termtype(XFCE-Terminal_titlepar) "--title"
+@@ -56,10 +56,16 @@ set termtype(XFCE-Terminal_titlepar) "--
set termtype(XFCE-Terminal_quotepar) ""
set termtype(XFCE-Terminal_iconpar) ""
set termtype(XFCE-Terminal_execpar) "-x"
@@ -9,3 +9,12 @@
set termtype(Putty's-Terminal_titlepar) "-title"
set termtype(Putty's-Terminal_quotepar) ""
+ set termtype(Putty's-Terminal_iconpar) ""
+ set termtype(Putty's-Terminal_execpar) "-e"
+ set termtype(Putty's-Terminal_path) "pterm"
++
++set termtype(MATE-Terminal_titlepar) "--title"
++set termtype(MATE-Terminal_quotepar) ""
++set termtype(MATE-Terminal_iconpar) ""
++set termtype(MATE-Terminal_execpar) "-e"
++set termtype(MATE-Terminal_path) "mate-terminal"
diff --git a/security/secpanel/files/pkg-message.in b/security/secpanel/files/pkg-message.in
new file mode 100644
index 000000000000..1396f6126c83
--- /dev/null
+++ b/security/secpanel/files/pkg-message.in
@@ -0,0 +1,13 @@
+
+
+################################################################################################################
+
+
+If you don't have already a default.config file, you have to copy "/usr/local/share/secpanel/default.config.sample"
+to "/usr/local/share/secpanel/default.config" Change it as you need or use the config-panel to make changes.
+
+
+#################################################################################################################
+
+
+
diff --git a/security/secpanel/pkg-plist b/security/secpanel/pkg-plist
index a8ca54d523d6..d6bbc7ee6017 100644
--- a/security/secpanel/pkg-plist
+++ b/security/secpanel/pkg-plist
@@ -2,7 +2,7 @@ bin/secpanel
share/pixmaps/secpanel.png
%%DATADIR%%/convert_history.tcl
%%DATADIR%%/convert_profile.tcl
-%%DATADIR%%/default.config
+%%DATADIR%%/default.config.sample
%%DATADIR%%/default.profile
%%DATADIR%%/dppw.tcl
%%DATADIR%%/export_profiles.tcl