aboutsummaryrefslogtreecommitdiff
path: root/security/secure_delete
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-25 12:26:18 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-25 12:26:18 +0000
commit2e9af4e385a68f925d15376df85513b042579c70 (patch)
tree12f0339cc226c3330f03223948447076d92d77ec /security/secure_delete
parent1346bf9c9bdec492755fbb2420bbf3113b304027 (diff)
downloadports-2e9af4e385a68f925d15376df85513b042579c70.tar.gz
ports-2e9af4e385a68f925d15376df85513b042579c70.zip
Support staging
Notes
Notes: svn path=/head/; revision=345978
Diffstat (limited to 'security/secure_delete')
-rw-r--r--security/secure_delete/Makefile22
1 files changed, 9 insertions, 13 deletions
diff --git a/security/secure_delete/Makefile b/security/secure_delete/Makefile
index e8c309985baa..be868748dab6 100644
--- a/security/secure_delete/Makefile
+++ b/security/secure_delete/Makefile
@@ -19,15 +19,14 @@ MAKE_JOBS_UNSAFE= yes
SUB_FILES= pkg-message
-MLINKS= srm.1 sdel.1
-MAN1= srm.1 sfill.1 sswap.1 smem.1
PORTDOCS= CHANGES FILES README secure_delete.doc usenix6-gutmann.doc
-PLIST_FILES= ${BIN_PROGRAMS:S,^,bin/,} ${BIN_SCRIPTS:S,^,bin/,} bin/sdel
+PLIST_FILES= bin/sdel bin/sfill bin/smem bin/srm bin/sswap \
+ bin/the_cleaner.sh man/man1/sfill.1.gz man/man1/smem.1.gz \
+ man/man1/srm.1.gz man/man1/sswap.1.gz
BIN_PROGRAMS= srm sfill sswap smem
BIN_SCRIPTS= the_cleaner.sh
-NO_STAGE= yes
.include <bsd.port.options.mk>
post-patch:
@@ -38,19 +37,16 @@ post-patch:
do-install:
.for i in ${BIN_PROGRAMS}
- ${INSTALL_PROGRAM} ${WRKSRC}/${i} ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/${i}.1 ${MANPREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/${i} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${i}.1 ${STAGEDIR}${MANPREFIX}/man/man1
.endfor
.for i in ${BIN_SCRIPTS}
- ${INSTALL_SCRIPT} ${WRKSRC}/${i} ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/${i} ${STAGEDIR}${PREFIX}/bin
.endfor
- ${LN} -sf srm ${PREFIX}/bin/sdel
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
+ ${LN} -sf srm ${STAGEDIR}${PREFIX}/bin/sdel
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
- @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>