aboutsummaryrefslogtreecommitdiff
path: root/security/sha1collisiondetection
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2019-02-11 19:38:47 +0000
committerSteve Wills <swills@FreeBSD.org>2019-02-11 19:38:47 +0000
commit001939be42724c9da1d0c3d40e182c498c8b2ea0 (patch)
tree028218724ce428376a763ba05c3c53203f3202ac /security/sha1collisiondetection
parent49ae18b48cae6950ee4726211fc81d5454189364 (diff)
downloadports-001939be42724c9da1d0c3d40e182c498c8b2ea0.tar.gz
ports-001939be42724c9da1d0c3d40e182c498c8b2ea0.zip
security/sha1collisiondetection: update to 1.0.3
PR: 235444 Submitted by: jharris@widomaker.com (maintainer)
Notes
Notes: svn path=/head/; revision=492732
Diffstat (limited to 'security/sha1collisiondetection')
-rw-r--r--security/sha1collisiondetection/Makefile18
-rw-r--r--security/sha1collisiondetection/distinfo6
-rw-r--r--security/sha1collisiondetection/files/patch-Makefile11
-rw-r--r--security/sha1collisiondetection/files/patch-src_main.c22
4 files changed, 44 insertions, 13 deletions
diff --git a/security/sha1collisiondetection/Makefile b/security/sha1collisiondetection/Makefile
index 4772319c0db4..df73b51e104b 100644
--- a/security/sha1collisiondetection/Makefile
+++ b/security/sha1collisiondetection/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= sha1collisiondetection
-PORTVERSION= 1.0.2
+PORTVERSION= 1.0.3
DISTVERSIONPREFIX= stable-v
CATEGORIES= security
@@ -15,28 +15,26 @@ BROKEN_aarch64= fails to compile: generic selections are a C11-specific feature
BROKEN_armv6= fails to compile: generic selections are a C11-specific feature [-Werror,-Wc11-extensions]
BROKEN_armv7= fails to compile: generic selections are a C11-specific feature [-Werror,-Wc11-extensions]
+USES= gmake libtool:build
+
USE_GITHUB= yes
GH_ACCOUNT= cr-marcstevens
-USES= gmake libtool:build
USE_LDCONFIG= yes
PLIST_FILES= bin/sha1dcsum \
bin/sha1dcsum_partialcoll \
include/sha1dc/sha1.h \
lib/libsha1detectcoll.so \
- lib/libsha1detectcoll.so.0 \
- lib/libsha1detectcoll.so.0.0.0
-
-post-patch:
- @${REINPLACE_CMD} -e 's/ -std=c90 / -std=c89 /' ${WRKSRC}/Makefile
+ lib/libsha1detectcoll.so.1 \
+ lib/libsha1detectcoll.so.1.0.0
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/.libs/sha1dcsum* ${STAGEDIR}${PREFIX}/bin
@${MKDIR} ${STAGEDIR}${PREFIX}/include/sha1dc
${INSTALL_DATA} ${WRKSRC}/lib/sha1.h ${STAGEDIR}${PREFIX}/include/sha1dc
- ${INSTALL_LIB} ${WRKSRC}/bin/.libs/libsha1detectcoll.so.0.0.0 ${STAGEDIR}${PREFIX}/lib
- ${LN} -sf libsha1detectcoll.so.0.0.0 ${STAGEDIR}${PREFIX}/lib/libsha1detectcoll.so
- ${LN} -sf libsha1detectcoll.so.0.0.0 ${STAGEDIR}${PREFIX}/lib/libsha1detectcoll.so.0
+ ${INSTALL_LIB} ${WRKSRC}/bin/.libs/libsha1detectcoll.so.1.0.0 ${STAGEDIR}${PREFIX}/lib
+ ${LN} -sf libsha1detectcoll.so.1.0.0 ${STAGEDIR}${PREFIX}/lib/libsha1detectcoll.so
+ ${LN} -sf libsha1detectcoll.so.1.0.0 ${STAGEDIR}${PREFIX}/lib/libsha1detectcoll.so.1
.include <bsd.port.mk>
diff --git a/security/sha1collisiondetection/distinfo b/security/sha1collisiondetection/distinfo
index dd8c444e48b7..3fffa0979677 100644
--- a/security/sha1collisiondetection/distinfo
+++ b/security/sha1collisiondetection/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1489459273
-SHA256 (cr-marcstevens-sha1collisiondetection-stable-v1.0.2_GH0.tar.gz) = ab1a5624d12417b5af9ffe6662546b6932c39c0e4c4bef822851a2d0e53df790
-SIZE (cr-marcstevens-sha1collisiondetection-stable-v1.0.2_GH0.tar.gz) = 778302
+TIMESTAMP = 1549146242
+SHA256 (cr-marcstevens-sha1collisiondetection-stable-v1.0.3_GH0.tar.gz) = 77a1c2b2a4fbe4f78de288fa4831ca63938c3cb84a73a92c79f436238bd9ac07
+SIZE (cr-marcstevens-sha1collisiondetection-stable-v1.0.3_GH0.tar.gz) = 780306
diff --git a/security/sha1collisiondetection/files/patch-Makefile b/security/sha1collisiondetection/files/patch-Makefile
new file mode 100644
index 000000000000..1b96c2da9120
--- /dev/null
+++ b/security/sha1collisiondetection/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig 2017-03-27 16:11:23 UTC
++++ Makefile
+@@ -33,7 +33,7 @@ INSTALL ?= install
+ endif
+
+
+-CFLAGS=-O2 -Wall -Werror -Wextra -pedantic -std=c90 -Ilib
++CFLAGS=-O2 -Wall -Werror -Wextra -pedantic -Ilib
+ LDFLAGS=
+
+ LT_CC:=$(LIBTOOL) --tag=CC --mode=compile $(CC)
diff --git a/security/sha1collisiondetection/files/patch-src_main.c b/security/sha1collisiondetection/files/patch-src_main.c
new file mode 100644
index 000000000000..8526ee628600
--- /dev/null
+++ b/security/sha1collisiondetection/files/patch-src_main.c
@@ -0,0 +1,22 @@
+--- src/main.c.orig 2017-03-27 16:11:23 UTC
++++ src/main.c
+@@ -9,6 +9,8 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <libgen.h>
++#include <limits.h> /* for NAME_MAX, max bytes in a file name */
++#include <assert.h> /* for assert() macro */
+
+ #include "sha1.h"
+
+@@ -23,7 +25,9 @@ int main(int argc, char** argv)
+
+ if (argc < 2)
+ {
+- printf("Usage: %s <file>\n", basename(argv[0]));
++assert (sizeof(buffer) >= NAME_MAX); /* reuse buffer[] for newly-POSIX-compliant, thread-safe basename() */
++ (void) strlcpy (buffer, argv[0], sizeof (buffer));
++ printf("Usage: %s <file>\n", basename(buffer));
+ return 1;
+ }
+