aboutsummaryrefslogtreecommitdiff
path: root/security/signify
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2014-07-15 17:48:40 +0000
committerKurt Jaeger <pi@FreeBSD.org>2014-07-15 17:48:40 +0000
commita6d0bf0d28888495ac5a3e794e54fca8a99b0d51 (patch)
tree21fc53b2f5f922def8d600dccbfe11d02ce3c4c9 /security/signify
parent1c7521fb6280b81cb866d0d843dd257b0f91a65d (diff)
downloadports-a6d0bf0d28888495ac5a3e794e54fca8a99b0d51.tar.gz
ports-a6d0bf0d28888495ac5a3e794e54fca8a99b0d51.zip
New port: security/signify
'signify' from OpenBSD as of July 15 2014, with the necessary plumbing cobbled together from the OpenBSD CVS to make it compile under Linux. It can be used to verify the LibreSSL distfile from the OpenBSD archive. Since the CVS itself is not signed, the author provides no guarantees. WWW: http://www.fefe.de/signify/
Notes
Notes: svn path=/head/; revision=361987
Diffstat (limited to 'security/signify')
-rw-r--r--security/signify/Makefile19
-rw-r--r--security/signify/distinfo2
-rw-r--r--security/signify/files/patch-Makefile19
-rw-r--r--security/signify/files/patch-readpassphrase.c13
-rw-r--r--security/signify/pkg-descr6
-rw-r--r--security/signify/pkg-plist1
6 files changed, 60 insertions, 0 deletions
diff --git a/security/signify/Makefile b/security/signify/Makefile
new file mode 100644
index 000000000000..c944bc1a4e52
--- /dev/null
+++ b/security/signify/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+
+PORTNAME= signify
+PORTVERSION= 1
+CATEGORIES= security
+MASTER_SITES= http://www.fefe.de/signify/
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= pi@FreeBSD.org
+COMMENT= OpenBSD signify ported by fefe
+
+LICENSE= BSD2CLAUSE
+
+USES= gmake
+
+do-install:
+ ${CP} ${WRKSRC}/signify ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/security/signify/distinfo b/security/signify/distinfo
new file mode 100644
index 000000000000..4df000472bb0
--- /dev/null
+++ b/security/signify/distinfo
@@ -0,0 +1,2 @@
+SHA256 (signify.tar.gz) = 72cbe892edbe8e14b314fc91f6422d6cede8f689a2db4d8b34d9bfaed56ff4ec
+SIZE (signify.tar.gz) = 88236
diff --git a/security/signify/files/patch-Makefile b/security/signify/files/patch-Makefile
new file mode 100644
index 000000000000..deaadf313eec
--- /dev/null
+++ b/security/signify/files/patch-Makefile
@@ -0,0 +1,19 @@
+--- Makefile.orig 2014-07-15 19:24:29.000000000 +0200
++++ Makefile 2014-07-15 19:29:34.000000000 +0200
+@@ -1,9 +1,10 @@
++
+ all: signify
+
+ SRCS=signify.c ohash.c strlcpy.c base64.c explicit_bzero.c readpassphrase.c bcrypt_pbkdf.c ed25519.c sc25519.c ge25519.c fe25519.c arc4random.c blowfish.c hash.c blocks.c getentropy.c verify.c sha2.c shafile.c
+ OBJS=$(patsubst %.c,%.o,$(SRCS))
+
+-CC=gcc -D_GNU_SOURCE -D_BSD_SOURCE -DHAVE_SYS_SYSCALL_H
++CC=clang -D_GNU_SOURCE -D_BSD_SOURCE -DHAVE_SYS_SYSCALL_H
+ CFLAGS=-Os -pipe
+ LDFLAGS=-s
+ LDLIBS=-lcrypto
+@@ -25,3 +26,4 @@
+
+ tar:
+ cd .. && tar czf signify.tar.gz $(patsubst %,signify/%,$(SRCS) blf.h chacha_private.h crypto_api.h fe25519.h ge25519.h ohash.h readpassphrase.h sc25519.h sha2.h util.h ge25519_base.data Makefile)
++
diff --git a/security/signify/files/patch-readpassphrase.c b/security/signify/files/patch-readpassphrase.c
new file mode 100644
index 000000000000..f05dbf6758a5
--- /dev/null
+++ b/security/signify/files/patch-readpassphrase.c
@@ -0,0 +1,13 @@
+--- readpassphrase.c-orig 2014-07-15 19:27:23.000000000 +0200
++++ readpassphrase.c 2014-07-15 19:28:20.000000000 +0200
+@@ -32,6 +32,10 @@
+ #include <unistd.h>
+ #include <readpassphrase.h>
+
++#ifndef _NSIG
++#define _NSIG NSIG
++#endif
++
+ static volatile sig_atomic_t signo[_NSIG];
+
+ static void handler(int);
diff --git a/security/signify/pkg-descr b/security/signify/pkg-descr
new file mode 100644
index 000000000000..f192942fe094
--- /dev/null
+++ b/security/signify/pkg-descr
@@ -0,0 +1,6 @@
+'signify' from OpenBSD as of July 15 2014, with the necessary plumbing
+cobbled together from the OpenBSD CVS to make it compile under Linux.
+
+Since the CVS itself is not signed, the author provides no guarantees.
+
+WWW: http://www.fefe.de/signify/
diff --git a/security/signify/pkg-plist b/security/signify/pkg-plist
new file mode 100644
index 000000000000..f84524a19fe6
--- /dev/null
+++ b/security/signify/pkg-plist
@@ -0,0 +1 @@
+bin/signify