aboutsummaryrefslogtreecommitdiff
path: root/security/skipfish
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2014-05-11 18:37:51 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2014-05-11 18:37:51 +0000
commitc23e1f2e6594e376d12d8b249bdb12bd1336772e (patch)
treece9b298870b55fc4d112adf9446cebfc7374f829 /security/skipfish
parentabf8087a19f4a0737790ca4108ccf798839dd93f (diff)
downloadports-c23e1f2e6594e376d12d8b249bdb12bd1336772e.tar.gz
ports-c23e1f2e6594e376d12d8b249bdb12bd1336772e.zip
- Add STAGE support
- Bump PORTREVISION
Notes
Notes: svn path=/head/; revision=353723
Diffstat (limited to 'security/skipfish')
-rw-r--r--security/skipfish/Makefile23
-rw-r--r--security/skipfish/pkg-plist1
2 files changed, 10 insertions, 14 deletions
diff --git a/security/skipfish/Makefile b/security/skipfish/Makefile
index 5ee17e081986..38b69d5f666b 100644
--- a/security/skipfish/Makefile
+++ b/security/skipfish/Makefile
@@ -1,8 +1,9 @@
-# Created by: rpsfa@rit.edu
+# Created by: Ryan Steinmetz <rpsfa@rit.edu>
# $FreeBSD$
PORTNAME= skipfish
PORTVERSION= 2.10b
+PORTREVISION= 1
CATEGORIES= security www
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
EXTRACT_SUFX= .tgz
@@ -19,13 +20,10 @@ LIB_DEPENDS= idn:${PORTSDIR}/dns/libidn \
USE_GMAKE= yes
SUB_FILES= pkg-message
-MAN1= skipfish.1
-
.if !defined(NOPORTDOCS)
PORTDOCS= README COPYING ChangeLog
.endif
-NO_STAGE= yes
.include <bsd.port.pre.mk>
post-patch:
@@ -33,19 +31,16 @@ post-patch:
-e 's:"assets":"${DATADIR}/assets":' ${WRKSRC}/src/config.h
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/skipfish ${PREFIX}/bin/skipfish
- ${INSTALL_SCRIPT} ${WRKSRC}/tools/sfscandiff ${PREFIX}/bin/sfscandiff
- ${INSTALL_MAN} ${WRKSRC}/doc/skipfish.1 ${PREFIX}/man/man1
- (cd ${WRKSRC}/assets/ && ${COPYTREE_SHARE} . ${DATADIR}/assets/)
- (cd ${WRKSRC}/dictionaries/ && ${COPYTREE_SHARE} . ${DATADIR}/dictionaries/)
+ ${INSTALL_PROGRAM} ${WRKSRC}/skipfish ${STAGEDIR}${PREFIX}/bin/skipfish
+ ${INSTALL_SCRIPT} ${WRKSRC}/tools/sfscandiff ${STAGEDIR}${PREFIX}/bin/sfscandiff
+ ${INSTALL_MAN} ${WRKSRC}/doc/skipfish.1 ${STAGEDIR}${PREFIX}/man/man1
+ (cd ${WRKSRC}/assets/ && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/assets/)
+ (cd ${WRKSRC}/dictionaries/ && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/dictionaries/)
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
. for doc in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${doc} ${STAGEDIR}${DOCSDIR}
. endfor
.endif
-post-install:
- @${CAT} ${PKGMESSAGE}
-
.include <bsd.port.post.mk>
diff --git a/security/skipfish/pkg-plist b/security/skipfish/pkg-plist
index 5828d2f1c959..ebc3c1dc4ed9 100644
--- a/security/skipfish/pkg-plist
+++ b/security/skipfish/pkg-plist
@@ -28,6 +28,7 @@ bin/sfscandiff
%%DATADIR%%/dictionaries/medium.wl
%%DATADIR%%/dictionaries/extensions-only.wl
%%DATADIR%%/dictionaries/minimal.wl
+man/man1/skipfish.1.gz
@dirrm %%DATADIR%%/dictionaries
@dirrm %%DATADIR%%/assets
@dirrm %%DATADIR%%