aboutsummaryrefslogtreecommitdiff
path: root/security/sks
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2014-07-06 09:28:30 +0000
committerJohan van Selst <johans@FreeBSD.org>2014-07-06 09:28:30 +0000
commitbd1b08fbd28e37e8869f29f0103f091a107210c6 (patch)
treeb7fa3de3c8c7e7e3427ef2906bd4000e8ed73c0f /security/sks
parentfa7348cd08ff1f3e2f5c2fda5e6dc2007e7c76c4 (diff)
downloadports-bd1b08fbd28e37e8869f29f0103f091a107210c6.tar.gz
ports-bd1b08fbd28e37e8869f29f0103f091a107210c6.zip
Fix build on FreeBSD 9 (and earlier)
While here, merge another patch from files to makefile to avoid patching the same file from multiple locations PR: ports/191643 Submitted by: Dan Lukes
Notes
Notes: svn path=/head/; revision=360866
Diffstat (limited to 'security/sks')
-rw-r--r--security/sks/Makefile6
-rw-r--r--security/sks/files/patch-Makefile15
2 files changed, 4 insertions, 17 deletions
diff --git a/security/sks/Makefile b/security/sks/Makefile
index 0f29dfef7161..0aac403e1862 100644
--- a/security/sks/Makefile
+++ b/security/sks/Makefile
@@ -31,8 +31,10 @@ post-extract:
@cd ${WRKSRC} && ${RM} -f .depend
post-patch:
- @${REINPLACE_CMD} '/^CC=/d; /^CFLAGS=/s/=/+=/' \
- ${WRKSRC}/Makefile ${WRKSRC}/bdb/Makefile
+ @${REINPLACE_CMD} -Ee '/^CC=/d; /^CFLAGS=/s/=/+=/' \
+ -e '/^install/,$$s/\$$\((PREFIX|MANDIR)\)/$$(DESTDIR)&/' \
+ -e '/patch/s/-p 0/-p0/' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e '/^CC=/d; /^CFLAGS=/s/=/+=/' ${WRKSRC}/bdb/Makefile
pre-build:
@cd ${WRKSRC} && test -f .depend || ${MAKE_CMD} dep
diff --git a/security/sks/files/patch-Makefile b/security/sks/files/patch-Makefile
deleted file mode 100644
index 5ba316da3b78..000000000000
--- a/security/sks/files/patch-Makefile
+++ /dev/null
@@ -1,15 +0,0 @@
---- Makefile.orig 2012-10-07 19:59:39.000000000 +0000
-+++ Makefile
-@@ -126,10 +126,8 @@ keyMerge.cmx: keyMerge.ml
- # Special targets
-
- install:
-- mkdir -p $(PREFIX)/bin
-- install sks_build.sh sks sks_add_mail $(PREFIX)/bin
-- mkdir -p $(MANDIR)/man8
-- install sks.8.gz $(MANDIR)/man8
-+ install sks_build.sh sks sks_add_mail $(DESTDIR)$(PREFIX)/bin
-+ install sks.8.gz $(DESTDIR)$(MANDIR)/man8
-
- install.bc:
- mkdir -p $(PREFIX)/bin