aboutsummaryrefslogtreecommitdiff
path: root/security/smtpscan
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-12-17 17:19:48 +0000
committerMathieu Arnold <mat@FreeBSD.org>2015-12-17 17:19:48 +0000
commit7c47779cb9cc1f12908949c26b831e944047ed17 (patch)
treecc6e929ebf67eee2cc8ce1692ea0663387b3a559 /security/smtpscan
parentb4c4d6656e7b913544a3cbd1bea7f40f7cad2e74 (diff)
downloadports-7c47779cb9cc1f12908949c26b831e944047ed17.tar.gz
ports-7c47779cb9cc1f12908949c26b831e944047ed17.zip
Fix usage of ${PERL5}.
${PERL5} points to a specific version of perl, say, perl5.22.1, it is fine to use it in a ports Makefile to do Perly things, but ports using it must use ${PERL}, that points to /usr/local/bin/perl so that if the minor version is updated, the shebang keep working. While there, make some ports use shebangfix, regen a few patches, and bump PORTREVISION where a shebang went from PERL5 to PERL. PR: 205367 With hat: portmgr Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=403913
Diffstat (limited to 'security/smtpscan')
-rw-r--r--security/smtpscan/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/security/smtpscan/Makefile b/security/smtpscan/Makefile
index 5c119baffe5a..2617e8bc5b82 100644
--- a/security/smtpscan/Makefile
+++ b/security/smtpscan/Makefile
@@ -18,8 +18,9 @@ RUN_DEPENDS= p5-Net-DNS>=0:${PORTSDIR}/dns/p5-Net-DNS
WRKSRC= ${WRKDIR}/${PORTNAME}
NO_BUILD= yes
-USES= perl5
+USES= perl5 shebangfix
USE_PERL5= run
+SHEBANG_FILES= src/smtpscan
PLIST_FILES= bin/smtpscan \
man/man1/smtpscan.1.gz \
@@ -28,8 +29,7 @@ PLIST_FILES= bin/smtpscan \
post-patch:
@${REINPLACE_CMD} -e \
- 's|^#!.*|#!${PERL}| ; \
- s|/usr/local/share|${PREFIX}/share| ; \
+ 's|/usr/local/share|${PREFIX}/share| ; \
s|@VERSION@|${PORTVERSION}|' ${WRKSRC}/src/smtpscan
@${REINPLACE_CMD} -e \
's|@VERSION@|${PORTVERSION}| ; \