aboutsummaryrefslogtreecommitdiff
path: root/security/snort
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-01-20 09:14:10 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-01-20 09:14:10 +0000
commite587cce18d218023990f567c4bb37a57713f2408 (patch)
tree4b2037efa311b2c88ad6376374840e8f02a6330b /security/snort
parenta53757871183c4b0b05bc2d4a59ca5cb50273fa4 (diff)
downloadports-e587cce18d218023990f567c4bb37a57713f2408.tar.gz
ports-e587cce18d218023990f567c4bb37a57713f2408.zip
Here come the patches!
* Add ghostscript knobs [1] * Add per-port persistent build options with a menu-driven front-end [2] * Allow porters to override the message generated when do-configure fails [3] * Add patch to obviate many pkg-plist files [4] * Fix the PKG_DBDIR comment [5] * Make ports framework more robust with regard to make index [6] * Add new command macros to bsd.port.mk [7] * Remove direct command use from bsd.port.mk [8] * Make the ports system respect WITHOUT_CPU_CFLAGS [9] * Break the SDL code out into bsd.sdl.mk [10] * Add working support for USE_SIZE [11] * Fix RANDOMIZE_MASTER_SITES on -CURRENT [12] * Convert some spaces to tabs [13] * Add new physcial categories accessibility and x11-themes [14] * Speed up GNU configure scripts [15] * Remove "//" from MLINKS items in PLISTs and fix make -s install and make -s deinstall [16] * Be more specific about looking for files in distinfo [17] * Add new run-autotools target, and resort configure targets [18] * Make CONFLICTS compare prefix for installed packages and PREFIX [19] * Change directory to ${.CURDIR} before running certain make commands [20] * When INSTALL_AS_USER is set, run ldconfig with failures ignored [21] * Speed up the security check phase [22] * Fix some corner cases in the PORTDOCS code [23] * Add a new DEPRECATED macro [24] * Make INDEX breakage more informative [25] Look for a full write-up to follow on ports@ and ports-developers@. PR: 36112 [1] 59909 [4] 61351 [6] 59058 [7] 59058 [8] 59493 [9] 55494 [10] 59058 [11] 59315 [12] 59058 [13] 59811 [15] 59058 [16] 59058 [17] 60882 [18] 58149 [19] 59058 [20] 61133 [21] 55331 [22] 59070 [23] 59362 [24] 59626 [25] Submitted by: linimon [1] eivind [2] marcus [3] trevor [4] gerald [5] linimon [6] eik [7] eik [8] jeh [9] edwin [10] eik [11] Sergey Matveychuk <sem@ciam.ru> [12] eik [13] trevor gnome [14] adamw [15] eik [16] eik [17] edwin [18] clement [19] eik [20] edwin lev [21] Eugene M. Kim <ab@astralblue.com> [22] eik [23] linimon [24] eik [25]
Notes
Notes: svn path=/head/; revision=98634
Diffstat (limited to 'security/snort')
-rw-r--r--security/snort/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/security/snort/Makefile b/security/snort/Makefile
index 64d137170a45..9b89b934bd80 100644
--- a/security/snort/Makefile
+++ b/security/snort/Makefile
@@ -60,6 +60,13 @@ MAN8= snort.8
DOCS= ChangeLog doc/AUTHORS doc/BUGS doc/CREDITS doc/FAQ doc/NEWS \
doc/README* doc/TODO doc/USAGE doc/snort_manual.pdf
+OPTIONS= FLEXRESP "Flexible response to events" off \
+ MYSQL "Mysql logging" off \
+ ODBC "ODBC logging" off \
+ POSTGRES "Postgresql logging" off
+
+.include <bsd.port.pre.mk>
+
post-patch:
${REINPLACE_CMD} "s,%%PREFIX%%,${PREFIX}," ${WRKSRC}/src/snort.c
@@ -92,4 +99,4 @@ post-install:
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>