aboutsummaryrefslogtreecommitdiff
path: root/security/softether/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-07-19 11:04:13 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-07-19 11:04:13 +0000
commitf899c758a653ca8ff2f8a63aafcb2519a0b524ed (patch)
treebe6eebf3e77ddf9fcf383081091d8b8b336dd71c /security/softether/Makefile
parent74d26774f830684ae21247061aa4bd7dabbe6527 (diff)
downloadports-f899c758a653ca8ff2f8a63aafcb2519a0b524ed.tar.gz
ports-f899c758a653ca8ff2f8a63aafcb2519a0b524ed.zip
When there is a do-install target, do not use a post-install target, do
everything at once. Sometime, rename post-install into a options helper target. I did not fix ports that were such a mess that I could not figure out what they really wanted to do. I also did not change ports that had some version of an auto-plist code in post-install, for the same reason. With hat: portmgr Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=418767
Diffstat (limited to 'security/softether/Makefile')
-rw-r--r--security/softether/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/security/softether/Makefile b/security/softether/Makefile
index 598c07fd08dc..97be83a81ea6 100644
--- a/security/softether/Makefile
+++ b/security/softether/Makefile
@@ -68,17 +68,14 @@ post-extract:
# into ${PREFIX}/sbin
do-install:
${MKDIR} ${STAGEDIR}/${PREFIX}/libexec/softether
- ${INSTALL_SCRIPT} ${WRKSRC}/bin/vpnbridge/vpnbridge ${STAGEDIR}/${PREFIX}/libexec/${PORTNAME}/vpnbridge
- ${INSTALL_SCRIPT} ${WRKSRC}/bin/vpnclient/vpnclient ${STAGEDIR}/${PREFIX}/libexec/${PORTNAME}/vpnclient
- ${INSTALL_SCRIPT} ${WRKSRC}/bin/vpncmd/vpncmd ${STAGEDIR}/${PREFIX}/libexec/${PORTNAME}/vpncmd
- ${INSTALL_SCRIPT} ${WRKSRC}/bin/vpnserver/vpnserver ${STAGEDIR}/${PREFIX}/libexec/${PORTNAME}/vpnserver
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/vpnbridge/vpnbridge ${STAGEDIR}/${PREFIX}/libexec/${PORTNAME}/vpnbridge
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/vpnclient/vpnclient ${STAGEDIR}/${PREFIX}/libexec/${PORTNAME}/vpnclient
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/vpncmd/vpncmd ${STAGEDIR}/${PREFIX}/libexec/${PORTNAME}/vpncmd
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/vpnserver/vpnserver ${STAGEDIR}/${PREFIX}/libexec/${PORTNAME}/vpnserver
${INSTALL_DATA} ${WRKSRC}/bin/vpnserver/hamcore.se2 ${STAGEDIR}/${PREFIX}/libexec/${PORTNAME}/hamcore.se2
${INSTALL_SCRIPT} ${WRKDIR}/vpncmd ${STAGEDIR}/${PREFIX}/sbin/vpncmd
-post-install:
-.for i in vpnbridge vpnclient vpncmd vpnserver
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/libexec/${PORTNAME}/${i}
-.endfor
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for doc in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${doc} ${STAGEDIR}${DOCSDIR}