aboutsummaryrefslogtreecommitdiff
path: root/security/softether
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2015-11-02 11:59:59 +0000
committerKurt Jaeger <pi@FreeBSD.org>2015-11-02 11:59:59 +0000
commit48118583579c4a46a565dbf636104e685c8ed038 (patch)
treeb557a22b1d4338030c398317f778f64d7d63d948 /security/softether
parent56dbdca86126d5013c6ffb7a6a48b6e409123741 (diff)
downloadports-48118583579c4a46a565dbf636104e685c8ed038.tar.gz
ports-48118583579c4a46a565dbf636104e685c8ed038.zip
security/softether: fixes
- iconv build - build with No-SSLv3 - MAKE_JOBS_UNSAFE=yes unconditionally PR: 203688, 204184 Submitted by: net@arrishq.net (maintainer)
Notes
Notes: svn path=/head/; revision=400650
Diffstat (limited to 'security/softether')
-rw-r--r--security/softether/Makefile10
-rw-r--r--security/softether/files/patch-src__Mayaqua__Network.c19
2 files changed, 23 insertions, 6 deletions
diff --git a/security/softether/Makefile b/security/softether/Makefile
index 5af109354fe0..fcfaaee8b0b8 100644
--- a/security/softether/Makefile
+++ b/security/softether/Makefile
@@ -2,6 +2,7 @@
PORTNAME= softether
PORTVERSION= 4.18.9570
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://www.softether-download.com/files/softether/v4.18-9570-rtm-2015.07.26-tree/Source_Code/
DISTNAME= ${PORTNAME}-src-v4.18-9570-rtm
@@ -24,6 +25,7 @@ DOS2UNIX_FILES= AUTHORS.TXT ChangeLog LICENSE README THIRD_PARTY.TXT \
src/Cedar/Server.c \
src/Mayaqua/Cfg.c \
src/Mayaqua/Cfg.h \
+ src/Mayaqua/Network.c \
src/Mayaqua/Kernel.c \
src/Mayaqua/Table.h \
src/Mayaqua/Unix.c
@@ -33,9 +35,10 @@ OPTIONS_DEFINE= DOCS
ONLY_FOR_ARCHS= i386 amd64
USE_OPENSSL= yes
-USES= dos2unix gmake iconv ncurses readline
+USES= dos2unix gmake iconv:translit iconv:wchar_t ncurses readline
USE_RC_SUBR= softether_bridge softether_client softether_server
SUB_FILES= vpncmd
+MAKE_JOBS_UNSAFE= yes
# a pity the source directory has such a naming scheme, but well
WRKSRC= ${WRKDIR}/v4.18-9570
@@ -47,11 +50,6 @@ ALL_TARGET= build
# requires OpenSSL from ports
.if ${OSVERSION} < 1000000
WITH_OPENSSL_PORT= yes
-MAKE_JOBS_UNSAFE= yes
-.endif
-
-.if ${OSVERSION} >= 1000000
-BUILD_DEPENDS= libiconv>=1.14:${PORTSDIR}/converters/libiconv
.endif
# skip configure at all and copy the corresponding Makefile in place
diff --git a/security/softether/files/patch-src__Mayaqua__Network.c b/security/softether/files/patch-src__Mayaqua__Network.c
new file mode 100644
index 000000000000..f80f71be401c
--- /dev/null
+++ b/security/softether/files/patch-src__Mayaqua__Network.c
@@ -0,0 +1,19 @@
+--- src/Mayaqua/Network.c.orig 2015-07-26 06:38:18 UTC
++++ src/Mayaqua/Network.c
+@@ -12920,7 +12920,16 @@ bool StartSSLEx(SOCK *sock, X *x, K *pri
+ {
+ if (client_tls == false)
+ {
++#ifndef OPENSSL_NO_SSL3
+ SSL_CTX_set_ssl_version(ssl_ctx, SSLv3_method());
++#else
++ SSL_CTX_set_ssl_version(ssl_ctx, SSLv23_method());
++ SSL_CTX_set_options(ssl_ctx, SSL_OP_NO_SSLv2 | SSL_OP_NO_TLSv1
++#ifdef SSL_OP_NO_TLSv1_2
++ | SSL_OP_NO_TLSv1_1 | SSL_OP_NO_TLSv1_2
++#endif
++ );
++#endif
+ }
+ else
+ {