aboutsummaryrefslogtreecommitdiff
path: root/security/sshguard/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2007-03-01 01:36:56 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2007-03-01 01:36:56 +0000
commit761d545251c35122518ddaa4e969a4e9433e71e6 (patch)
treed318a23a5ba17badfcd8b286c9ff76fe7710260c /security/sshguard/Makefile
parent062a21e7055ae183b497f4ccb1003de71b6188f5 (diff)
downloadports-761d545251c35122518ddaa4e969a4e9433e71e6.tar.gz
ports-761d545251c35122518ddaa4e969a4e9433e71e6.zip
Add sshguard 0.91, protect networked hosts from brute force attacks
against ssh. PR: ports/109439 Submitted by: Mij <mij at bitchx.it>
Notes
Notes: svn path=/head/; revision=186233
Diffstat (limited to 'security/sshguard/Makefile')
-rw-r--r--security/sshguard/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/security/sshguard/Makefile b/security/sshguard/Makefile
new file mode 100644
index 000000000000..8698ebf78777
--- /dev/null
+++ b/security/sshguard/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: sshguard
+# Date created: 2007-02-22
+# Whom: Mij <mij@bitchx.it>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sshguard
+PORTVERSION= 0.91
+CATEGORIES= security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= mij@bitchx.it
+COMMENT= Protect networked hosts from brute force attacks against ssh
+
+PLIST_FILES= sbin/sshguard
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+
+OPTIONS= PF "Use PF as firewall backend" on \
+ IPFW "Use IPFW as firewall backend" off
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITH_PF) && defined(WITH_IPFW)
+# compile with IPFW support
+CONFIGURE_ARGS+= --with-firewall=ipfw
+.else
+# compile with PF support
+CONFIGURE_ARGS+= --with-firewall=pf
+.endif
+
+post-install:
+ # spare pkg-message
+ ${ECHO_MSG} " Sshguard installed successfully."
+ ${ECHO_MSG} "Make it active by putting in /etc/syslog.conf something like:"
+ ${ECHO_MSG} " auth.info;authpriv.info |exec ${PREFIX}/sbin/sshguard"
+ ${ECHO_MSG} "Otherwise, run sshguard standalone with (as root):"
+ ${ECHO_MSG} " tail -n 0 -f /var/log/auth.log | ${PREFIX}/sbin/sshguard"
+
+.include <bsd.port.post.mk>