aboutsummaryrefslogtreecommitdiff
path: root/security/step-certificates/Makefile
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2020-07-02 07:20:08 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2020-07-02 07:20:08 +0000
commitc10c0128beb0eb56db6b77a77d8596e2ad50f9bb (patch)
treebf28f0b6d84e9fdd86776a52be9a5eaff9b198d2 /security/step-certificates/Makefile
parent2fb89f0364768f4eede18cf7a764c6439dfe8097 (diff)
downloadports-c10c0128beb0eb56db6b77a77d8596e2ad50f9bb.tar.gz
ports-c10c0128beb0eb56db6b77a77d8596e2ad50f9bb.zip
Update to 0.14.5
PR: 247704 Submitted by: Markus Wipp <mw@wipp.bayern> (maintainer)
Notes
Notes: svn path=/head/; revision=541018
Diffstat (limited to 'security/step-certificates/Makefile')
-rw-r--r--security/step-certificates/Makefile15
1 files changed, 10 insertions, 5 deletions
diff --git a/security/step-certificates/Makefile b/security/step-certificates/Makefile
index 1e8ab2232c30..36df33c54a52 100644
--- a/security/step-certificates/Makefile
+++ b/security/step-certificates/Makefile
@@ -2,7 +2,7 @@
PORTNAME= step-certificates
DISTVERSIONPREFIX=v
-DISTVERSION= 0.14.4
+DISTVERSION= 0.14.5
CATEGORIES= security
MAINTAINER= mw@wipp.bayern
@@ -11,6 +11,8 @@ COMMENT= Smallstep step-ca certificates server
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
+BUILD_DEPENDS= pcsc-lite>0:devel/pcsc-lite
+LIB_DEPENDS= libpcsclite.so:devel/pcsc-lite
RUN_DEPENDS= step:security/step-cli
USES= go:modules
@@ -35,6 +37,7 @@ GH_TUPLE= \
Masterminds:goutils:v1.1.0:masterminds_goutils/vendor/github.com/Masterminds/goutils \
Masterminds:semver:v3.0.1:masterminds_semver/vendor/github.com/Masterminds/semver/v3 \
Masterminds:sprig:v3.0.0:masterminds_sprig/vendor/github.com/Masterminds/sprig/v3 \
+ aws:aws-sdk-go:v1.30.29:aws_aws_sdk_go/vendor/github.com/aws/aws-sdk-go \
census-instrumentation:opencensus-go:v0.22.2:census_instrumentation_opencensus_go/vendor/go.opencensus.io \
cespare:xxhash:v1.1.0:cespare_xxhash/vendor/github.com/cespare/xxhash \
chzyer:readline:2972be24d48e:chzyer_readline/vendor/github.com/chzyer/readline \
@@ -46,11 +49,12 @@ GH_TUPLE= \
dustin:go-humanize:v1.0.0:dustin_go_humanize/vendor/github.com/dustin/go-humanize \
etcd-io:bbolt:v1.3.2:etcd_io_bbolt/vendor/go.etcd.io/bbolt \
go-chi:chi:v4.0.2:go_chi_chi/vendor/github.com/go-chi/chi \
- go-sql-driver:mysql:v1.4.1:go_sql_driver_mysql/vendor/github.com/go-sql-driver/mysql \
+ go-piv:piv-go:a3e5767:go_piv_piv_go/vendor/github.com/go-piv/piv-go \
+ go-sql-driver:mysql:v1.5.0:go_sql_driver_mysql/vendor/github.com/go-sql-driver/mysql \
golang:appengine:v1.6.5:golang_appengine/vendor/google.golang.org/appengine \
golang:crypto:0ec3e9974c59:golang_crypto/vendor/golang.org/x/crypto \
golang:groupcache:215e87163ea7:golang_groupcache/vendor/github.com/golang/groupcache \
- golang:net:c0dbc17a3553:golang_net/vendor/golang.org/x/net \
+ golang:net:16171245cfb2:golang_net/vendor/golang.org/x/net \
golang:oauth2:858c2ad4c8b6:golang_oauth2/vendor/golang.org/x/oauth2 \
golang:protobuf:v1.3.2:golang_protobuf/vendor/github.com/golang/protobuf \
golang:snappy:v0.0.1:golang_snappy/vendor/github.com/golang/snappy \
@@ -65,6 +69,7 @@ GH_TUPLE= \
grpc:grpc-go:v1.26.0:grpc_grpc_go/vendor/google.golang.org/grpc \
huandu:xstrings:v1.2.0:huandu_xstrings/vendor/github.com/huandu/xstrings \
imdario:mergo:v0.3.7:imdario_mergo/vendor/github.com/imdario/mergo \
+ jmespath:go-jmespath:v0.3.0:jmespath_go_jmespath/vendor/github.com/jmespath/go-jmespath \
juju:ansiterm:720a0952cc2a:juju_ansiterm/vendor/github.com/juju/ansiterm \
konsorten:go-windows-terminal-sequences:v1.0.2:konsorten_go_windows_terminal_sequences/vendor/github.com/konsorten/go-windows-terminal-sequences \
lunixbochs:vtclean:v1.0.0:lunixbochs_vtclean/vendor/github.com/lunixbochs/vtclean \
@@ -74,14 +79,14 @@ GH_TUPLE= \
mitchellh:copystructure:v1.0.0:mitchellh_copystructure/vendor/github.com/mitchellh/copystructure \
mitchellh:reflectwalk:v1.0.0:mitchellh_reflectwalk/vendor/github.com/mitchellh/reflectwalk \
newrelic:go-agent:v2.15.0:newrelic_go_agent/vendor/github.com/newrelic/go-agent \
- pkg:errors:v0.8.1:pkg_errors/vendor/github.com/pkg/errors \
+ pkg:errors:v0.9.1:pkg_errors/vendor/github.com/pkg/errors \
rs:xid:v1.2.1:rs_xid/vendor/github.com/rs/xid \
russross:blackfriday:v2.0.1:russross_blackfriday/vendor/github.com/russross/blackfriday/v2 \
samfoo:ansi:b6bd2ded7189:samfoo_ansi/vendor/github.com/samfoo/ansi \
shurcooL:sanitized_anchor_name:v1.0.0:shurcool_sanitized_anchor_name/vendor/github.com/shurcooL/sanitized_anchor_name \
sirupsen:logrus:v1.4.2:sirupsen_logrus/vendor/github.com/sirupsen/logrus \
smallstep:assert:b99dc1097b15:smallstep_assert/vendor/github.com/smallstep/assert \
- smallstep:cli:v0.14.3:smallstep_cli/vendor/github.com/smallstep/cli \
+ smallstep:cli:v0.14.5:smallstep_cli/vendor/github.com/smallstep/cli \
smallstep:nosql:v0.3.0:smallstep_nosql/vendor/github.com/smallstep/nosql \
spf13:cast:v1.3.1:spf13_cast/vendor/github.com/spf13/cast \
square:go-jose:v2.4.0:square_go_jose/vendor/gopkg.in/square/go-jose.v2 \