aboutsummaryrefslogtreecommitdiff
path: root/security/strongswan/Makefile
diff options
context:
space:
mode:
authorFrancois ten Krooden <strongswan@Nanoteq.com>2022-06-16 06:15:23 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2022-06-16 14:41:07 +0000
commit4e7ee356bbfdef75435f4fd3e395ebb806eb8790 (patch)
treebca4bc1b918686a392425a651e2e1e9f68329a5d /security/strongswan/Makefile
parent8d838c5c5827e7ce7636fa20f9b568cb37defd25 (diff)
downloadports-4e7ee356bbfdef75435f4fd3e395ebb806eb8790.tar.gz
ports-4e7ee356bbfdef75435f4fd3e395ebb806eb8790.zip
security/strongswan: Fix key derivation
An issue in the upstream port causes key derivation to fail in version 5.9.6. A work around is to enable the KDF pluging by default. PR: 264667 Reported by: strongswan@Nanoteq.com (maintainer)
Diffstat (limited to 'security/strongswan/Makefile')
-rw-r--r--security/strongswan/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/security/strongswan/Makefile b/security/strongswan/Makefile
index a7dd87435306..ace6b5f45521 100644
--- a/security/strongswan/Makefile
+++ b/security/strongswan/Makefile
@@ -1,6 +1,6 @@
PORTNAME= strongswan
DISTVERSION= 5.9.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security net-vpn
MASTER_SITES= https://download.strongswan.org/ \
https://download2.strongswan.org/
@@ -45,7 +45,7 @@ OPTIONS_DEFINE= CTR CURL EAPAKA3GPP2 EAPDYNAMIC EAPRADIUS \
PKCS11 PKI PYTHON SCEP SMP SQLITE SWANCTL \
TESTVECTOR TPM TSS2 UNBOUND UNITY VICI XAUTH
OPTIONS_DEFINE_i386= VIA
-OPTIONS_DEFAULT= BUILTIN CURL IKEV1 PKI SWANCTL VICI
+OPTIONS_DEFAULT= BUILTIN CURL IKEV1 KDF PKI SWANCTL VICI
OPTIONS_SINGLE= PRINTF_HOOKS
OPTIONS_SINGLE_PRINTF_HOOKS= BUILTIN LIBC VSTR
OPTIONS_SUB= yes