aboutsummaryrefslogtreecommitdiff
path: root/security/sudo
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2010-08-22 01:58:33 +0000
committerWesley Shields <wxs@FreeBSD.org>2010-08-22 01:58:33 +0000
commitaef8c682639fce23f6052f52dbad1c44e382db4e (patch)
tree9680bda1f6aaecf07909fcbcf1ca9fb27c58900a /security/sudo
parent2624176279549953f587de97b57d06a70d5d0058 (diff)
downloadports-aef8c682639fce23f6052f52dbad1c44e382db4e.tar.gz
ports-aef8c682639fce23f6052f52dbad1c44e382db4e.zip
Update to 1.7.4p3
Install etc/pam.d/sudo and etc/pam.d/sudo.default
Notes
Notes: svn path=/head/; revision=259711
Diffstat (limited to 'security/sudo')
-rw-r--r--security/sudo/Makefile11
-rw-r--r--security/sudo/distinfo6
-rw-r--r--security/sudo/files/patch-Makefile.in10
-rw-r--r--security/sudo/files/patch-sudoers4
-rw-r--r--security/sudo/pkg-plist4
5 files changed, 21 insertions, 14 deletions
diff --git a/security/sudo/Makefile b/security/sudo/Makefile
index b4fea318f602..e1d24601fbf7 100644
--- a/security/sudo/Makefile
+++ b/security/sudo/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= sudo
-PORTVERSION= 1.7.4.2
-PORTREVISION= 1
+PORTVERSION= 1.7.4.3
CATEGORIES= security
MASTER_SITES= http://www.sudo.ws/sudo/dist/ \
ftp://obsd.isc.org/pub/sudo/ \
@@ -15,7 +14,7 @@ MASTER_SITES= http://www.sudo.ws/sudo/dist/ \
ftp://boulder.tele.dk/pub/sudo/ \
ftp://core.ring.gr.jp/pub/misc/sudo/ \
ftp://ftp.wiretapped.net/pub/security/host-security/sudo/
-DISTNAME= ${PORTNAME}-1.7.4p2
+DISTNAME= ${PORTNAME}-1.7.4p3
MAINTAINER= wxs@FreeBSD.org
COMMENT= Allow others to run commands as root
@@ -89,11 +88,15 @@ post-patch:
.if defined(NOPORTDOCS)
@${REINPLACE_CMD} -e 's/$$(DESTDIR)$$(sudoersdir) $$(DESTDIR)$$(docdir)/$$(DESTDIR)$$(sudoersdir)/' \
${WRKSRC}/Makefile.in
-
@${REINPLACE_CMD} -e '/for f in ChangeLog/d' ${WRKSRC}/Makefile.in
.endif
post-install:
+ ${INSTALL_DATA} ${FILESDIR}/pam.conf ${PREFIX}/etc/pam.d/sudo.default
+ if [ ! -f ${PREFIX}/etc/pam.d/sudo ]; then \
+ ${CP} -p ${PREFIX}/etc/pam.d/sudo.default \
+ ${PREFIX}/etc/pam.d/sudo ; \
+ fi
if [ ! -f ${PREFIX}/etc/sudoers ]; then \
${CP} -p ${PREFIX}/etc/sudoers.sample ${PREFIX}/etc/sudoers; \
fi
diff --git a/security/sudo/distinfo b/security/sudo/distinfo
index 3d2bc80c41c7..21aaf6ad45ac 100644
--- a/security/sudo/distinfo
+++ b/security/sudo/distinfo
@@ -1,3 +1,3 @@
-MD5 (sudo-1.7.4p2.tar.gz) = 80f3a2506f0ec3e2d75e7d17d95f5341
-SHA256 (sudo-1.7.4p2.tar.gz) = 5e53839abd6bf8d23197cf2c4e54e14ebfd996e8b95ce0c6cb35cadacc1181e5
-SIZE (sudo-1.7.4p2.tar.gz) = 962214
+MD5 (sudo-1.7.4p3.tar.gz) = 950994a454a3eb7a74df5f4bc863bd2b
+SHA256 (sudo-1.7.4p3.tar.gz) = 1dd7ce66046c6479603db41c7cb9d878e1b4b1f23b90c9c7f2e5e808e3d0bbb5
+SIZE (sudo-1.7.4p3.tar.gz) = 962697
diff --git a/security/sudo/files/patch-Makefile.in b/security/sudo/files/patch-Makefile.in
index 3366efdc21d1..3101bc8d12eb 100644
--- a/security/sudo/files/patch-Makefile.in
+++ b/security/sudo/files/patch-Makefile.in
@@ -1,14 +1,14 @@
---- Makefile.in.orig 2010-07-30 17:58:54.000000000 +0200
-+++ Makefile.in 2010-08-16 10:21:01.000000000 +0200
-@@ -493,11 +493,8 @@
- if [ -f .libs/lib$(noexecfile) ]; then $(INSTALL) -b~ -O $(install_uid) -G $(install_gid) -M 0755 .libs/lib$(noexecfile) $(DESTDIR)$(noexecdir)/$(noexecfile); fi
+--- Makefile.in.orig 2010-08-18 15:32:57.000000000 -0400
++++ Makefile.in 2010-08-21 21:22:51.000000000 -0400
+@@ -494,10 +494,9 @@
install-sudoers: install-dirs
-- $(INSTALL) -d -O $(sudoers_uid) -G $(sudoers_gid) -M 0750 \
+ $(INSTALL) -d -O $(sudoers_uid) -G $(sudoers_gid) -M 0750 \
- $(DESTDIR)$(sudoersdir)/sudoers.d
- test -f $(DESTDIR)$(sudoersdir)/sudoers || \
- $(INSTALL) -O $(sudoers_uid) -G $(sudoers_gid) -M $(sudoers_mode) \
- $(srcdir)/sudoers $(DESTDIR)$(sudoersdir)/sudoers
++ $(DESTDIR)$(sudoersdir)/sudoers.d
+ $(INSTALL) -O $(sudoers_uid) -G $(sudoers_gid) -M $(sudoers_mode) \
+ $(srcdir)/sudoers $(DESTDIR)$(sudoersdir)/sudoers.sample
diff --git a/security/sudo/files/patch-sudoers b/security/sudo/files/patch-sudoers
index dc95d16d3733..adb81b144c7c 100644
--- a/security/sudo/files/patch-sudoers
+++ b/security/sudo/files/patch-sudoers
@@ -1,5 +1,5 @@
---- ./sudoers.orig 2010-07-30 11:58:54.000000000 -0400
-+++ ./sudoers 2010-08-15 21:31:54.000000000 -0400
+--- ./sudoers.in.orig 2010-07-30 11:58:54.000000000 -0400
++++ ./sudoers.in 2010-08-15 21:31:54.000000000 -0400
@@ -31,6 +31,14 @@
##
## Defaults specification
diff --git a/security/sudo/pkg-plist b/security/sudo/pkg-plist
index d558b8d4db94..26a5f8708f72 100644
--- a/security/sudo/pkg-plist
+++ b/security/sudo/pkg-plist
@@ -4,6 +4,9 @@ bin/sudoreplay
@unexec if cmp -s %D/etc/sudoers.sample %D/etc/sudoers; then rm -f %D/etc/sudoers; fi
etc/sudoers.sample
@exec if [ ! -f %D/etc/sudoers ] ; then cp -p %D/%F %B/sudoers; fi
+@unexec if cmp -s %D/etc/pam.d/sudo.default %D/etc/pam.d/sudo; then rm -f %D/etc/pam.d/sudo ; fi
+etc/pam.d/sudo.default
+@exec if [ ! -f %D/etc/pam.d/sudo ] ; then cp -p %D/%F %B/pam.d/sudo; fi
libexec/sudo_noexec.so
sbin/visudo
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
@@ -20,3 +23,4 @@ sbin/visudo
%%LDAP%%%%PORTDOCS%%%%DOCSDIR%%/schema.OpenLDAP
%%LDAP%%%%PORTDOCS%%%%DOCSDIR%%/sudoers2ldif
%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrmtry etc/sudoers.d