aboutsummaryrefslogtreecommitdiff
path: root/security/sudosh2
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2007-01-06 22:42:50 +0000
committerCy Schubert <cy@FreeBSD.org>2007-01-06 22:42:50 +0000
commit15b09be1d4d96dddfce87d5278f96651adc306a6 (patch)
tree81a747a6841470645a5952b57be4922acf56f8f2 /security/sudosh2
parent79bc5c9d32f404de80edfb36a0a0f148b653bdfb (diff)
downloadports-15b09be1d4d96dddfce87d5278f96651adc306a6.tar.gz
ports-15b09be1d4d96dddfce87d5278f96651adc306a6.zip
Fix SIBGUS and SIGSEGV violations on amd64 platform.
Notes
Notes: svn path=/head/; revision=181650
Diffstat (limited to 'security/sudosh2')
-rw-r--r--security/sudosh2/Makefile2
-rw-r--r--security/sudosh2/files/patch-src-parse.c12
2 files changed, 13 insertions, 1 deletions
diff --git a/security/sudosh2/Makefile b/security/sudosh2/Makefile
index 1ee670dc6228..e63bfdd9f01e 100644
--- a/security/sudosh2/Makefile
+++ b/security/sudosh2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= sudosh
PORTVERSION= 1.8.2
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= ${PORTNAME:S/_/-/}
diff --git a/security/sudosh2/files/patch-src-parse.c b/security/sudosh2/files/patch-src-parse.c
new file mode 100644
index 000000000000..646cb65d3235
--- /dev/null
+++ b/security/sudosh2/files/patch-src-parse.c
@@ -0,0 +1,12 @@
+--- src/parse.c.orig Sun Jun 12 16:22:42 2005
++++ src/parse.c Fri Jan 5 17:54:55 2007
+@@ -19,7 +19,8 @@
+ void parse(option * o, const char *file)
+ {
+ FILE *f = fopen(file, "r");
+- unsigned int line_number, i;
++ unsigned int line_number;
++ int i;
+ char line[BUFSIZ];
+ char *arg, *cmt, *opt;
+ config *scan;