aboutsummaryrefslogtreecommitdiff
path: root/security/testssl.sh/Makefile
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2020-09-29 10:10:50 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2020-09-29 10:10:50 +0000
commit3ccf9c24eada821fc6a3c4478a8182e342d07ce5 (patch)
tree9625b7fedd83074926baf8e2ee09242efa797c4d /security/testssl.sh/Makefile
parentf8d6af2f51456147fa4595b9f47ad397c68ec5b6 (diff)
downloadports-3ccf9c24eada821fc6a3c4478a8182e342d07ce5.tar.gz
ports-3ccf9c24eada821fc6a3c4478a8182e342d07ce5.zip
security/testssl.sh: Turn REINPLACEs into patches
While here, improve some text strings and general formatting.
Notes
Notes: svn path=/head/; revision=550490
Diffstat (limited to 'security/testssl.sh/Makefile')
-rw-r--r--security/testssl.sh/Makefile25
1 files changed, 10 insertions, 15 deletions
diff --git a/security/testssl.sh/Makefile b/security/testssl.sh/Makefile
index 884e69fc13dc..ea0c33b501b5 100644
--- a/security/testssl.sh/Makefile
+++ b/security/testssl.sh/Makefile
@@ -5,45 +5,40 @@ DISTVERSION= 3.0.2
CATEGORIES= security
MAINTAINER= adamw@FreeBSD.org
-COMMENT= Test TLS/SSL encryption anywhere on any port
+COMMENT= Analyze and report TLS/SSL configuration/misconfiguration
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${LOCALBASE}/openssl-unsafe/bin/openssl:security/openssl-unsafe \
+RUN_DEPENDS= openssl-unsafe>=1.0.1:security/openssl-unsafe \
bash:shells/bash
TEST_DEPENDS= p5-JSON>=0:converters/p5-JSON
USES= perl5 shebangfix
USE_GITHUB= yes
GH_ACCOUNT= drwetter
-USE_PERL5= test
+
SHEBANG_FILES= testssl.sh utils/*
+
+USE_PERL5= test
TEST_ENV= TESTSSL_INSTALL_DIR=${WRKSRC}
NO_ARCH= yes
NO_BUILD= yes
post-patch:
- @${REINPLACE_CMD} -e '/elif test_openssl_suffix/d' \
- -e 's@OPENSSL=PREFIX@OPENSSL=${PREFIX}@' \
- -e 's@$${TESTSSL_INSTALL_DIR:-""}@$${TESTSSL_INSTALL_DIR:-"${DATADIR}"}@' \
- -e '/check_bsd_mount$$/d' \
+ ${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|; s|%%DATADIR%%|${DATADIR}|' \
${WRKSRC}/testssl.sh
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/testssl.sh \
- ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/doc/testssl.1 \
- ${STAGEDIR}${MAN1PREFIX}/man/man1
- @cd ${WRKSRC} && \
- ${COPYTREE_SHARE} "etc utils" ${STAGEDIR}${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/testssl.sh ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/doc/testssl.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
+ cd ${WRKSRC} && ${COPYTREE_SHARE} "etc utils" ${STAGEDIR}${DATADIR}
do-test:
# Run the badssl.com test as a sanity check. The full test suite
# opens too many network connections and might take too long to
# run.
- @cd ${WRKSRC} && \
- ${SETENV} ${TEST_ENV} prove -v t/51_badssl.com.t
+ cd ${WRKSRC} && ${SETENV} ${TEST_ENV} prove -v t/51_badssl.com.t
.include <bsd.port.mk>