aboutsummaryrefslogtreecommitdiff
path: root/security/tpm-tools/Makefile
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2013-07-25 10:49:53 +0000
committerHiroki Sato <hrs@FreeBSD.org>2013-07-25 10:49:53 +0000
commit3326a8cc13b868fabaf0c38a720b1bf69794fbc6 (patch)
treec08f9fc2029348d360f35885dabe955a7ec38921 /security/tpm-tools/Makefile
parent8525495496296c92599a10938e57a5f4c565a14d (diff)
downloadports-3326a8cc13b868fabaf0c38a720b1bf69794fbc6.tar.gz
ports-3326a8cc13b868fabaf0c38a720b1bf69794fbc6.zip
- Fix build on -CURRENT.
- Take maintainership.
Notes
Notes: svn path=/head/; revision=323634
Diffstat (limited to 'security/tpm-tools/Makefile')
-rw-r--r--security/tpm-tools/Makefile27
1 files changed, 11 insertions, 16 deletions
diff --git a/security/tpm-tools/Makefile b/security/tpm-tools/Makefile
index 93b7b8657f66..168cba96f760 100644
--- a/security/tpm-tools/Makefile
+++ b/security/tpm-tools/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: tpm-tools
-# Date created: 18 Sep 2007
-# Whom: Sebastian Schuetz <sschuetz@fhm.edu>
-#
+# Created by: Sebastian Schuetz <sschuetz@fhm.edu>
# $FreeBSD$
-#
PORTNAME= tpm-tools
PORTVERSION= 1.3.5
@@ -11,27 +7,26 @@ PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= SF/trousers/${PORTNAME}/${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= hrs@FreeBSD.org
COMMENT= Provides a basic set of TPM tools
-LIB_DEPENDS= tspi.2:${PORTSDIR}/security/trousers
+LICENSE= CPL
+LICENSE_NAME= Common Public License
+LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+LIB_DEPENDS= tspi:${PORTSDIR}/security/trousers
BUILD_DEPENDS= pkcsconf:${PORTSDIR}/security/opencryptoki
-RUN_DEPENDS= ${LOCALBASE}/sbin/tcsd:${PORTSDIR}/security/trousers
-RUN_DEPENDS+= ${LOCALBASE}/lib/pkcs11/libopencryptoki.so:${PORTSDIR}/security/opencryptoki
+RUN_DEPENDS= ${LOCALBASE}/sbin/tcsd:${PORTSDIR}/security/trousers \
+ ${LOCALBASE}/lib/pkcs11/libopencryptoki.so:${PORTSDIR}/security/opencryptoki
-USE_GMAKE= YES
-USES= gettext iconv
+USES= gettext gmake iconv
USE_LDCONFIG= YES
USE_AUTOTOOLS= autoconf
GNU_CONFIGURE= YES
LDFLAGS+= -L${LOCALBASE}/lib -lintl -liconv
MAKE_JOBS_SAFE= YES
-LICENSE= CPL
-LICENSE_NAME= Common Public License
-LICENSE_FILE= ${WRKSRC}/LICENSE
-LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-
MAN1= tpm_sealdata.1 tpm_version.1 \
tpmtoken_import.1 tpmtoken_init.1 tpmtoken_objects.1 \
tpmtoken_protect.1 tpmtoken_setpasswd.1