aboutsummaryrefslogtreecommitdiff
path: root/security/vault/Makefile
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2019-09-02 16:00:56 +0000
committerSteve Wills <swills@FreeBSD.org>2019-09-02 16:00:56 +0000
commit45d25cc7f764a10748159b198d7efa03988b4dbb (patch)
tree650205fc1e24ee1c372589d251e613177721f076 /security/vault/Makefile
parent0b01056bfc8715817fd79c2f070758b70a8780c9 (diff)
downloadports-45d25cc7f764a10748159b198d7efa03988b4dbb.tar.gz
ports-45d25cc7f764a10748159b198d7efa03988b4dbb.zip
security/vault: Unbreak with go1.13
PR: 240075 Submitted by: Dmitri Goutnik <dg@syrec.org>
Notes
Notes: svn path=/head/; revision=510814
Diffstat (limited to 'security/vault/Makefile')
-rw-r--r--security/vault/Makefile25
1 files changed, 9 insertions, 16 deletions
diff --git a/security/vault/Makefile b/security/vault/Makefile
index d06eb840f1d5..c9558ac6d4bf 100644
--- a/security/vault/Makefile
+++ b/security/vault/Makefile
@@ -15,9 +15,17 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USES= go
USE_GITHUB= yes
-GH_TUPLE= hashicorp:${PORTNAME}:${VAULTTAG}:DEFAULT/src/github.com/hashicorp/${PORTNAME} \
+GH_TUPLE= hashicorp:${PORTNAME}:${VAULTTAG}:DEFAULT \
swills:vaultui:${VAULTUITAG}:vaultui
+GO_PKGNAME= github.com/${GH_ACCOUNT}/${PORTNAME}
+GO_BUILDFLAGS= -tags=ui \
+ -ldflags="\
+ -X github.com/hashicorp/vault/version.Version=${PORTVERSION} \
+ -X github.com/hashicorp/vault/version.VersionPrerelease= \
+ -X github.com/hashicorp/vault/version.VersionMetadata= \
+ -X github.com/hashicorp/vault/version.GitCommit='${COMMIT_ID}'"
+
VAULTTAG= ${DISTVERSIONPREFIX}${PORTVERSION}
VAULTUITAG= ${DISTVERSIONPREFIX}${PORTVERSION}
@@ -32,19 +40,4 @@ SUB_FILES= pkg-message
post-patch:
@${CP} ${WRKDIR}/vaultui-${PORTVERSION}/http/bindata_assetfs.go ${WRKDIR}/vault-${PORTVERSION}/http/bindata_assetfs.go
-do-build:
- @cd ${WRKSRC}; \
- ${SETENV} ${MAKE_ENV} ${BUILD_ENV} CGO_ENABLED=0 GOPATH=${WRKSRC} \
- go build \
- -tags=ui \
- -ldflags "\
- -X github.com/hashicorp/vault/version.Version=${PORTVERSION} \
- -X github.com/hashicorp/vault/version.VersionPrerelease= \
- -X github.com/hashicorp/vault/version.VersionMetadata= \
- -X github.com/hashicorp/vault/version.GitCommit='${COMMIT_ID}'" \
- -o bin/${PORTNAME}
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
-
.include <bsd.port.mk>