aboutsummaryrefslogtreecommitdiff
path: root/security/xca
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2018-11-13 19:09:01 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2018-11-13 19:09:01 +0000
commit78e45117302234ccc9972e8b03f4b5aa21f3f886 (patch)
treeb6c798c1e92e6646c271d092c1f98867d09b35dd /security/xca
parente4afaf37cfb286601870c1e9dcf2dbb0cc0d6566 (diff)
downloadports-78e45117302234ccc9972e8b03f4b5aa21f3f886.tar.gz
ports-78e45117302234ccc9972e8b03f4b5aa21f3f886.zip
- Update xca to 2.1.2
- The new version works fine with OpenSSL 1.1.1 - Drop Qt4 option and move to Qt5 - Fix portlint warning - Project moved to github - Update WWW in pkg-descr - Take maintainership
Notes
Notes: svn path=/head/; revision=484897
Diffstat (limited to 'security/xca')
-rw-r--r--security/xca/Makefile35
-rw-r--r--security/xca/distinfo5
-rw-r--r--security/xca/files/patch-lib_pki__temp.cpp11
-rw-r--r--security/xca/files/patch-widgets_MW__help.cpp13
-rw-r--r--security/xca/pkg-descr2
-rw-r--r--security/xca/pkg-plist7
6 files changed, 21 insertions, 52 deletions
diff --git a/security/xca/Makefile b/security/xca/Makefile
index 43c7ead8de7f..11a5997fd610 100644
--- a/security/xca/Makefile
+++ b/security/xca/Makefile
@@ -2,11 +2,11 @@
# $FreeBSD$
PORTNAME= xca
-PORTVERSION= 1.3.2
+PORTVERSION= 2.1.2
+DISTVERSIONPREFIX= RELEASE.
CATEGORIES= security
-MASTER_SITES= SF
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= madpilot@FreeBSD.org
COMMENT= Graphical certification authority
LICENSE= BSD3CLAUSE
@@ -14,26 +14,23 @@ LICENSE_FILE= ${WRKSRC}/COPYRIGHT
LIB_DEPENDS= libltdl.so:devel/libltdl
-USES= desktop-file-utils gmake localbase pkgconfig \
- shared-mime-info ssl
+USES= autoreconf compiler:c++11-lang desktop-file-utils gmake \
+ localbase pkgconfig qt:5 shared-mime-info shebangfix ssl
+USE_QT= buildtools_build core gui linguist_build sql widgets
+USE_CXXSTD= c++11
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-openssl=${OPENSSLDIR} \
- --with-qt=${PREFIX}
+ --with-qt=${PREFIX} \
+ --with-qt-version=5
MAKE_ARGS= DOCTOOL="${TRUE}"
DESTDIRNAME= destdir
+SHEBANG_FILES= doc/code2html
-OPTIONS_DEFINE= DOCS
-OPTIONS_SINGLE= TOOLKIT
-OPTIONS_SINGLE_TOOLKIT= QT4 QT5
-OPTIONS_DEFAULT= QT4
+USE_GITHUB= yes
+GH_ACCOUNT= chris2511
-QT4_USES= qt:4
-QT4_USE= qt=gui,linguist_build,moc_build,qmake_build \
- qt=rcc_build,uic_build
-QT5_USES= qt:5
-QT5_USE= qt=widgets,buildtools_build,linguist_build \
- CXXSTD=c++11
-TOOLKIT_DESC= Qt toolkit
+OPTIONS_DEFINE= DOCS
post-patch:
@${REINPLACE_CMD} -e \
@@ -41,10 +38,6 @@ post-patch:
@${REINPLACE_CMD} -e \
'/install/s|-D|-c|' ${WRKSRC}/img/Makefile
-post-patch-QT5-off:
- @${REINPLACE_CMD} -e \
- 's|Qt5|Qt0|g' ${WRKSRC}/configure
-
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/xca*
diff --git a/security/xca/distinfo b/security/xca/distinfo
index df17059bef96..1e45ef818b2a 100644
--- a/security/xca/distinfo
+++ b/security/xca/distinfo
@@ -1,2 +1,3 @@
-SHA256 (xca-1.3.2.tar.gz) = 04f11f2148c8369c1a1b4e109956ed8cc807ec266d0d936410624ba8ee4b5ce4
-SIZE (xca-1.3.2.tar.gz) = 897947
+TIMESTAMP = 1542022933
+SHA256 (chris2511-xca-RELEASE.2.1.2_GH0.tar.gz) = 19da0b19e5d3b145f630e9b18b3e29d5a569495d6dd3ab927f41e6b490a99cec
+SIZE (chris2511-xca-RELEASE.2.1.2_GH0.tar.gz) = 1048019
diff --git a/security/xca/files/patch-lib_pki__temp.cpp b/security/xca/files/patch-lib_pki__temp.cpp
deleted file mode 100644
index 311553f12f36..000000000000
--- a/security/xca/files/patch-lib_pki__temp.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/pki_temp.cpp.orig 2015-10-10 12:54:12 UTC
-+++ lib/pki_temp.cpp
-@@ -363,7 +363,7 @@ BIO *pki_temp::pem(BIO *b, int format)
- QByteArray ba = toExportData();
- if (!b)
- b = BIO_new(BIO_s_mem());
--#if OPENSSL_VERSION_NUMBER < 0x10002000L
-+#if OPENSSL_VERSION_NUMBER < 0x10002000L || defined(LIBRESSL_VERSION_NUMBER)
- PEM_write_bio(b, PEM_STRING_XCA_TEMPLATE, (char*)"",
- (unsigned char*)(ba.data()), ba.size());
- #else
diff --git a/security/xca/files/patch-widgets_MW__help.cpp b/security/xca/files/patch-widgets_MW__help.cpp
deleted file mode 100644
index 9ea73852258b..000000000000
--- a/security/xca/files/patch-widgets_MW__help.cpp
+++ /dev/null
@@ -1,13 +0,0 @@
---- widgets/MW_help.cpp.orig 2015-10-10 12:54:12 UTC
-+++ widgets/MW_help.cpp
-@@ -67,8 +67,8 @@ void MainWindow::about()
- {
- version = QString("<table border=0 width=500><tr>"
- "<td>Compile time:</td>"
-- "<td>"OPENSSL_VERSION_TEXT"</td>"
-- "<td>QT version: "QT_VERSION_STR"</td>"
-+ "<td>" OPENSSL_VERSION_TEXT "</td>"
-+ "<td>QT version: " QT_VERSION_STR "</td>"
- "</tr><tr>"
- "<td>Run time:</td>"
- "<td>%1</td>"
diff --git a/security/xca/pkg-descr b/security/xca/pkg-descr
index 3b1ee72bc488..505d24beb4c9 100644
--- a/security/xca/pkg-descr
+++ b/security/xca/pkg-descr
@@ -5,4 +5,4 @@ storage. It supports importing and exporting keys and PEM DER PKCS8
certificates, signing and revoking of PEM DER PKCS12, and selection of
x509v3 extensions. A tree view of certificates is presented.
-WWW: http://xca.sourceforge.net/
+WWW: https://www.hohnstaedt.de/xca/
diff --git a/security/xca/pkg-plist b/security/xca/pkg-plist
index 7a63072b2324..158e72cad221 100644
--- a/security/xca/pkg-plist
+++ b/security/xca/pkg-plist
@@ -1,7 +1,5 @@
bin/xca
-bin/xca_db_stat
man/man1/xca.1.gz
-man/man1/xca_db_stat.1.gz
share/applications/xca.desktop
%%PORTDOCS%%%%DOCSDIR%%/xca-1.html
%%PORTDOCS%%%%DOCSDIR%%/xca-10.html
@@ -24,14 +22,15 @@ share/pixmaps/xca-32x32.xpm
%%DATADIR%%/CA.xca
%%DATADIR%%/HTTPS_client.xca
%%DATADIR%%/HTTPS_server.xca
-%%DATADIR%%/aia.txt
%%DATADIR%%/dn.txt
%%DATADIR%%/eku.txt
%%DATADIR%%/oids.txt
-%%DATADIR%%/release.txt
%%DATADIR%%/xca_de.qm
%%DATADIR%%/xca_es.qm
%%DATADIR%%/xca_fr.qm
%%DATADIR%%/xca_hr.qm
+%%DATADIR%%/xca_pl.qm
+%%DATADIR%%/xca_pt_BR.qm
%%DATADIR%%/xca_ru.qm
+%%DATADIR%%/xca_sk.qm
%%DATADIR%%/xca_tr.qm