aboutsummaryrefslogtreecommitdiff
path: root/security/xmlsec1
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2010-05-26 18:09:23 +0000
committerJohan van Selst <johans@FreeBSD.org>2010-05-26 18:09:23 +0000
commit1cab29310b97e46d7d19ac7e671488517ac54833 (patch)
treec1369dc531f87522637ad974a57908a3f7b7d899 /security/xmlsec1
parent8994d03cf3cc4864edef33271981e29f17a66811 (diff)
downloadports-1cab29310b97e46d7d19ac7e671488517ac54833.tar.gz
ports-1cab29310b97e46d7d19ac7e671488517ac54833.zip
- Update to 1.2.16
- Remove dynamic plist generation
Notes
Notes: svn path=/head/; revision=255131
Diffstat (limited to 'security/xmlsec1')
-rw-r--r--security/xmlsec1/Makefile25
-rw-r--r--security/xmlsec1/distinfo6
-rw-r--r--security/xmlsec1/pkg-plist86
3 files changed, 95 insertions, 22 deletions
diff --git a/security/xmlsec1/Makefile b/security/xmlsec1/Makefile
index 1786414f7020..084afb20d8ae 100644
--- a/security/xmlsec1/Makefile
+++ b/security/xmlsec1/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= xmlsec1
-PORTVERSION= 1.2.15
+PORTVERSION= 1.2.16
CATEGORIES= security
MASTER_SITES= http://www.aleksey.com/xmlsec/download/ \
ftp://ftp.aleksey.com/pub/xmlsec/releases/ \
@@ -26,13 +26,8 @@ USE_OPENSSL= yes
USE_GNOME= gnomehack lthack libxslt gnometarget
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-PLIST_FILES= bin/xmlsec1 bin/xmlsec1-config etc/xmlsec1Conf.sh \
- share/aclocal/xmlsec1.m4
MAN1= xmlsec1.1 xmlsec1-config.1
-# The software comes with its own tests, but it is nauseating to sort,
-# which failures are, and which aren't legitimate. Some other day, maybe.
-#ALL_TARGET= all check-all
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
MAKE_ENV+= ABS_BUILDDIR=${WRKSRC} TMPFOLDER=${WRKSRC}
@@ -40,36 +35,28 @@ MAKE_ARGS+= -EABS_BUILDDIR
USE_AUTOTOOLS= libltdl:22
.if !defined(NOPORTDOCS)
+PORTDOCS= *
MAKE_ENV+= DOCS=docs
.endif
-post-install:
- @${FIND} ${PREFIX}/include/xmlsec1 -type f | \
- ${SED} 's,${PREFIX}/,,' >> ${TMPPLIST}
- @${FIND} ${PREFIX}/include/xmlsec1 -type d | ${SORT} -r | \
- ${SED} 's,${PREFIX}/,, ; s,^,@dirrm ,' >> ${TMPPLIST}
- @${FIND} ${PREFIX}/lib/libxmlsec1* | \
- ${SED} 's,${PREFIX}/,,' >> ${TMPPLIST}
- @${FIND} ${PREFIX}/libdata/pkgconfig/xmlsec1* | \
- ${SED} 's,${PREFIX}/,,' >> ${TMPPLIST}
- @${FIND} ${DOCSDIR} -type f | ${SED} 's,${PREFIX}/,,' >> ${TMPPLIST}
- @${FIND} ${DOCSDIR} -type d | ${SORT} -r | \
- ${SED} 's,${PREFIX}/,, ; s,^,@dirrm ,' >> ${TMPPLIST}
-
.include <bsd.port.pre.mk>
.if defined(WITH_GNUTLS)
CONFIGURE_ARGS+= --with-gnutls="${LOCALBASE}"
LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
+PLIST_SUB+= GNUTLS=""
.else
CONFIGURE_ARGS+= --without-gnutls
+PLIST_SUB+= GNUTLS="@comment "
.endif
.if defined(WITH_NSS)
CONFIGURE_ARGS+= --with-nss="${LOCALBASE}" --with-nspr="${LOCALBASE}"
LIB_DEPENDS+= nss3:${PORTSDIR}/security/nss
+PLIST_SUB+= NSS=""
.else
CONFIGURE_ARGS+= --without-nss
+PLIST_SUB+= NSS="@comment "
.endif
CONFIGURE_ARGS+= --with-openssl="${OPENSSLBASE}"
diff --git a/security/xmlsec1/distinfo b/security/xmlsec1/distinfo
index f6e1cf43eabc..daf1b230f6df 100644
--- a/security/xmlsec1/distinfo
+++ b/security/xmlsec1/distinfo
@@ -1,3 +1,3 @@
-MD5 (xmlsec1-1.2.15.tar.gz) = 43bc8011a33ef9fba862eca4573034c4
-SHA256 (xmlsec1-1.2.15.tar.gz) = 8cdcc3861ad5f2b010010ffe359acadc9777f5d1ea35a8f74e52e0e1e7eca935
-SIZE (xmlsec1-1.2.15.tar.gz) = 1702205
+MD5 (xmlsec1-1.2.16.tar.gz) = 17e8eb9a4ec4139b7689d139be4da133
+SHA256 (xmlsec1-1.2.16.tar.gz) = f62df3315b87d61544d7733e99ceccece046c813b60b898109d98808ca8bd88c
+SIZE (xmlsec1-1.2.16.tar.gz) = 1803092
diff --git a/security/xmlsec1/pkg-plist b/security/xmlsec1/pkg-plist
new file mode 100644
index 000000000000..d0ba4042b022
--- /dev/null
+++ b/security/xmlsec1/pkg-plist
@@ -0,0 +1,86 @@
+bin/xmlsec1
+bin/xmlsec1-config
+etc/xmlsec1Conf.sh
+share/aclocal/xmlsec1.m4
+lib/libxmlsec1-gcrypt.a
+lib/libxmlsec1-gcrypt.la
+lib/libxmlsec1-gcrypt.so
+lib/libxmlsec1-gcrypt.so.3
+lib/libxmlsec1-openssl.a
+lib/libxmlsec1-openssl.la
+lib/libxmlsec1-openssl.so
+lib/libxmlsec1-openssl.so.3
+lib/libxmlsec1.a
+lib/libxmlsec1.la
+lib/libxmlsec1.so
+lib/libxmlsec1.so.3
+%%GNUTLS%%lib/libxmlsec1-gnutls.a
+%%GNUTLS%%lib/libxmlsec1-gnutls.la
+%%GNUTLS%%lib/libxmlsec1-gnutls.so
+%%GNUTLS%%lib/libxmlsec1-gnutls.so.3
+%%NSS%%lib/libxmlsec1-nss.a
+%%NSS%%lib/libxmlsec1-nss.la
+%%NSS%%lib/libxmlsec1-nss.so
+%%NSS%%lib/libxmlsec1-nss.so.3
+include/xmlsec1/xmlsec/private/xkms.h
+include/xmlsec1/xmlsec/openssl/app.h
+include/xmlsec1/xmlsec/openssl/bn.h
+include/xmlsec1/xmlsec/openssl/crypto.h
+include/xmlsec1/xmlsec/openssl/evp.h
+include/xmlsec1/xmlsec/openssl/symbols.h
+include/xmlsec1/xmlsec/openssl/x509.h
+include/xmlsec1/xmlsec/gcrypt/app.h
+include/xmlsec1/xmlsec/gcrypt/crypto.h
+include/xmlsec1/xmlsec/gcrypt/symbols.h
+%%GNUTLS%%include/xmlsec1/xmlsec/gnutls/app.h
+%%GNUTLS%%include/xmlsec1/xmlsec/gnutls/crypto.h
+%%GNUTLS%%include/xmlsec1/xmlsec/gnutls/symbols.h
+%%GNUTLS%%include/xmlsec1/xmlsec/gnutls/x509.h
+%%NSS%%include/xmlsec1/xmlsec/nss/app.h
+%%NSS%%include/xmlsec1/xmlsec/nss/bignum.h
+%%NSS%%include/xmlsec1/xmlsec/nss/crypto.h
+%%NSS%%include/xmlsec1/xmlsec/nss/keysstore.h
+%%NSS%%include/xmlsec1/xmlsec/nss/pkikeys.h
+%%NSS%%include/xmlsec1/xmlsec/nss/symbols.h
+%%NSS%%include/xmlsec1/xmlsec/nss/x509.h
+include/xmlsec1/xmlsec/app.h
+include/xmlsec1/xmlsec/base64.h
+include/xmlsec1/xmlsec/bn.h
+include/xmlsec1/xmlsec/buffer.h
+include/xmlsec1/xmlsec/crypto.h
+include/xmlsec1/xmlsec/dl.h
+include/xmlsec1/xmlsec/errors.h
+include/xmlsec1/xmlsec/exports.h
+include/xmlsec1/xmlsec/io.h
+include/xmlsec1/xmlsec/keyinfo.h
+include/xmlsec1/xmlsec/keysdata.h
+include/xmlsec1/xmlsec/keys.h
+include/xmlsec1/xmlsec/keysmngr.h
+include/xmlsec1/xmlsec/list.h
+include/xmlsec1/xmlsec/membuf.h
+include/xmlsec1/xmlsec/nodeset.h
+include/xmlsec1/xmlsec/parser.h
+include/xmlsec1/xmlsec/private.h
+include/xmlsec1/xmlsec/soap.h
+include/xmlsec1/xmlsec/strings.h
+include/xmlsec1/xmlsec/templates.h
+include/xmlsec1/xmlsec/transforms.h
+include/xmlsec1/xmlsec/version.h
+include/xmlsec1/xmlsec/x509.h
+include/xmlsec1/xmlsec/xkms.h
+include/xmlsec1/xmlsec/xmldsig.h
+include/xmlsec1/xmlsec/xmlenc.h
+include/xmlsec1/xmlsec/xmlsec.h
+include/xmlsec1/xmlsec/xmltree.h
+%%GNUTLS%%@dirrm include/xmlsec1/xmlsec/gnutls
+%%NSS%%@dirrm include/xmlsec1/xmlsec/nss
+@dirrm include/xmlsec1/xmlsec/gcrypt
+@dirrm include/xmlsec1/xmlsec/openssl
+@dirrm include/xmlsec1/xmlsec/private
+@dirrm include/xmlsec1/xmlsec
+@dirrm include/xmlsec1
+%%GNUTLS%%libdata/pkgconfig/xmlsec1-gnutls.pc
+%%NSS%%libdata/pkgconfig/xmlsec1-nss.pc
+libdata/pkgconfig/xmlsec1-gcrypt.pc
+libdata/pkgconfig/xmlsec1-openssl.pc
+libdata/pkgconfig/xmlsec1.pc