aboutsummaryrefslogtreecommitdiff
path: root/security/yapet
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-04-28 21:02:39 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-04-28 21:02:39 +0000
commit0b881b0ecebc9440a559f1c2b27758488a1188fa (patch)
tree933fd11da647dda8c169bc24693094174bdc0355 /security/yapet
parent928d434bd206738b7213dd9b5802c680794a9b10 (diff)
downloadports-0b881b0ecebc9440a559f1c2b27758488a1188fa.tar.gz
ports-0b881b0ecebc9440a559f1c2b27758488a1188fa.zip
Convert security to new options framework
Notes
Notes: svn path=/head/; revision=316749
Diffstat (limited to 'security/yapet')
-rw-r--r--security/yapet/Makefile26
1 files changed, 12 insertions, 14 deletions
diff --git a/security/yapet/Makefile b/security/yapet/Makefile
index b1e676eab7cd..65120d8d7ed0 100644
--- a/security/yapet/Makefile
+++ b/security/yapet/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: yapet
-# Date created: 01 March 2008
-# Whom: Rafael Ostertag <rafi@guengel.ch>
-#
+# Created by: Rafael Ostertag <rafi@guengel.ch>
# $FreeBSD$
-#
PORTNAME= yapet
PORTVERSION= 0.7
@@ -19,9 +15,11 @@ MANCOMPRESSED= no
USE_OPENSSL= yes
GNU_CONFIGURE= yes
-OPTIONS= TTITLE "Enable Terminal Title" ON \
- PWGEN "Enable Password Generator" ON \
- CSV2YAPET "Build csv2yapet" ON
+OPTIONS_DEFINE= TTITLE PWGEN CSV2YAPET DOCS
+OPTIONS_DEFAULT= TTITLE PWGEN CSV2YAPET
+TTITLE_DESC= Enable Terminal Title
+PWGEN_DESC= Enable Password Generator
+CSV2YAPET_DESC= Build csv2yapet
.include <bsd.port.pre.mk>
@@ -29,19 +27,19 @@ OPTIONS= TTITLE "Enable Terminal Title" ON \
# --disable-install-doc: I take care of installing docs
CONFIGURE_ARGS+= --enable-silent-rules --disable-install-doc
-.if defined(WITH_TTITLE)
+.if ${PORT_OPTIONS:MTTITLE}
CONFIGURE_ARGS+= --enable-terminal-title
.else
CONFIGURE_ARGS+= --disable-terminal-title
.endif
-.if defined(WITH_PWGEN)
+.if ${PORT_OPTIONS:MPWGEN}
CONFIGURE_ARGS+= --enable-pwgen
.else
CONFIGURE_ARGS+= --disable-pwgen
.endif
-.if defined(WITH_CSV2YAPET)
+.if ${PORT_OPTIONS:MCSV2YAPET}
CONFIGURE_ARGS+= --enable-csv2yapet
MAN1+= csv2yapet.1
PLIST_SUB+= CSV2YAPET=""
@@ -50,7 +48,7 @@ CONFIGURE_ARGS+= --disable-csv2yapet
PLIST_SUB+= CSV2YAPET="@comment "
.endif
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
CONFIGURE_ARGS+= --enable-nls
PLIST_SUB+= NLS=""
@@ -61,7 +59,7 @@ CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
PLIST_SUB+= NOPORTDOCS=""
.else
PLIST_SUB+= NOPORTDOCS="@comment "
@@ -70,7 +68,7 @@ PLIST_SUB+= NOPORTDOCS="@comment "
# Taking care of installing docs due to --disable-install-doc
# configure switch.
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/AUTHORS ${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/DESIGN ${DOCSDIR}