aboutsummaryrefslogtreecommitdiff
path: root/security/yersinia
diff options
context:
space:
mode:
authorVolodymyr Pushkar <vladimir.pushkar@gmail.com>2021-08-20 19:10:16 +0000
committerRenato Botelho <garga@FreeBSD.org>2021-08-20 19:12:26 +0000
commit90580b96c4150f9810b42e8ff5ce558fc2bd6e58 (patch)
treecbe61b97fcf95a22a66eed7a60d6bcd379e4911d /security/yersinia
parentb8431d76fc78d6325f2032a32aa5027cddc84533 (diff)
downloadports-90580b96c4150f9810b42e8ff5ce558fc2bd6e58.tar.gz
ports-90580b96c4150f9810b42e8ff5ce558fc2bd6e58.zip
security/yersinia: Add PORTS_PCAP option
Add a new option PORTS_PCAP and explicit rules to build it using base libpcap or ports PR: 254301 Approved by: maintainer timeout (5 months) Sponsored by: Rubicon Communications, LLC ("Netgate")
Diffstat (limited to 'security/yersinia')
-rw-r--r--security/yersinia/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/security/yersinia/Makefile b/security/yersinia/Makefile
index 87857d710747..14a6b7da35a5 100644
--- a/security/yersinia/Makefile
+++ b/security/yersinia/Makefile
@@ -2,8 +2,10 @@
PORTNAME= yersinia
PORTVERSION= 0.8.2
+PORTREVISION= 1
CATEGORIES= security
# MASTER_SITES= http://www.yersinia.net/download/
+PKGNAMESUFFIX= -gtk
MAINTAINER= ayu@commun.jp
COMMENT= Layer 2 vulnerability scanner (switches, spanning tree, 802.1q ...)
@@ -16,7 +18,6 @@ LIB_DEPENDS= libnet.so:net/libnet \
USES= autoreconf gnome ncurses pkgconfig
USE_GNOME= cairo gdkpixbuf2 gtk20
-PKGNAMESUFFIX= -gtk
USE_GITHUB= yes
GH_TUPLE= tomac:yersinia:8c0d7c5
GNU_CONFIGURE= yes
@@ -24,6 +25,14 @@ GNU_CONFIGURE= yes
PLIST_FILES= sbin/yersinia \
man/man8/yersinia.8.gz
+OPTIONS_DEFINE= PORTS_PCAP
+
+PORTS_PCAP_DESC=Use ports PCAP instead of system PCAP
+
+PORTS_PCAP_CONFIGURE_ON= --with-pcap-includes=${LOCALBASE}/include
+PORTS_PCAP_CONFIGURE_OFF= --with-pcap-includes=/usr/include
+PORTS_PCAP_BUILD_DEPENDS= ${LOCALBASE}/lib/libpcap.a:net/libpcap
+
post-patch:
@${REINPLACE_CMD} -e 's,-O3 -Wall -g,${CFLAGS} -fcommon,' \
${WRKSRC}/configure.ac