aboutsummaryrefslogtreecommitdiff
path: root/security/ykclient
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-07-05 19:57:32 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-07-05 19:57:32 +0000
commit47c1707021f8eb729050f30ae99b06d8aebad54b (patch)
tree167557e7a0e34386eacd9dba1d7e6b5f1acce365 /security/ykclient
parent71d9f8f55b54a3ac3e09f03c96cdd25f220793ee (diff)
downloadports-47c1707021f8eb729050f30ae99b06d8aebad54b.tar.gz
ports-47c1707021f8eb729050f30ae99b06d8aebad54b.zip
- Add USES=libtool to security/ykclient and bump dependent ports
- Use MAKE_CMD
Notes
Notes: svn path=/head/; revision=360815
Diffstat (limited to 'security/ykclient')
-rw-r--r--security/ykclient/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/security/ykclient/Makefile b/security/ykclient/Makefile
index 39794cef57d6..721ed2ff6940 100644
--- a/security/ykclient/Makefile
+++ b/security/ykclient/Makefile
@@ -2,6 +2,7 @@
PORTNAME= ykclient
PORTVERSION= 2.12
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://opensource.yubico.com/yubico-c-client/releases/
@@ -14,8 +15,8 @@ LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
BUILD_DEPENDS= curl-config:${PORTSDIR}/ftp/curl \
help2man:${PORTSDIR}/misc/help2man
-USES= pkgconfig
GNU_CONFIGURE= yes
+USES= libtool pkgconfig
USE_LDCONFIG= yes
PLIST_FILES= bin/ykclient \
@@ -23,9 +24,9 @@ PLIST_FILES= bin/ykclient \
include/ykclient_errors.h \
include/ykclient_server_response.h \
include/ykclient_version.h \
- lib/libykclient.la \
lib/libykclient.so \
- lib/libykclient.so.8 \
+ lib/libykclient.so.3 \
+ lib/libykclient.so.3.5.2 \
man/man1/ykclient.1.gz
OPTIONS_DEFINE= STATIC
@@ -36,6 +37,6 @@ STATIC_PLIST_FILES= lib/libykclient.a
MAKE_JOBS_UNSAFE= yes
regression-test: build
- @(cd ${WRKSRC}; ${MAKE} check)
+ @(cd ${WRKSRC} && ${MAKE_CMD} check)
.include <bsd.port.mk>