aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-10-21 11:18:25 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-10-21 11:18:25 +0000
commit0adaa54209cb6b7c07f849e15c64ec9703b92f07 (patch)
tree43dbe589aa2a007848fc9f055ba6a47848b5dfd6 /security
parent662b7bbca60937dcccc78388fab418251d55d2c6 (diff)
downloadports-0adaa54209cb6b7c07f849e15c64ec9703b92f07.tar.gz
ports-0adaa54209cb6b7c07f849e15c64ec9703b92f07.zip
security/helib: disable -march=native
Also fixes a build issue on powerpc64/12.1-RELEASE: g++9: error: unrecognized command line option '-march=native'; did you mean '-mcpu=native'?
Notes
Notes: svn path=/head/; revision=552862
Diffstat (limited to 'security')
-rw-r--r--security/helib/Makefile1
-rw-r--r--security/helib/files/patch-CMakeLists.txt29
2 files changed, 30 insertions, 0 deletions
diff --git a/security/helib/Makefile b/security/helib/Makefile
index bc2be6a32b47..de91b775c67f 100644
--- a/security/helib/Makefile
+++ b/security/helib/Makefile
@@ -3,6 +3,7 @@
PORTNAME= helib
DISTVERSIONPREFIX= v
DISTVERSION= 1.1.0
+PORTREVISION= 1
CATEGORIES= security
MAINTAINER= yuri@FreeBSD.org
diff --git a/security/helib/files/patch-CMakeLists.txt b/security/helib/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..bd282f610bbc
--- /dev/null
+++ b/security/helib/files/patch-CMakeLists.txt
@@ -0,0 +1,29 @@
+--- CMakeLists.txt.orig 2020-10-21 10:59:03 UTC
++++ CMakeLists.txt
+@@ -87,18 +87,6 @@ set_property(CACHE
+ PROPERTY
+ STRINGS "Debug" "RelWithDebInfo" "Release" "MinSizeRel")
+
+-# Creating and documenting TARGET_ARCHITECTURE cmake property
+-set(TARGET_ARCHITECTURE "${TARGET_ARCHITECTURE}"
+- CACHE
+- STRING "Target architecture used for -march (default is native)")
+-# If TARGET_ARCHITECTURE is not set use default
+-if (NOT TARGET_ARCHITECTURE)
+- set(TARGET_ARCHITECTURE "native"
+- CACHE
+- STRING "Target architecture used for -march (default is native)"
+- FORCE)
+-endif (NOT TARGET_ARCHITECTURE)
+-
+ # Path containing FindGMP.cmake and FindNTL.cmake
+ list(APPEND CMAKE_MODULE_PATH "${HELIB_CMAKE_EXTRA_DIR}")
+
+@@ -150,7 +138,6 @@ endif (NOT PACKAGE_BUILD)
+
+ # Setting flag lists to avoid polluting CMAKE_CXX_FLAGS.
+ # PUBLIC_HELIB_CXX_FLAGS will be exported to the installed target.
+-set(PRIVATE_HELIB_CXX_FLAGS "-march=${TARGET_ARCHITECTURE}")
+ set(PUBLIC_HELIB_CXX_FLAGS "")
+ # Add extra checks during build
+ if (PEDANTIC_BUILD)