aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorSergei Kolobov <sergei@FreeBSD.org>2004-03-08 23:43:20 +0000
committerSergei Kolobov <sergei@FreeBSD.org>2004-03-08 23:43:20 +0000
commit12203ab0c403b16d65291db35517a08849ce6510 (patch)
tree595323d89b8eb000c29303e3d856435d37c86128 /security
parent1335fcecbec9e16f883953f019b57564a36d5877 (diff)
downloadports-12203ab0c403b16d65291db35517a08849ce6510.tar.gz
ports-12203ab0c403b16d65291db35517a08849ce6510.zip
- Update to 1.0.8
- Always depend on libtasn1 and opencdk - Add libgcrypt-devel and libgpg-error dependencies - Add explicit USE_ICONV and USE_GETTEXT to properly register shared library dependencies - Add CONFLICTS to prevent installation over gnutls-devel
Notes
Notes: svn path=/head/; revision=103354
Diffstat (limited to 'security')
-rw-r--r--security/gnutls/Makefile28
-rw-r--r--security/gnutls/distinfo6
-rw-r--r--security/gnutls/pkg-plist23
3 files changed, 35 insertions, 22 deletions
diff --git a/security/gnutls/Makefile b/security/gnutls/Makefile
index 072f729464c6..8f8c576c9d71 100644
--- a/security/gnutls/Makefile
+++ b/security/gnutls/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gnutls
-PORTVERSION= 0.8.10
-PORTREVISION= 1
+PORTVERSION= 1.0.8
CATEGORIES= security net
MASTER_SITES= ${MASTER_SITE_GNUPG} \
http://www.mirrors.wiretapped.net/security/network-security/gnutls/ \
@@ -18,8 +17,17 @@ MASTER_SITE_SUBDIR= alpha/gnutls
MAINTAINER= sergei@FreeBSD.org
COMMENT= GNU Transport Layer Security library
-LIB_DEPENDS= gcrypt.6:${PORTSDIR}/security/libgcrypt
+LIB_DEPENDS= gcrypt.10:${PORTSDIR}/security/libgcrypt-devel \
+ gpg-error.1:${PORTSDIR}/security/libgpg-error \
+ opencdk.8:${PORTSDIR}/security/opencdk \
+ tasn1.2:${PORTSDIR}/security/libtasn1
+CONFLICTS= gnutls-devel-*
+
+#USE_GPG?= yes
+SIG_SUFFIX= .sig.asc
+USE_ICONV= yes
+USE_GETTEXT= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CPPFLAGS+= -I${LOCALBASE}/include
@@ -28,18 +36,8 @@ CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-included-lzo
-.if defined(WITH_LIBTASN1) || exists(${LOCALBASE}/lib/libtasn1.so.2)
-LIB_DEPENDS+= tasn1.2:${PORTSDIR}/security/libtasn1
-.else
-CONFIGURE_ARGS+= --with-included-libtasn1
-.endif
-
-.if defined(WITH_OPENCDK) || exists(${LOCALBASE}/lib/libopencdk.so.6)
-LIB_DEPENDS+= opencdk.6:${PORTSDIR}/security/opencdk
-.else
-CONFIGURE_ARGS+= --disable-openpgp-authentication
-.endif
-
+MAN1= certtool.1 gnutls-cli.1 gnutls-cli-debug.1 \
+ gnutls-serv.1 gnutls-srpcrypt.1
DOCS= AUTHORS NEWS README THANKS doc/tex/*.ps
EXAMPLES= doc/examples/*.c
diff --git a/security/gnutls/distinfo b/security/gnutls/distinfo
index 606a8d08e784..f150e1e60f90 100644
--- a/security/gnutls/distinfo
+++ b/security/gnutls/distinfo
@@ -1,2 +1,4 @@
-MD5 (gnutls-0.8.10.tar.gz) = 11130b920b1395d03e559beebf6b3c2b
-SIZE (gnutls-0.8.10.tar.gz) = 1040032
+MD5 (gnutls-1.0.8.tar.gz) = 7226b151a390150d02d270f9442e74b5
+SIZE (gnutls-1.0.8.tar.gz) = 1407598
+MD5 (gnutls-1.0.8.tar.gz.sig.asc) = de3cd68923a6a0503840602f43da792e
+SIZE (gnutls-1.0.8.tar.gz.sig.asc) = 392
diff --git a/security/gnutls/pkg-plist b/security/gnutls/pkg-plist
index da6dd05f151f..dbbfe05e3bf7 100644
--- a/security/gnutls/pkg-plist
+++ b/security/gnutls/pkg-plist
@@ -1,4 +1,5 @@
@comment $FreeBSD$
+bin/certtool
bin/gnutls-cli
bin/gnutls-cli-debug
bin/gnutls-serv
@@ -6,20 +7,27 @@ bin/gnutls-srpcrypt
bin/libgnutls-config
bin/libgnutls-extra-config
include/gnutls/compat4.h
+include/gnutls/compat8.h
include/gnutls/extra.h
include/gnutls/gnutls.h
+include/gnutls/openpgp.h
include/gnutls/openssl.h
-@dirrm include/gnutls
+include/gnutls/pkcs12.h
+include/gnutls/x509.h
lib/libgnutls-extra.a
lib/libgnutls-extra.la
lib/libgnutls-extra.so
-lib/libgnutls-extra.so.7
+lib/libgnutls-extra.so.13
+lib/libgnutls-openssl.a
+lib/libgnutls-openssl.la
+lib/libgnutls-openssl.so
+lib/libgnutls-openssl.so.13
lib/libgnutls.a
lib/libgnutls.la
lib/libgnutls.so
-lib/libgnutls.so.7
-share/aclocal/libgnutls.m4
+lib/libgnutls.so.13
share/aclocal/libgnutls-extra.m4
+share/aclocal/libgnutls.m4
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/NEWS
%%PORTDOCS%%%%DOCSDIR%%/README
@@ -28,15 +36,20 @@ share/aclocal/libgnutls-extra.m4
%%PORTDOCS%%%%DOCSDIR%%/gnutls.ps
%%PORTDOCS%%@dirrm %%DOCSDIR%%
%%EXAMPLESDIR%%/ex-alert.c
+%%EXAMPLESDIR%%/ex-cert-select.c
%%EXAMPLESDIR%%/ex-client-resume.c
%%EXAMPLESDIR%%/ex-client-srp.c
%%EXAMPLESDIR%%/ex-client1.c
%%EXAMPLESDIR%%/ex-client2.c
-%%EXAMPLESDIR%%/ex-info.c
+%%EXAMPLESDIR%%/ex-crq.c
%%EXAMPLESDIR%%/ex-pgp-keyserver.c
+%%EXAMPLESDIR%%/ex-pkcs12.c
%%EXAMPLESDIR%%/ex-rfc2818.c
%%EXAMPLESDIR%%/ex-serv-export.c
%%EXAMPLESDIR%%/ex-serv-pgp.c
%%EXAMPLESDIR%%/ex-serv-srp.c
%%EXAMPLESDIR%%/ex-serv1.c
+%%EXAMPLESDIR%%/ex-session-info.c
+%%EXAMPLESDIR%%/ex-x509-info.c
@dirrm %%EXAMPLESDIR%%
+@dirrm include/gnutls