aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorTorsten Zuehlsdorff <tz@FreeBSD.org>2018-10-08 08:52:51 +0000
committerTorsten Zuehlsdorff <tz@FreeBSD.org>2018-10-08 08:52:51 +0000
commit3a5533b48d284380e9a3a97b953e1a555242caf2 (patch)
treeadfd6b20496941d7ab22cbbb81aacdf0db2ffbe3 /security
parentefe5dba5fb2dfc94a3bb101e8b9920b0ab69c2c3 (diff)
downloadports-3a5533b48d284380e9a3a97b953e1a555242caf2.tar.gz
ports-3a5533b48d284380e9a3a97b953e1a555242caf2.zip
Add PHP 7.3 RC2 to the ports-tree.
Notable changes: - Switch from PCRE to PCRE2 - Many modules now require PCRE2 for building - graphics/php73-gd: X11 option is no longer default Changes to Mk/Uses/php.mk approved by ale
Notes
Notes: svn path=/head/; revision=481525
Diffstat (limited to 'security')
-rw-r--r--security/php73-filter/Makefile11
-rw-r--r--security/php73-filter/files/patch-config.m410
-rw-r--r--security/php73-hash/Makefile13
-rw-r--r--security/php73-openssl/Makefile11
-rw-r--r--security/php73-sodium/Makefile11
-rw-r--r--security/php73-sodium/files/patch-config.m417
6 files changed, 73 insertions, 0 deletions
diff --git a/security/php73-filter/Makefile b/security/php73-filter/Makefile
new file mode 100644
index 000000000000..c14ce980bcae
--- /dev/null
+++ b/security/php73-filter/Makefile
@@ -0,0 +1,11 @@
+# $FreeBSD$
+
+CATEGORIES= security
+
+MASTERDIR= ${.CURDIR}/../../lang/php73
+
+PKGNAMESUFFIX= -filter
+
+TEST_TARGET= test
+
+.include "${MASTERDIR}/Makefile"
diff --git a/security/php73-filter/files/patch-config.m4 b/security/php73-filter/files/patch-config.m4
new file mode 100644
index 000000000000..ab64c6c9d5ad
--- /dev/null
+++ b/security/php73-filter/files/patch-config.m4
@@ -0,0 +1,10 @@
+--- config.m4.orig 2009-03-06 08:25:45.000000000 +0100
++++ config.m4 2009-03-06 08:28:10.000000000 +0100
+@@ -32,6 +32,7 @@
+ #endif
+ ],[
+ PHP_PCRE_REGEX=pecl
++ PHP_ADD_INCLUDE($PHP_PCRE_DIR/include)
+ ],[
+ PHP_PCRE_REGEX=no
+ ])
diff --git a/security/php73-hash/Makefile b/security/php73-hash/Makefile
new file mode 100644
index 000000000000..a91f81c34cf1
--- /dev/null
+++ b/security/php73-hash/Makefile
@@ -0,0 +1,13 @@
+# $FreeBSD$
+
+CATEGORIES= security
+
+MASTERDIR= ${.CURDIR}/../../lang/php73
+
+PKGNAMESUFFIX= -hash
+
+TEST_TARGET= test
+
+BROKEN_mips64= fails to compile: KeccakHash.h: No such file or directory
+
+.include "${MASTERDIR}/Makefile"
diff --git a/security/php73-openssl/Makefile b/security/php73-openssl/Makefile
new file mode 100644
index 000000000000..4071e6c65105
--- /dev/null
+++ b/security/php73-openssl/Makefile
@@ -0,0 +1,11 @@
+# $FreeBSD$
+
+CATEGORIES= security
+
+MASTERDIR= ${.CURDIR}/../../lang/php73
+
+PKGNAMESUFFIX= -openssl
+
+TEST_TARGET= test
+
+.include "${MASTERDIR}/Makefile"
diff --git a/security/php73-sodium/Makefile b/security/php73-sodium/Makefile
new file mode 100644
index 000000000000..6b7aa6565b37
--- /dev/null
+++ b/security/php73-sodium/Makefile
@@ -0,0 +1,11 @@
+# $FreeBSD$
+
+CATEGORIES= security
+
+MASTERDIR= ${.CURDIR}/../../lang/php73
+
+PKGNAMESUFFIX= -sodium
+
+TEST_TARGET= test
+
+.include "${MASTERDIR}/Makefile"
diff --git a/security/php73-sodium/files/patch-config.m4 b/security/php73-sodium/files/patch-config.m4
new file mode 100644
index 000000000000..9d328698a487
--- /dev/null
+++ b/security/php73-sodium/files/patch-config.m4
@@ -0,0 +1,17 @@
+--- config.m4.orig 2017-11-03 18:32:08 UTC
++++ config.m4
+@@ -50,14 +50,6 @@ if test "$PHP_SODIUM" != "no"; then
+ PHP_ADD_LIBRARY_WITH_PATH($LIBNAME, $LIBSODIUM_DIR/$PHP_LIBDIR, SODIUM_SHARED_LIBADD)
+ fi
+
+- PHP_CHECK_LIBRARY($LIBNAME,$LIBSYMBOL,
+- [
+- AC_DEFINE(HAVE_LIBSODIUMLIB,1,[ ])
+- ],[
+- AC_MSG_ERROR([wrong libsodium lib version (< 1.0.8) or lib not found])
+- ],[
+- ])
+-
+ PHP_SUBST(SODIUM_SHARED_LIBADD)
+
+ PHP_NEW_EXTENSION(sodium, libsodium.c, $ext_shared)