aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorMichael Landin <mich@FreeBSD.org>2018-04-10 08:53:19 +0000
committerMichael Landin <mich@FreeBSD.org>2018-04-10 08:53:19 +0000
commit3acd30349727fe7130a01e6a2af14558e33ac83d (patch)
tree4b806d48f8c0a403f7b4e432d9e5059a295a61dd /security
parent9697387a8196fef78d6c39950bba92a7d3213e0e (diff)
downloadports-3acd30349727fe7130a01e6a2af14558e33ac83d.tar.gz
ports-3acd30349727fe7130a01e6a2af14558e33ac83d.zip
- fix for mhash exporting defined that normally autotools-private
- Bump portrevision Reviewed by: mat
Notes
Notes: svn path=/head/; revision=466946
Diffstat (limited to 'security')
-rw-r--r--security/mhash/Makefile2
-rw-r--r--security/mhash/files/patch-configure.in10
-rw-r--r--security/mhash/files/patch-include_mutils_config.h.in25
-rw-r--r--security/mhash/files/patch-include_mutils_mhash__config.h.in37
4 files changed, 73 insertions, 1 deletions
diff --git a/security/mhash/Makefile b/security/mhash/Makefile
index 40d966cf9473..9fcf93120380 100644
--- a/security/mhash/Makefile
+++ b/security/mhash/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mhash
PORTVERSION= 0.9.9.9
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= security
MASTER_SITES= SF
diff --git a/security/mhash/files/patch-configure.in b/security/mhash/files/patch-configure.in
new file mode 100644
index 000000000000..c0e5398610ea
--- /dev/null
+++ b/security/mhash/files/patch-configure.in
@@ -0,0 +1,10 @@
+--- configure.in.orig
++++ configure.in
+@@ -6,6 +6,7 @@
+ AM_INIT_AUTOMAKE
+
+ AC_DEFINE([MHASH_VERSION], PROGRAM_VERSION, "MHash Version")
++AC_CONFIG_HEADER([include/mutils/config.h])
+ AC_CONFIG_HEADER([include/mutils/mhash_config.h])
+
+
diff --git a/security/mhash/files/patch-include_mutils_config.h.in b/security/mhash/files/patch-include_mutils_config.h.in
new file mode 100644
index 000000000000..c173dad5b393
--- /dev/null
+++ b/security/mhash/files/patch-include_mutils_config.h.in
@@ -0,0 +1,25 @@
+--- include/mutils/config.h.in.orig
++++ include/mutils/config.h.in
+@@ -0,0 +1,22 @@
++/* Name of package */
++#undef PACKAGE
++
++/* Define to the address where bug reports for this package should be sent. */
++#undef PACKAGE_BUGREPORT
++
++/* Define to the full name of this package. */
++#undef PACKAGE_NAME
++
++/* Define to the full name and version of this package. */
++#undef PACKAGE_STRING
++
++/* Define to the one symbol short name of this package. */
++#undef PACKAGE_TARNAME
++
++/* Define to the version of this package. */
++#undef PACKAGE_VERSION
++
++/* Version number of package */
++#undef VERSION
++
++
diff --git a/security/mhash/files/patch-include_mutils_mhash__config.h.in b/security/mhash/files/patch-include_mutils_mhash__config.h.in
new file mode 100644
index 000000000000..34c3fe95447e
--- /dev/null
+++ b/security/mhash/files/patch-include_mutils_mhash__config.h.in
@@ -0,0 +1,37 @@
+--- include/mutils/mhash_config.h.in.orig
++++ include/mutils/mhash_config.h.in
+@@ -181,24 +181,6 @@
+ /* Define to 1 if your C compiler doesn't accept -c and -o together. */
+ #undef NO_MINUS_C_MINUS_O
+
+-/* Name of package */
+-#undef PACKAGE
+-
+-/* Define to the address where bug reports for this package should be sent. */
+-#undef PACKAGE_BUGREPORT
+-
+-/* Define to the full name of this package. */
+-#undef PACKAGE_NAME
+-
+-/* Define to the full name and version of this package. */
+-#undef PACKAGE_STRING
+-
+-/* Define to the one symbol short name of this package. */
+-#undef PACKAGE_TARNAME
+-
+-/* Define to the version of this package. */
+-#undef PACKAGE_VERSION
+-
+ /* Define to 1 if the C compiler supports function prototypes. */
+ #undef PROTOTYPES
+
+@@ -208,9 +190,6 @@
+ /* dmalloc */
+ #undef USE_DMALLOC
+
+-/* Version number of package */
+-#undef VERSION
+-
+ /* Define if using the dmalloc debugging malloc package */
+ #undef WITH_DMALLOC
+