aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-01-21 16:38:37 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-01-25 17:54:07 +0000
commit40843b1ccb8f70cca82dd115a71a46ae2a97a450 (patch)
treeeab403c2779e9e34988645d31bb779a42ff3be86 /security
parent455187b1323a74758a56578b37760fd554a9144a (diff)
downloadports-40843b1ccb8f70cca82dd115a71a46ae2a97a450.tar.gz
ports-40843b1ccb8f70cca82dd115a71a46ae2a97a450.zip
Mk/Uses/apache.mk: Refactor after removal of older versions
apache22 and apache25 had been removed a long time ago however the apache.mk file has never been refactored and is out of sync from the file Mk/bsd.default-versions.mk. These changes refactors the removals of the older versions. In addition: - Move some keywords like USE_APACHE, USE_APACHE_BUILD, USE_APACHE_RUN from SANITY_DEPRECATED to SANITY_UNSUPPORTED - Remove apache versions from ports Makefiles as currently there is only one available version in the tree. However the version checks are still valid and should work flawlessly whenever a new version is added. For example USES=apache:2.2+ are simply replaced with USES=apache. As currently there are no other versions available for test this could not be checked on it's own ground. - Update FOO_USE=APACHE=yes to FOO_USES=apache - Remove trailing whitespaces Approved by: portmgr Differential Revision: https://reviews.freebsd.org/D38113
Diffstat (limited to 'security')
-rw-r--r--security/maia/Makefile3
-rw-r--r--security/openscep/Makefile2
-rw-r--r--security/shibboleth-sp/Makefile2
3 files changed, 3 insertions, 4 deletions
diff --git a/security/maia/Makefile b/security/maia/Makefile
index 611c4fed77e6..77fecd2366b5 100644
--- a/security/maia/Makefile
+++ b/security/maia/Makefile
@@ -49,7 +49,6 @@ OPTIONS_DEFINE= APACHE LIGHTTPD NGINX WEBHOST MYSQL LOCAL PGSQL \
OPTIONS_DEFAULT= MYSQL CLAMAV DOCS SPAMASSASSIN BDB IPCOUNTRY \
DOMAINKEYS SPF DKIM FILE UNRAR ARJ LHA ARC CAB RPM ZOO
-APACHE_DESC= Use Apache web server
LIGHTTPD_DESC= Use LighTTPD web server
NGINX_DESC= Use Nginx web server
WEBHOST_DESC= PHP, PEAR, etc... for Maia web interface
@@ -98,7 +97,7 @@ USE_RC_SUBR+= maiad
# setting USE_ variables. C'est la vie.
.if ${PORT_OPTIONS:MAPACHE}
-USES+= apache:run,2.4+
+USES+= apache:run
.endif
.if ${PORT_OPTIONS:MWEBHOST}
diff --git a/security/openscep/Makefile b/security/openscep/Makefile
index 1835c7ba6232..67fd39562883 100644
--- a/security/openscep/Makefile
+++ b/security/openscep/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
DEPRECATED= Do not support recent RFC 8894
EXPIRATION_DATE= 2023-03-31
-USES= apache:2.2+ gmake libtool ssl
+USES= apache gmake libtool ssl
BROKEN_SSL= base
BROKEN_SSL_REASON= unexpected type name 'issuer_and_subject_t': expected expression
IGNORE_SSL= libressl libressl-devel
diff --git a/security/shibboleth-sp/Makefile b/security/shibboleth-sp/Makefile
index dd23c4060629..bd8eefe90f85 100644
--- a/security/shibboleth-sp/Makefile
+++ b/security/shibboleth-sp/Makefile
@@ -47,7 +47,7 @@ ODBC_DESC= ODBC database backend - store sessions in a database
FASTCGI_DESC= FastCGI protocol support, e.g. for NGINX
APACHE_DESC= Build Apache module
-APACHE_USES= apache:2.4+
+APACHE_USES= apache
ODBC_CONFIGURE_ENABLE= odbc
ODBC_LIB_DEPENDS= libodbc.so:databases/unixODBC