aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorGabor Kovesdan <gabor@FreeBSD.org>2007-08-04 11:41:30 +0000
committerGabor Kovesdan <gabor@FreeBSD.org>2007-08-04 11:41:30 +0000
commit42542fb07642b8336e808272918f3ae46aa67e0b (patch)
tree98ff235c33c6493aa26457284f122652c38935f7 /security
parent4c9cd257fd4e6eca46807a43e128d298429ee3cd (diff)
downloadports-42542fb07642b8336e808272918f3ae46aa67e0b.tar.gz
ports-42542fb07642b8336e808272918f3ae46aa67e0b.zip
- Remove the DESTDIR modifications from individual ports as we have a new,
fully chrooted DESTDIR, which does not need such any more. Sponsored by: Google Summer of Code 2007 Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=197075
Diffstat (limited to 'security')
-rw-r--r--security/aafid2/Makefile4
-rw-r--r--security/botan/Makefile2
-rw-r--r--security/clamsmtp/Makefile2
-rw-r--r--security/find-zlib/Makefile2
-rw-r--r--security/ipsec-tools/Makefile2
-rw-r--r--security/nikto/Makefile8
-rw-r--r--security/nmap-i18n-man/Makefile4
-rw-r--r--security/nmap/Makefile4
-rw-r--r--security/openssl/Makefile8
-rw-r--r--security/pam_krb5/Makefile2
-rw-r--r--security/py-gnutls/Makefile2
-rw-r--r--security/snort/Makefile2
-rw-r--r--security/vnccrack/Makefile2
13 files changed, 22 insertions, 22 deletions
diff --git a/security/aafid2/Makefile b/security/aafid2/Makefile
index 675ca56bf303..aa61d4871140 100644
--- a/security/aafid2/Makefile
+++ b/security/aafid2/Makefile
@@ -21,7 +21,7 @@ NO_WRKSUBDIR= yes
NO_BUILD= yes
do-install:
- tar -C ${TARGETDIR}/lib -xzf ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}
- ${SH} ${FILESDIR}/post-install ${TARGETDIR}
+ tar -C ${PREFIX}/lib -xzf ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}
+ ${SH} ${FILESDIR}/post-install ${PREFIX}
.include <bsd.port.mk>
diff --git a/security/botan/Makefile b/security/botan/Makefile
index 51a8207da172..550756bcdde3 100644
--- a/security/botan/Makefile
+++ b/security/botan/Makefile
@@ -29,7 +29,7 @@ USE_LDCONFIG= yes
PLIST_SUB= PORTVERSION=${PORTVERSION}
.if !defined(NOPORTDOCS)
-DOCSDIR= ${TARGETDIR}/share/doc/Botan-${PORTVERSION}
+DOCSDIR= ${PREFIX}/share/doc/Botan-${PORTVERSION}
PORTDOCS= *
.endif
diff --git a/security/clamsmtp/Makefile b/security/clamsmtp/Makefile
index 67d3a0f5af8d..979959d51470 100644
--- a/security/clamsmtp/Makefile
+++ b/security/clamsmtp/Makefile
@@ -57,7 +57,7 @@ post-patch:
@${REINPLACE_CMD} -e "s,%%PTHREAD_LIBS%%,${PTHREAD_LIBS}," ${WRKSRC}/configure
post-install:
- @${INSTALL_DATA} ${WRKSRC}/doc/clamsmtpd.conf ${TARGETDIR}/etc/clamsmtpd.conf-sample
+ @${INSTALL_DATA} ${WRKSRC}/doc/clamsmtpd.conf ${PREFIX}/etc/clamsmtpd.conf-sample
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
diff --git a/security/find-zlib/Makefile b/security/find-zlib/Makefile
index 7741375c44a2..acc5e86251b5 100644
--- a/security/find-zlib/Makefile
+++ b/security/find-zlib/Makefile
@@ -21,6 +21,6 @@ NO_BUILD= none
USE_PERL5_RUN= yes
do-install:
- ${INSTALL_SCRIPT} ${DISTDIR}/${DISTNAME} ${TARGETDIR}/bin
+ ${INSTALL_SCRIPT} ${DISTDIR}/${DISTNAME} ${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/security/ipsec-tools/Makefile b/security/ipsec-tools/Makefile
index 767cf78d44f6..0fed3ecbf534 100644
--- a/security/ipsec-tools/Makefile
+++ b/security/ipsec-tools/Makefile
@@ -31,7 +31,7 @@ CONFIGURE_ARGS= --enable-shared --sysconfdir=${PREFIX}/etc/racoon \
--localstatedir=${STATEDIR:S/\/racoon//} \
--with-pkgversion=freebsd-${PORTVERSION}
-STATEDIR= ${DESTDIR}/var/db/racoon
+STATEDIR= /var/db/racoon
SUB_LIST+= STATEDIR=${STATEDIR}
PLIST_SUB+= STATEDIR=${STATEDIR}
diff --git a/security/nikto/Makefile b/security/nikto/Makefile
index 709ab065f94e..2c2fb72aaafe 100644
--- a/security/nikto/Makefile
+++ b/security/nikto/Makefile
@@ -40,7 +40,7 @@ RUN_DEPENEDS+= nmap:${PORTSDIR}/security/nmap
post-patch:
@${REINPLACE_CMD} -e "s|/usr/local/bin/perl|${PERL}|" ${WRKSRC}/nikto.pl
- @${REINPLACE_CMD} -Ee "s,(config.txt),${TARGETDIR}/etc/nikto.conf," ${WRKSRC}/nikto.pl
+ @${REINPLACE_CMD} -Ee "s,(config.txt),${PREFIX}/etc/nikto.conf," ${WRKSRC}/nikto.pl
@${REINPLACE_CMD} -Ee "s|/usr/bin/nmap|${LOCALBASE}/bin/nmap|g" \
-e "s|# (PLUGINDIR=)/usr/local/nikto/plugins|\1${DATADIR}|g" \
${WRKSRC}/config.txt
@@ -51,10 +51,10 @@ post-patch:
@${MV} ${WRKSRC}/docs/${PORTNAME}-${PORTVERSION}.man ${WRKSRC}/docs/${PORTNAME}.1
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/nikto.pl ${TARGETDIR}/bin/nikto
- ${INSTALL_DATA} ${WRKSRC}/config.txt ${TARGETDIR}/etc/nikto.conf.sample
+ ${INSTALL_SCRIPT} ${WRKSRC}/nikto.pl ${PREFIX}/bin/nikto
+ ${INSTALL_DATA} ${WRKSRC}/config.txt ${PREFIX}/etc/nikto.conf.sample
[ -f ${PREFIX}/etc/nikto.conf ] || \
- ${INSTALL_DATA} ${WRKSRC}/config.txt ${TARGETDIR}/etc/nikto.conf
+ ${INSTALL_DATA} ${WRKSRC}/config.txt ${PREFIX}/etc/nikto.conf
@${MKDIR} ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/plugins/LW.pm ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/plugins/*.db ${DATADIR}
diff --git a/security/nmap-i18n-man/Makefile b/security/nmap-i18n-man/Makefile
index 73da3c42c87e..a4c6d1a17351 100644
--- a/security/nmap-i18n-man/Makefile
+++ b/security/nmap-i18n-man/Makefile
@@ -88,10 +88,10 @@ do-install:
lang="`expr $${token} : '\([^=]*\)'`"; \
locale="`expr $${token} : '.*=\([^=]*\)'`"; \
charset="`expr $${locale} : '[^.]*\.\([^.]*\)'`"; \
- ${MKDIR} ${DESTDIR}${MAN1PREFIX}/man/$${locale}/man1; \
+ ${MKDIR} ${MAN1PREFIX}/man/$${locale}/man1; \
${ECHO_CMD} Installing man/$${locale}/man1/nmap.1; \
${INSTALL_MAN} ${WRKSRC}/nmap-$${lang}.1.$${charset} \
- ${DESTDIR}${MAN1PREFIX}/man/$${locale}/man1/nmap.1; \
+ ${MAN1PREFIX}/man/$${locale}/man1/nmap.1; \
done
.include <bsd.port.post.mk>
diff --git a/security/nmap/Makefile b/security/nmap/Makefile
index f89b0b3fb57d..34b6a211312b 100644
--- a/security/nmap/Makefile
+++ b/security/nmap/Makefile
@@ -53,9 +53,9 @@ post-configure:
post-install:
.ifndef NOPORTDOCS
- @${MKDIR} ${DESTDIR}${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}
@for doc in CHANGELOG HACKING docs/nmap.dtd; do \
- ${INSTALL_DATA} ${WRKSRC}/$${doc} ${DESTDIR}${DOCSDIR}; \
+ ${INSTALL_DATA} ${WRKSRC}/$${doc} ${DOCSDIR}; \
done
.endif
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index 1c5c9a106cd9..b75435afcf13 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -886,7 +886,7 @@ MLINKS+= \
.include <bsd.port.pre.mk>
-OPENSSL_BASE_SONAME!= readlink ${DESTDIR}/usr/lib/libcrypto.so || true
+OPENSSL_BASE_SONAME!= readlink /usr/lib/libcrypto.so || true
OPENSSL_SHLIBVER_BASE= ${OPENSSL_BASE_SONAME:E}
OPENSSL_BASE_SOPATH= ${OPENSSL_BASE_SONAME:H}
@@ -937,7 +937,7 @@ pre-everything::
@${FALSE}
.endif
-.if exists(${DESTDIR}/usr/lib/libcrypto.so.3) && ${OPENSSL_SHLIBVER} != 3
+.if exists(/usr/lib/libcrypto.so.3) && ${OPENSSL_SHLIBVER} != 3
pre-everything::
@${ECHO_CMD} "#"
@${ECHO_CMD} "# this ports conflicts with your base system"
@@ -950,7 +950,7 @@ pre-everything::
BASE_SUFFIX= -overwrite-base
PREFIX= /usr
OPENSSLDIR= /etc/ssl
-MANPREFIX= ${TARGETDIR}/openssl
+MANPREFIX= ${PREFIX}/openssl
PLIST_SUB+= MANDIR=""
PLIST_SUB+= NOBASE="@comment "
.else
@@ -965,7 +965,7 @@ pre-everything::
.endif
OPENSSLDIR= ${PREFIX}/openssl
-MANPREFIX= ${TARGETDIR}
+MANPREFIX= ${PREFIX}
PLIST_SUB+= MANDIR="@comment "
PLIST_SUB+= NOBASE=""
.endif
diff --git a/security/pam_krb5/Makefile b/security/pam_krb5/Makefile
index 682f89ac4b6c..6af133b03531 100644
--- a/security/pam_krb5/Makefile
+++ b/security/pam_krb5/Makefile
@@ -48,7 +48,7 @@ IGNORE= FreeBSD 5.x already ships with its own version of pam_krb5
.endif
MANDIR= ${MANPREFIX}/man
PREFIX= /usr
-MANPREFIX= ${TARGETDIR}/usr/share
+MANPREFIX= /usr/share
MANDIR= ${PREFIX}/share/man
KRB5_DIR?= ${LOCALBASE}
CONFIGURE_ENV= CFLAGS="${CFLAGS}"
diff --git a/security/py-gnutls/Makefile b/security/py-gnutls/Makefile
index e12be8c48367..31ba54b5a7af 100644
--- a/security/py-gnutls/Makefile
+++ b/security/py-gnutls/Makefile
@@ -22,7 +22,7 @@ USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_PKGNAME= python_gnutls
-EXAMPLESDIR= ${TARGETDIR}/share/examples/py-${PORTNAME}
+EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
post-patch:
${REINPLACE_CMD} -e "s|include_dirs=\[\]|include_dirs=\['${LOCALBASE}/include'\]|" ${WRKSRC}/setup.py
diff --git a/security/snort/Makefile b/security/snort/Makefile
index 920e2c581257..0068477b142d 100644
--- a/security/snort/Makefile
+++ b/security/snort/Makefile
@@ -36,7 +36,7 @@ CONFIG_DIR?= ${PREFIX}/etc/snort
CONFIG_FILES= classification.config gen-msg.map generators reference.config \
sid sid-msg.map snort.conf threshold.conf unicode.map
RULES_DIR= ${PREFIX}/etc/snort/rules
-LOGS_DIR= ${DESTDIR}/var/log/snort
+LOGS_DIR= /var/log/snort
MAN8= snort.8
DOCS= RELEASE.NOTES doc/AUTHORS doc/BUGS doc/CREDITS \
diff --git a/security/vnccrack/Makefile b/security/vnccrack/Makefile
index dea019ab37b1..49cedd62d272 100644
--- a/security/vnccrack/Makefile
+++ b/security/vnccrack/Makefile
@@ -22,7 +22,7 @@ USE_OPENSSL= yes
SUB_FILES+= pkg-message
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/vnccrack ${TARGETDIR}/bin/vnccrack
+ @${INSTALL_PROGRAM} ${WRKSRC}/vnccrack ${PREFIX}/bin/vnccrack
post-install:
.if !defined(NOPORTDOCS)