aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2012-08-06 02:57:57 +0000
committerSteve Wills <swills@FreeBSD.org>2012-08-06 02:57:57 +0000
commit4db0c05f208e4f79011d986de20c5ffd13dad742 (patch)
tree325f3fedf2fc46057fe83d482af7e3d378d7a1c9 /security
parentdae082c95897ea9e3bf31e8c00259529958cae4d (diff)
downloadports-4db0c05f208e4f79011d986de20c5ffd13dad742.tar.gz
ports-4db0c05f208e4f79011d986de20c5ffd13dad742.zip
- Copy ruby-hmac to rubygem-hmac for use with ports that depend on the gem
Notes
Notes: svn path=/head/; revision=302143
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/rubygem-hmac/Makefile22
-rw-r--r--security/rubygem-hmac/distinfo2
-rw-r--r--security/rubygem-hmac/pkg-descr10
4 files changed, 35 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 3f19030cc14f..098c25f53b13 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -821,6 +821,7 @@
SUBDIR += rubygem-bcrypt-ruby
SUBDIR += rubygem-ezcrypto
SUBDIR += rubygem-gpgr
+ SUBDIR += rubygem-hmac
SUBDIR += rubygem-net-scp
SUBDIR += rubygem-net-sftp
SUBDIR += rubygem-net-ssh
diff --git a/security/rubygem-hmac/Makefile b/security/rubygem-hmac/Makefile
new file mode 100644
index 000000000000..09d82eec6d8b
--- /dev/null
+++ b/security/rubygem-hmac/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: ruby-hmac
+# Date created: 20 February 2002
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hmac
+PORTVERSION= 0.4.0
+CATEGORIES= security ruby
+MASTER_SITES= RG
+DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= ruby@freebsd.org
+COMMENT= A Ruby library which implements the HMAC algorithm
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+GEM_NAME= ${DISTNAME}
+
+.include <bsd.port.mk>
diff --git a/security/rubygem-hmac/distinfo b/security/rubygem-hmac/distinfo
new file mode 100644
index 000000000000..511d212d0fe6
--- /dev/null
+++ b/security/rubygem-hmac/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/ruby-hmac-0.4.0.gem) = a4245ecf2cfb2036975b63dc37d41426727d8449617ff45daf0b3be402a9fe07
+SIZE (rubygem/ruby-hmac-0.4.0.gem) = 7168
diff --git a/security/rubygem-hmac/pkg-descr b/security/rubygem-hmac/pkg-descr
new file mode 100644
index 000000000000..122a341a4140
--- /dev/null
+++ b/security/rubygem-hmac/pkg-descr
@@ -0,0 +1,10 @@
+ruby-hmac: HMAC for Ruby
+
+This module provides a common interface to HMAC functionality. HMAC
+is a kind of "Message Authentication Code" (MAC) algorithm which
+standard is documented in RFC2104. Namely, a MAC provides a way to
+check the integrity of information transmitted over or stored in an
+unreliable medium, based on a secret key.
+
+Author: Daiki Ueno <ueno@unixuser.org>
+WWW: http://deisui.org/~ueno/ruby/hmac.html