aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-03-07 13:49:59 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-03-07 13:49:59 +0000
commit54d0ea9212c722546681438bab0a797a235b79be (patch)
treec84de131c0589433dd5e495f007ef528e154452a /security
parenta0b54d6290a7767862e670d1e6558c3d8912c147 (diff)
downloadports-54d0ea9212c722546681438bab0a797a235b79be.tar.gz
ports-54d0ea9212c722546681438bab0a797a235b79be.zip
py-bcrypt is a Python wrapper of OpenBSDs Blowfish password hashing code,
as described in A Future-Adaptable Password Scheme by Niels Provos and David Mazières. WWW: http://www.mindrot.org/projects/py-bcrypt/
Notes
Notes: svn path=/head/; revision=186805
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/py-bcrypt/Makefile25
-rw-r--r--security/py-bcrypt/distinfo3
-rw-r--r--security/py-bcrypt/pkg-descr5
-rw-r--r--security/py-bcrypt/pkg-plist7
5 files changed, 41 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 01a268cfb5d9..b0a62bf0d37b 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -577,6 +577,7 @@
SUBDIR += pwauth
SUBDIR += pwman
SUBDIR += pxytest
+ SUBDIR += py-bcrypt
SUBDIR += py-cerealizer
SUBDIR += py-clamav
SUBDIR += py-crack
diff --git a/security/py-bcrypt/Makefile b/security/py-bcrypt/Makefile
new file mode 100644
index 000000000000..4d85b47fe9af
--- /dev/null
+++ b/security/py-bcrypt/Makefile
@@ -0,0 +1,25 @@
+# ex:ts=8
+# Ports collection makefile for: py-bcrypt
+# Date created: 07 maerch, 2007
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bcrypt
+PORTVERSION= 0.1
+CATEGORIES= security python
+MASTER_SITES= http://www.mindrot.org/files/py-bcrypt/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= py-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= Python bcrypt module
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+
+CFLAGS+= -I${LOCALBASE}/include
+MAKE_ENV= "LDFLAGS=-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/security/py-bcrypt/distinfo b/security/py-bcrypt/distinfo
new file mode 100644
index 000000000000..bb6e245ec6f2
--- /dev/null
+++ b/security/py-bcrypt/distinfo
@@ -0,0 +1,3 @@
+MD5 (py-bcrypt-0.1.tar.gz) = de80dbc79943fba1228bb5a1c2ddb773
+SHA256 (py-bcrypt-0.1.tar.gz) = c556244fd09398d3e40437c01f90f68f6aa58284db63aa73d20eed7acca4ceba
+SIZE (py-bcrypt-0.1.tar.gz) = 16863
diff --git a/security/py-bcrypt/pkg-descr b/security/py-bcrypt/pkg-descr
new file mode 100644
index 000000000000..09b777931c09
--- /dev/null
+++ b/security/py-bcrypt/pkg-descr
@@ -0,0 +1,5 @@
+py-bcrypt is a Python wrapper of OpenBSDs Blowfish password hashing code,
+as described in A Future-Adaptable Password Scheme by Niels Provos and
+David Mazières.
+
+WWW: http://www.mindrot.org/projects/py-bcrypt/
diff --git a/security/py-bcrypt/pkg-plist b/security/py-bcrypt/pkg-plist
new file mode 100644
index 000000000000..a7e008a28044
--- /dev/null
+++ b/security/py-bcrypt/pkg-plist
@@ -0,0 +1,7 @@
+%%PYTHON_SITELIBDIR%%/bcrypt/__init__.py
+%%PYTHON_SITELIBDIR%%/bcrypt/__init__.pyc
+%%PYTHON_SITELIBDIR%%/bcrypt/__init__.pyo
+%%PYTHON_SITELIBDIR%%/bcrypt/_bcrypt.so
+@dirrm %%PYTHON_SITELIBDIR%%/bcrypt
+@dirrm %%PYTHON_SITELIBDIR%%
+@dirrm %%PYTHON_LIBDIR%%