aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-05-26 12:50:40 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-05-26 12:50:40 +0000
commit5743712b3dfcfacb272cb7492a82c59a5b460847 (patch)
tree00c970bcb909a3394bb57c821fd8330ca2421162 /security
parent05e980f565333e9d634ba0706053b2471b3518ce (diff)
downloadports-5743712b3dfcfacb272cb7492a82c59a5b460847.tar.gz
ports-5743712b3dfcfacb272cb7492a82c59a5b460847.zip
- Convert gmake, bzip2 to USES
Approved by: portmgr
Notes
Notes: svn path=/head/; revision=355321
Diffstat (limited to 'security')
-rw-r--r--security/aide/Makefile3
-rw-r--r--security/clamsmtp/Makefile2
-rw-r--r--security/courierpassd/Makefile2
-rw-r--r--security/doscan/Makefile2
-rw-r--r--security/fwbuilder/Makefile2
-rw-r--r--security/gpasman/Makefile2
-rw-r--r--security/libprelude/Makefile3
-rw-r--r--security/libpreludedb/Makefile3
-rw-r--r--security/libtomcrypt/Makefile4
-rw-r--r--security/lsh/Makefile2
-rw-r--r--security/matrixssl/Makefile2
-rw-r--r--security/mosref/Makefile2
-rw-r--r--security/openscep/Makefile2
-rw-r--r--security/osslsigncode/Makefile2
-rw-r--r--security/p5-openxpki-client/Makefile3
-rw-r--r--security/p5-openxpki-deployment/Makefile3
-rw-r--r--security/pam_krb5/Makefile3
-rw-r--r--security/pam_ldap/Makefile3
-rw-r--r--security/pam_pgina/Makefile3
-rw-r--r--security/parano/Makefile3
-rw-r--r--security/pft/Makefile2
-rw-r--r--security/prelude-lml/Makefile3
-rw-r--r--security/prelude-manager/Makefile3
-rw-r--r--security/prelude-pflogger/Makefile2
-rw-r--r--security/rats/Makefile2
-rw-r--r--security/samba-virusfilter/Makefile3
-rw-r--r--security/scannedonly/Makefile2
-rw-r--r--security/skipfish/Makefile4
-rw-r--r--security/starttls/Makefile2
-rw-r--r--security/steghide/Makefile3
-rw-r--r--security/xinetd/Makefile2
31 files changed, 33 insertions, 46 deletions
diff --git a/security/aide/Makefile b/security/aide/Makefile
index 241a77983e93..871d4f5d0ae6 100644
--- a/security/aide/Makefile
+++ b/security/aide/Makefile
@@ -13,12 +13,11 @@ MAINTAINER= cy@FreeBSD.org
COMMENT= Replacement and extension for Tripwire
LIB_DEPENDS= mhash.2:${PORTSDIR}/security/mhash
-USES= bison
+USES= bison gmake
NO_STAGE= yes
.include <bsd.port.pre.mk>
-USE_GMAKE= yes
USE_AUTOTOOLS= autoconf
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-mhash \
diff --git a/security/clamsmtp/Makefile b/security/clamsmtp/Makefile
index 0d6f92b6362f..992447d34f02 100644
--- a/security/clamsmtp/Makefile
+++ b/security/clamsmtp/Makefile
@@ -11,7 +11,7 @@ MAINTAINER= clsung@FreeBSD.org
COMMENT= ClamAV anti-virus SMTP Filter
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
USE_RC_SUBR= clamsmtpd
SUB_LIST= CLAMAV_PID_DIR=${CLAMAV_PID_DIR}
SUB_FILES+= pkg-message
diff --git a/security/courierpassd/Makefile b/security/courierpassd/Makefile
index 37e7d3b6a330..9a2ea8555114 100644
--- a/security/courierpassd/Makefile
+++ b/security/courierpassd/Makefile
@@ -14,7 +14,7 @@ BUILD_DEPENDS= courierauthconfig:${PORTSDIR}/security/courier-authlib-base
RUN_DEPENDS= courierauthconfig:${PORTSDIR}/security/courier-authlib-base
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/security/doscan/Makefile b/security/doscan/Makefile
index bd83400361d8..89b7ec88650b 100644
--- a/security/doscan/Makefile
+++ b/security/doscan/Makefile
@@ -13,7 +13,7 @@ COMMENT= Tool to quickly scan your network for machines listening on a TCP port
LIB_DEPENDS= pcre.3:${PORTSDIR}/devel/pcre
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
PORTDOCS= README
MAN1= doscan.1
diff --git a/security/fwbuilder/Makefile b/security/fwbuilder/Makefile
index 77c4ce31a494..82d487ff9988 100644
--- a/security/fwbuilder/Makefile
+++ b/security/fwbuilder/Makefile
@@ -46,7 +46,7 @@ USE_QT4= corelib \
QTDIR?= ${QT_PREFIX}
USE_OPENSSL= yes
-USE_GMAKE= yes
+USES= gmake
USE_AUTOTOOLS= autoconf aclocal libtool
CONFIGURE_SCRIPT= autogen.sh
GNU_CONFIGURE= yes
diff --git a/security/gpasman/Makefile b/security/gpasman/Makefile
index 06b5a8b69d09..11c77fe25259 100644
--- a/security/gpasman/Makefile
+++ b/security/gpasman/Makefile
@@ -11,7 +11,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Password manager that stores password information encrypted
PLIST_FILES= bin/gpasman
-USE_GMAKE= yes
+USES= gmake
USE_GNOME= gtk12
GNU_CONFIGURE= yes
CONFIGURE_ENV= GTKCONFIG="${GTK_CONFIG}"
diff --git a/security/libprelude/Makefile b/security/libprelude/Makefile
index eae537020e34..82aac224cb76 100644
--- a/security/libprelude/Makefile
+++ b/security/libprelude/Makefile
@@ -23,8 +23,7 @@ USE_AUTOTOOLS= libtool libltdl
CONFIGURE_ARGS= --localstatedir=/var \
--enable-gtk-doc=no \
--with-html-dir=${PREFIX}/share/doc
-USE_GMAKE= yes
-USES= pathfix pkgconfig gettext iconv charsetfix
+USES= pathfix pkgconfig gettext iconv charsetfix gmake
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/security/libpreludedb/Makefile b/security/libpreludedb/Makefile
index 051198ae5720..68c6c10fd88a 100644
--- a/security/libpreludedb/Makefile
+++ b/security/libpreludedb/Makefile
@@ -18,10 +18,9 @@ LIB_DEPENDS= gmp:${PORTSDIR}/math/gmp \
nettle:${PORTSDIR}/security/nettle \
p11-kit:${PORTSDIR}/security/p11-kit
-USE_GMAKE= yes
USE_AUTOTOOLS= libltdl
GNU_CONFIGURE= yes
-USES= gettext iconv
+USES= gettext iconv gmake
CONFIGURE_ARGS= --enable-gtk-doc=no
USE_LDCONFIG= yes
diff --git a/security/libtomcrypt/Makefile b/security/libtomcrypt/Makefile
index 4e92961a238f..223eec732296 100644
--- a/security/libtomcrypt/Makefile
+++ b/security/libtomcrypt/Makefile
@@ -15,8 +15,8 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
MAKEFILE= makefile
MAKE_ARGS= DESTDIR="${PREFIX}" LIBPATH="/lib" INCPATH="/include" \
DATAPATH="${DOCSDIR}/pdf"
-USE_BZIP2= yes
-USE_GMAKE= yes
+
+USES= gmake tar:bzip2
ALL_TARGET= library
CFLAGS+= -I${PREFIX}/include
diff --git a/security/lsh/Makefile b/security/lsh/Makefile
index da6d48078f8b..3b0027008af0 100644
--- a/security/lsh/Makefile
+++ b/security/lsh/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= oop:${PORTSDIR}/devel/liboop \
USE_CSTD= c89
GNU_CONFIGURE= yes
USE_XORG= xau
-USE_GMAKE= yes
+USES= yes
INSTALL_TARGET= install
CONFIGURE_ENV= PREFIX="${PREFIX}"
CONFIGURE_ARGS+= --with-include-path=${LOCALBASE}/include
diff --git a/security/matrixssl/Makefile b/security/matrixssl/Makefile
index 0219f951cb62..46bf591f33e0 100644
--- a/security/matrixssl/Makefile
+++ b/security/matrixssl/Makefile
@@ -18,7 +18,7 @@ OPTIONS_DEFINE= DOCS EXAMPLES
WRKSRC= ${WRKDIR}/${DISTNAME}/${PORTNAME}-${PORTVERSION:S/./-/g}-open
-USE_GMAKE= yes
+USES= gmake
MAKE_ARGS= CC="${CC}" DFLAGS="${CFLAGS}" STRIP="${TEST}"
USE_LDCONFIG= yes
diff --git a/security/mosref/Makefile b/security/mosref/Makefile
index d1e652d781ed..803d07c963e2 100644
--- a/security/mosref/Makefile
+++ b/security/mosref/Makefile
@@ -10,7 +10,7 @@ DISTNAME= ${PORTNAME}-2.0-beta3
MAINTAINER= pjdelport@gmail.com
COMMENT= Secure remote execution framework using a compact Scheme-influenced VM
-USE_GMAKE= yes
+USES= gmake
PORTDOCS= ChangeLog TODO vm-implementation.tex vm-implementation.pdf
diff --git a/security/openscep/Makefile b/security/openscep/Makefile
index 201265af3251..ff07d2108b14 100644
--- a/security/openscep/Makefile
+++ b/security/openscep/Makefile
@@ -16,8 +16,8 @@ USE_OPENSSL= yes
USE_OPENLDAP= yes
USE_APACHE= 22+
GNU_CONFIGURE= yes
-USE_GMAKE= yes
USE_LDCONFIG= yes
+USES= gmake
NO_STAGE= yes
.include <bsd.port.pre.mk>
diff --git a/security/osslsigncode/Makefile b/security/osslsigncode/Makefile
index 7e7d2b1deca0..281952f2dd4f 100644
--- a/security/osslsigncode/Makefile
+++ b/security/osslsigncode/Makefile
@@ -15,7 +15,7 @@ PLIST_FILES= bin/osslsigncode
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
USE_OPENSSL= yes
.if !defined(WITHOUT_CURL)
diff --git a/security/p5-openxpki-client/Makefile b/security/p5-openxpki-client/Makefile
index 0c49b0fb4b29..9c7be8333436 100644
--- a/security/p5-openxpki-client/Makefile
+++ b/security/p5-openxpki-client/Makefile
@@ -16,8 +16,7 @@ BUILD_DEPENDS= \
p5-openxpki>=0:${PORTSDIR}/security/p5-openxpki
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USE_GMAKE= yes
-USES= perl5
+USES= perl5 gmake
USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/security/p5-openxpki-deployment/Makefile b/security/p5-openxpki-deployment/Makefile
index 12cb42d5704e..9436868f86d9 100644
--- a/security/p5-openxpki-deployment/Makefile
+++ b/security/p5-openxpki-deployment/Makefile
@@ -24,8 +24,7 @@ MAN1= openxpki-configure.1 \
openxpki-metaconf.1 \
openxpkiadm.1 \
openxpkictl.1
-USES= perl5
-USE_GMAKE= yes
+USES= perl5 gmake
USE_RC_SUBR= openxpki
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix ${PREFIX}
diff --git a/security/pam_krb5/Makefile b/security/pam_krb5/Makefile
index 599e944e0da5..be87b0bf5709 100644
--- a/security/pam_krb5/Makefile
+++ b/security/pam_krb5/Makefile
@@ -15,9 +15,8 @@ CONFLICTS= pam_krb5-rh-2.*
MAN5= pam_krb5.5
-USES= perl5
+USES= perl5 gmake
GNU_CONFIGURE= yes
-USE_GMAKE= yes
.if defined(KRB5_IMPL) && ${KRB5_IMPL} == heimdal
.if defined(HEIMDAL_HOME)
diff --git a/security/pam_ldap/Makefile b/security/pam_ldap/Makefile
index 34d87d31385b..f4fc94b1f399 100644
--- a/security/pam_ldap/Makefile
+++ b/security/pam_ldap/Makefile
@@ -12,10 +12,9 @@ DISTNAME= pam_ldap-${PORTVERSION:S/.//g}
MAINTAINER= marcus@FreeBSD.org
COMMENT= A pam module for authenticating with LDAP
-USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_OPENLDAP= yes
-USES= perl5
+USES= perl5 gmake
USE_PERL5= build
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/.//g}
PAM_LDAP_CONF?= ldap.conf
diff --git a/security/pam_pgina/Makefile b/security/pam_pgina/Makefile
index d40b22a784a1..e49ad6285c90 100644
--- a/security/pam_pgina/Makefile
+++ b/security/pam_pgina/Makefile
@@ -13,10 +13,9 @@ COMMENT= Daemon for allowing a pGina plugin to authenticate against Unix PAM
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/GPL
-USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_OPENSSL= yes
-USES= perl5
+USES= perl5 gmake
USE_PERL5= run
NO_STAGE= yes
diff --git a/security/parano/Makefile b/security/parano/Makefile
index 56103bbb8235..05c22d22513f 100644
--- a/security/parano/Makefile
+++ b/security/parano/Makefile
@@ -12,8 +12,7 @@ COMMENT= A Gnome program to deal with hashfiles
USE_GNOME= pygnome2
USE_PYTHON= yes
-USES= gettext
-USE_GMAKE= yes
+USES= gettext gmake
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/security/pft/Makefile b/security/pft/Makefile
index e98c237703ea..7abc61989c60 100644
--- a/security/pft/Makefile
+++ b/security/pft/Makefile
@@ -13,7 +13,7 @@ COMMENT= Printer Job Language library and tool
NO_WRKSUBDIR= yes
ALL_TARGET= libPJL.a
-USE_GMAKE= yes
+USES= gmake
PLIST_FILES= bin/pft lib/libPJL.a
diff --git a/security/prelude-lml/Makefile b/security/prelude-lml/Makefile
index 4a7eb27d13be..d53c2e542e99 100644
--- a/security/prelude-lml/Makefile
+++ b/security/prelude-lml/Makefile
@@ -20,12 +20,11 @@ LIB_DEPENDS= libicuuc.so:${PORTSDIR}/devel/icu \
libnettle.so:${PORTSDIR}/security/nettle \
libp11-kit.so:${PORTSDIR}/security/p11-kit
-USE_GMAKE= yes
USE_AUTOTOOLS= libltdl
GNU_CONFIGURE= yes
USE_RC_SUBR= prelude-lml
CONFIGURE_ARGS+= --with-html-dir=${PREFIX}/share/doc
-USES= charsetfix gettext iconv pkgconfig
+USES= charsetfix gettext iconv pkgconfig gmake
OPTIONS_DEFINE= FAM
FAM_CONFIGURE_ENABLE= fam
diff --git a/security/prelude-manager/Makefile b/security/prelude-manager/Makefile
index 0aed5c93bc97..10003f37d5f5 100644
--- a/security/prelude-manager/Makefile
+++ b/security/prelude-manager/Makefile
@@ -19,8 +19,7 @@ LIB_DEPENDS= gmp:${PORTSDIR}/math/gmp \
nettle:${PORTSDIR}/security/nettle \
p11-kit:${PORTSDIR}/security/p11-kit
-USES= pkgconfig gettext iconv
-USE_GMAKE= yes
+USES= pkgconfig gettext iconv gmake
USE_AUTOTOOLS= libltdl
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/security/prelude-pflogger/Makefile b/security/prelude-pflogger/Makefile
index ba45785642e0..c0d79a0c8323 100644
--- a/security/prelude-pflogger/Makefile
+++ b/security/prelude-pflogger/Makefile
@@ -12,7 +12,7 @@ COMMENT= Prelude-PFlogger Listens at OpenBSD PF
LIB_DEPENDS+= prelude:${PORTSDIR}/security/libprelude
-USE_GMAKE= yes
+USES= gmake
GNU_CONFIGURE= yes
USE_RC_SUBR= prelude-pflogger
diff --git a/security/rats/Makefile b/security/rats/Makefile
index b1dad7ec79be..51b96328b9dd 100644
--- a/security/rats/Makefile
+++ b/security/rats/Makefile
@@ -13,7 +13,7 @@ COMMENT= Source code auditing tool
LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
CONFIGURE_ARGS+=--with-expat-lib=${LOCALBASE}/lib \
--with-expat-include=${LOCALBASE}/include/xml \
--datadir=${DATADIR}
diff --git a/security/samba-virusfilter/Makefile b/security/samba-virusfilter/Makefile
index 5ecd67cc16d6..89f007e6ff94 100644
--- a/security/samba-virusfilter/Makefile
+++ b/security/samba-virusfilter/Makefile
@@ -11,9 +11,8 @@ COMMENT= On-access anti-virus filter for Samba
PATCH_DEPENDS= smbclient:${PORTSDIR}/net/${SAMBA_PORT}
BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/net/${SAMBA_PORT}:configure
-USE_BZIP2= yes
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= tar:bzip2 gmake
ALL_TARGET= # should empty
CONFIGURE_ARGS= --with-samba-source=`cd ${PORTSDIR}/net/${SAMBA_PORT}; ${MAKE} -VWRKSRC` \
--with-clamd=${PREFIX}/sbin/clamd --with-savdid=${PREFIX}/bin/savdid
diff --git a/security/scannedonly/Makefile b/security/scannedonly/Makefile
index 52b1fda70bee..22e19f589c07 100644
--- a/security/scannedonly/Makefile
+++ b/security/scannedonly/Makefile
@@ -18,7 +18,7 @@ BUILD_DEPENDS+= smbd:${PORTSDIR}/${SAMBA_PORT}
CONFIGURE_ARGS+=--with-samba-vfs-dir=${PREFIX}/lib/samba/vfs
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
USE_RC_SUBR= ${PORTNAME}
LDFLAGS+= -L${LOCALBASE}/lib
CFLAGS+= -I${LOCALBASE}/include
diff --git a/security/skipfish/Makefile b/security/skipfish/Makefile
index 38b69d5f666b..d1b720a7929e 100644
--- a/security/skipfish/Makefile
+++ b/security/skipfish/Makefile
@@ -16,8 +16,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= idn:${PORTSDIR}/dns/libidn \
pcre:${PORTSDIR}/devel/pcre
-
-USE_GMAKE= yes
+
+USES= gmake
SUB_FILES= pkg-message
.if !defined(NOPORTDOCS)
diff --git a/security/starttls/Makefile b/security/starttls/Makefile
index 630785c5f717..653bfd235fb3 100644
--- a/security/starttls/Makefile
+++ b/security/starttls/Makefile
@@ -10,7 +10,7 @@ MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Simple wrapper program for STARTTLS on ${EMACS_PORT_NAME}
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
USE_EMACS= yes
NO_STAGE= yes
diff --git a/security/steghide/Makefile b/security/steghide/Makefile
index 17817a56cd4b..73343916b931 100644
--- a/security/steghide/Makefile
+++ b/security/steghide/Makefile
@@ -17,9 +17,8 @@ LIB_DEPENDS= mcrypt.8:${PORTSDIR}/security/libmcrypt \
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= gettext perl5
+USES= gettext perl5 gmake
USE_AUTOTOOLS= libtool
-USE_GMAKE= yes
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib -lintl -lmcrypt"
CPPFLAGS+= ${CFLAGS} -I${LOCALBASE}/include -fpermissive
diff --git a/security/xinetd/Makefile b/security/xinetd/Makefile
index 86933e00bd88..e9b243c06c94 100644
--- a/security/xinetd/Makefile
+++ b/security/xinetd/Makefile
@@ -12,7 +12,7 @@ COMMENT= Replacement for inetd with better control and logging
LICENSE= BSD
-USE_GMAKE= yes
+USES= gmake
GNU_CONFIGURE= yes
USE_RC_SUBR= xinetd
ALL_TARGET= build