aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2015-06-25 05:48:02 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2015-06-25 05:48:02 +0000
commit5f31c6193149ee5d7586dfa6c75e124b30569d95 (patch)
tree1390c1f647e0d89141908388b66e41114b388b23 /security
parent3345a13190f5f398b8a8c74f721932752bd32f03 (diff)
downloadports-5f31c6193149ee5d7586dfa6c75e124b30569d95.tar.gz
ports-5f31c6193149ee5d7586dfa6c75e124b30569d95.zip
security/py-libnacl: Update to 1.4.3
- Update to 1.4.3 - Patch setup.py so test command is supported - Add regression-test target Changes: https://libnacl.readthedocs.org/en/latest/topics/releases/1.4.3.html Based on: PR: 200830 Submitted by: Christer Edwards <christer dot edwards gmail com>
Notes
Notes: svn path=/head/; revision=390533
Diffstat (limited to 'security')
-rw-r--r--security/py-libnacl/Makefile7
-rw-r--r--security/py-libnacl/distinfo4
-rw-r--r--security/py-libnacl/files/patch-setup.py10
3 files changed, 17 insertions, 4 deletions
diff --git a/security/py-libnacl/Makefile b/security/py-libnacl/Makefile
index b27d2680a4a4..540db869e0c9 100644
--- a/security/py-libnacl/Makefile
+++ b/security/py-libnacl/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= libnacl
-PORTVERSION= 1.4.2
-PORTREVISION= 1
+PORTVERSION= 1.4.3
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -19,4 +18,8 @@ LIB_DEPENDS= libsodium.so:${PORTSDIR}/security/libsodium
USES= python
USE_PYTHON= autoplist distutils
+regression-test: build
+ ${TOUCH} ${WRKSRC}/tests/__init__.py
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+
.include <bsd.port.mk>
diff --git a/security/py-libnacl/distinfo b/security/py-libnacl/distinfo
index 52ca49523839..27e48d857d71 100644
--- a/security/py-libnacl/distinfo
+++ b/security/py-libnacl/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libnacl-1.4.2.tar.gz) = 2443c9c8835bc3e337de1ba137fd783a1d73ef3d404966d960255c29910e58cf
-SIZE (libnacl-1.4.2.tar.gz) = 28162
+SHA256 (libnacl-1.4.3.tar.gz) = 873614913c90c4011f791a8fd1448f6bb3ab7dc8cdd329d1baaa65e7e1d1a929
+SIZE (libnacl-1.4.3.tar.gz) = 28777
diff --git a/security/py-libnacl/files/patch-setup.py b/security/py-libnacl/files/patch-setup.py
new file mode 100644
index 000000000000..6e85ddd242e6
--- /dev/null
+++ b/security/py-libnacl/files/patch-setup.py
@@ -0,0 +1,10 @@
+--- setup.py.orig 2015-03-17 16:11:06 UTC
++++ setup.py
+@@ -36,4 +36,6 @@ setup(name=NAME,
+ 'Intended Audience :: Developers',
+ 'Topic :: Security :: Cryptography',
+ ],
+- packages=['libnacl'])
++ packages=['libnacl'],
++ test_suite='tests.runtests.run_suite',
++)